Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-08-06, 12:33 PM   #25
vvb
Registered User
 
Join Date: Dec 2006
Posts: 24
Default Re: FC6 1.0-9629 & 1.0-9631 troubles

UDEV on startup says that all is [OK].
I've use Fedora Core since its 3 version (FC3, FC4, FC5, now FC6). I've use it on my work and at home. In ALL of this versions was everything correct with my videocard. May be not at the first startup (as far as I remember default kernel in FC5 don't allow to load nonGPG modules)...
Anyway, on my work I have GeForce4 MX440 and Fedora Core 5. All latest nVidia drivers are work well with it.
At home I have GeForce 6600 GT. There is no change in hardware last month (since I've reinstall system. NOTE: I've reinstall it COMPLETELY, including format of HDD). Everyday I install all updates of FC, which concern system things.

And one more thing. On Changelog of kernel 2.6.16-35 there is interesting information:

Commit: 193d2e39e134fb04211b77e0eb0ac3f8315a5967
Author: Nathan Lynch <ntl@pobox.com> Wed, 29 Nov 2006 12:17:37 +0100

nvidiafb: fix unreachable code in nv10GetConfig

Fix binary/logical operator typo which leads to unreachable code. Noticed
while looking at other issues; I don't have the relevant hardware to test
this.

Signed-off-by: Nathan Lynch <ntl@pobox.com>
Signed-off-by: Adrian Bunk <bunk@stusta.de>

May be in 2.6.18 kernels not everything is perfect also?
So, I'll wait for next releases of NVIDIA_drivers/FC_kernels. I think problem not in my hardware. It works for me for several years without troubles.
vvb is offline   Reply With Quote
Old 12-08-06, 12:44 PM   #26
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: FC6 1.0-9629 & 1.0-9631 troubles

nvidiafb is a framebuffer driver and has no association with the nvidia X driver.

Please post the output from dmesg after X fails to start.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 12-08-06, 12:57 PM   #27
vvb
Registered User
 
Join Date: Dec 2006
Posts: 24
Default Re: FC6 1.0-9629 & 1.0-9631 troubles

Here it is.
Attached Files
File Type: log 1.log (21.1 KB, 81 views)
vvb is offline   Reply With Quote
Old 12-08-06, 01:02 PM   #28
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: FC6 1.0-9629 & 1.0-9631 troubles

There's nothing appearing in dmesg to indicate why the nvidia devices aren't getting created. Have you adjusted syslogd in any way to suppress logging?
netllama is offline   Reply With Quote
Old 12-08-06, 01:30 PM   #29
vvb
Registered User
 
Join Date: Dec 2006
Posts: 24
Default Re: FC6 1.0-9629 & 1.0-9631 troubles

[vvb@vampire dvd]$ ps -eaf | grep syslog
root 2114 1 0 21:12 ? 00:00:00 syslogd -m 0
vvb 8655 8276 0 22:22 pts/5 00:00:00 grep syslog
[vvb@vampire dvd]$

If you mean this...
vvb is offline   Reply With Quote
Old 12-08-06, 03:55 PM   #30
iki488
Registered User
 
Join Date: Dec 2006
Posts: 13
Default Re: FC6 1.0-9629 & 1.0-9631 troubles

I think that it can be a conflict between nvidia kernel module and nvidia X module (which probably haven't the same version).

try
Code:
sudo nano /lib/modules/2.6.17-10-generic/modules.alias
(change 2.6.17-10-generic with your kernel version)

and comment these two lines :
Code:
alias char-major-195-* nvidia_legacy
alias pci:v000010DEd*sv*sd*bc03sc00i00* nvidia_legacy
hope it will work
iki488 is offline   Reply With Quote
Old 12-09-06, 12:10 AM   #31
vvb
Registered User
 
Join Date: Dec 2006
Posts: 24
Default Re: FC6 1.0-9629 & 1.0-9631 troubles

I've searched all directory /lib/modules for string "nvidia_legacy" and found none in ANY of files.

In file /lib/modules/2.6.18-1.2849.fc6/modules.alias I have followinf information about nvidia:

alias char-major-195-* nvidia
alias pci:v000010DEd*sv*sd*bc03sc02i00* nvidia
alias pci:v000010DEd*sv*sd*bc03sc00i00* nvidia
alias pci:v000010DEd*sv*sd*bc03sc*i* nvidiafb

and that's all...
vvb is offline   Reply With Quote
Old 12-09-06, 05:12 AM   #32
iki488
Registered User
 
Join Date: Dec 2006
Posts: 13
Default Re: FC6 1.0-9629 & 1.0-9631 troubles

uh ... maybe it's different from ubuntu :s:s

sorry guy

but try to search about module conflict in FC6 ! I think this is the problem
iki488 is offline   Reply With Quote

Old 12-09-06, 01:23 PM   #33
vvb
Registered User
 
Join Date: Dec 2006
Posts: 24
Default Re: FC6 1.0-9629 & 1.0-9631 troubles

Strange thing. After I've install rpms from livna repository...

kmod-nvidia-1.0.9631-1.2.6.18_1.2849.fc6.i686.rpm
xorg-x11-drv-nvidia-1.0.9631-1.lvn6.i386.rpm

...all seems to be working -- glxgears, Desktop Effects, and wine applications. All seems to be perfect. All is working... But from sources same version doesn't run. 8-(

[After several hours of checking...]
Sorry. Some wine applications starts, but some wine applications still hangs (they works on FC5). So, nothing changes. 8-(

Last edited by vvb; 12-09-06 at 02:22 PM.
vvb is offline   Reply With Quote
Old 12-09-06, 02:38 PM   #34
vvb
Registered User
 
Join Date: Dec 2006
Posts: 24
Default Re: FC6 1.0-9629 & 1.0-9631 troubles

So. Finally. Almost resolve problem.
Wine applications crashes becouse of SCIM. After reomving all SCIM rpms from system and rebooting, all wine applications now runs well.
One more thing is left.
I can't run compiled driver still (but downloaded from livna works perfectly).
vvb is offline   Reply With Quote
Old 12-24-06, 07:19 AM   #35
vvb
Registered User
 
Join Date: Dec 2006
Posts: 24
Default Re: FC6 1.0-9629 & 1.0-9631 troubles

I've download nvidia-x11-drv-1.0.9746-1.i386.rpm from freshrpms (zod.freshrpms.net).
After install I still can't start X:
(EE) Failed to load module "wfb" (module does not exist, 0)
NVIDIA: could not open the device file /dev/nvidiactl (No such file or directory).
(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module! Please ensure
(EE) NVIDIA(0): that there is a supported NVIDIA GPU in this system, and
(EE) NVIDIA(0): that the NVIDIA device files have been created properly.
(EE) NVIDIA(0): Please consult the NVIDIA README for details.
(EE) NVIDIA(0): *** Aborting ***
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found
XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0"
after 0 requests (0 known processed) with 0 events remaining.

Bug-report in attach.

So, only driver works is xorg-x11-drv-nvidia-1.0.9631-1.lvn6.i386.rpm from Livna repository...
Attached Files
File Type: log nvidia-bug-report.log (97.4 KB, 95 views)
vvb is offline   Reply With Quote
Old 12-30-06, 08:37 AM   #36
vvb
Registered User
 
Join Date: Dec 2006
Posts: 24
Default Re: FC6 1.0-9629 & 1.0-9631 troubles

I've try with kernel 2.6.18-1.2868.fc6.
Still can't start X with driver compiled from sources.
And with livna rpm (xorg-x11-drv-nvidia-1.0.9631-1.lvn6 & kmod-nvidia-1.0.9631-1.2.6.18_1.2868.fc6) I can start X.
But at this time a picture slightly differs.
"glxinfo" says:
name of display: :0.0
NVIDIA: could not open the device file /dev/nvidiactl (Permission denied).
NVIDIA: Direct rendering failed; attempting indirect rendering.
display: :0 screen: 0
direct rendering: No

And glxgears says that it can't open /dev/nvidiactl, BUT!
The gears spinning with high speed (FPS=5000, and it is normal for my system).

And quake3 under wine works perfectly.

I wonder how Livna guys can compile driver...
vvb is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:57 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.