Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-02-06, 03:56 PM   #1
rdeeming
Registered User
 
Join Date: Nov 2004
Posts: 15
Default Sharp Aquos EDID FX 5700LE

How do I obtain a better resolution than 1280x720, 720p according to the display, on a Sharp AQUOS 52 LCD that is supposedly 1080p capable?

Display - Sharp LC-52D62U
Graphics Card - NVIDIA FX5700LE
Connection - NVIDIA DVI -> Yamaha HTR-5990 HDMI -> Sharp Input 4 HDMI

The 1280x720 resolution size displays a bit larger than the display screen. This started me down the path of trying to understand why in the very least the display of 1360x768, as listed in the Sharp operation manual, can not be achieved.

There appears to be no EDID information being passed to NVIDIA regarding this resolution. Am I correct on this? Does this mean this is a problem on Sharp's end? If so is there a way around that?

I have tried serveral xorg.conf modelines and NVIDIA specific Options to get around this but simply come up short or right back to 1280x720.

Thanks for any help or thoughts on this.
Attached Files
File Type: gz nvidia-bug-report.log.gz (39.6 KB, 139 views)
rdeeming is offline   Reply With Quote
Old 12-02-06, 10:37 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Sharp Aquos EDID FX 5700LE

You are correct, there are no 1080p or 1360x768 modes in the EDID. This looks like a problem that Sharp would need to correct.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 12-03-06, 03:41 AM   #3
pe1chl
Registered User
 
Join Date: Aug 2003
Posts: 1,026
Default Re: Sharp Aquos EDID FX 5700LE

Have you tried using the 8776 driver?
There seem to be some errors in the EDID of the TV, like that it returns the native resolution of 1280x720 while it actually is 1366x768, but in the log we also see the usual rejects by the driver "because Mode is too large for DFP Native Resolution".
This is a goof-up from NVIDIA. They assume that modes larger than the DFP size should be rejected, even when those timings are handed by the panel itself over EDID.
This is a mistake, because when using a scaling HD TV like this, you may want to use it with a 1920x1080 mode even though the native size is smaller. The TV will scale down that higher resolution to the panel size. No reason to reject or disallow that. But the 9xxx driver blindly rejects this.
(this also causes problems for panels for which the native resolution in the EDID does not match the real value, in which your TV is not alone)

But there also appears to be some confusion about the interlaced mode. Not the first time I have seen this, either.
The 1920x1080 interlaced mode either is calculated as having half the resolution (1920x540) or double the scan frequency (120 Hz) or both. So that ends up getting rejected a well.
Try the following 1080i modeline:

Modeline "1920x1080i60" 74.25 1920 1976 2008 2200 1080 1083 1085 1125 +Hsync +Vsync Interlace

This will give the correct timing. It works on my system. But you will need to go back to an older driver or turn off the agressive checking, as it will be rejected by the new driver as being "too large" as well.
pe1chl is offline   Reply With Quote
Old 12-03-06, 03:07 PM   #4
rdeeming
Registered User
 
Join Date: Nov 2004
Posts: 15
Default Re: Sharp Aquos EDID FX 5700LE

Thanks so much for the info,

Doing some reading there is a good reason why Sharp does not give any EDID information about the resolution 1360x768. Because it can't.
http://en.wikipedia.org/wiki/EDID See Limitations.

So, I need to get the NVIDIA driver so it does not use the EDID data and refer to a specific mode line. I have not been successful.

Is there a different NVIDIA Option that I should be using?

Generated by http://xtiming.sourceforge.net/cgi-bin/xtiming.pl

Modeline "1360x768@59" 82.78 1360 1392 1704 1736 768 783 791 807

(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "UseEDID" "FALSE"
(**) NVIDIA(0): Enabling RENDER acceleration
(**) NVIDIA(0): Ignoring EDIDs
(II) NVIDIA(GPU-0): Not probing EDID on DFP-0.
(II) NVIDIA(0): NVIDIA GPU GeForce FX 5700LE at PCI:1:0:0 (GPU-0)
(--) NVIDIA(0): Memory: 131072 kBytes
(--) NVIDIA(0): VideoBIOS: 04.36.20.31.00
(II) NVIDIA(0): Detected AGP rate: 8X
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce FX 5700LE at
(--) NVIDIA(0): PCI:1:0:0:
(--) NVIDIA(0): DFP-0
(--) NVIDIA(0): DFP-0: 150.0 MHz maximum pixel clock
(--) NVIDIA(0): DFP-0: Internal Single Link TMDS
(II) NVIDIA(0): Assigned Display Device: DFP-0
(WW) NVIDIA(0): No valid modes for "1360x768@59"; removing.
(WW) NVIDIA(0):
(WW) NVIDIA(0): Unable to validate any modes; falling back to the default mode
(WW) NVIDIA(0): "nvidia-auto-select".
(WW) NVIDIA(0):
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0): "nvidia-auto-select"
(II) NVIDIA(0): Virtual screen size determined to be 640 x 480
(WW) NVIDIA(0): Unable to get display device DFP-0's EDID; cannot compute DPI
(WW) NVIDIA(0): from DFP-0's EDID.
(==) NVIDIA(0): DPI set to (75, 75); computed from built-in default
rdeeming is offline   Reply With Quote
Old 12-03-06, 03:19 PM   #5
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Sharp Aquos EDID FX 5700LE

I'd need to see a bug report to comment on this.
netllama is offline   Reply With Quote
Old 12-03-06, 03:46 PM   #6
rdeeming
Registered User
 
Join Date: Nov 2004
Posts: 15
Default Re: Sharp Aquos EDID FX 5700LE

Good idea asking for that. Looking at the report it was obvious NVIDIA was rejecting the modeling because it was not at 60Hz Ver. So I added a 60Hz to the xorg.conf file on this run. Now it looks like the driver is still doing some type of check and saying the mode is to large for the DFP.
Attached Files
File Type: gz nvidia-bug-report.log.gz (35.6 KB, 95 views)
rdeeming is offline   Reply With Quote
Old 12-03-06, 05:41 PM   #7
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Sharp Aquos EDID FX 5700LE

You could try setting the following option in xorg.conf:
Option "ModeValidation" "AllowNon60HzDFPModes"
netllama is offline   Reply With Quote
Old 12-03-06, 11:08 PM   #8
rdeeming
Registered User
 
Join Date: Nov 2004
Posts: 15
Default Re: Sharp Aquos EDID FX 5700LE

Same result.
Attached Files
File Type: gz nvidia-bug-report.log.gz (38.1 KB, 109 views)
rdeeming is offline   Reply With Quote

Old 12-03-06, 11:16 PM   #9
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Sharp Aquos EDID FX 5700LE

Try adding NoDFPNativeResolutionCheck.
netllama is offline   Reply With Quote
Old 12-04-06, 12:25 AM   #10
rdeeming
Registered User
 
Join Date: Nov 2004
Posts: 15
Default Re: Sharp Aquos EDID FX 5700LE

NVIDIA does not seem to pay any attention to this paramerter NoDFPNativeResolutionCheck?
Attached Files
File Type: gz nvidia-bug-report.log.gz (38.3 KB, 117 views)
rdeeming is offline   Reply With Quote
Old 12-04-06, 02:55 AM   #11
pe1chl
Registered User
 
Join Date: Aug 2003
Posts: 1,026
Default Re: Sharp Aquos EDID FX 5700LE

Your modelines are incorrect. Pixel clock is 74.25 for HDTV, like in the modeline I gave you.
pe1chl is offline   Reply With Quote
Old 12-04-06, 10:04 AM   #12
rdeeming
Registered User
 
Join Date: Nov 2004
Posts: 15
Default Re: Sharp Aquos EDID FX 5700LE

xorg.conf
Option "ModeValidation" "NoEdidModes, AllowNon60HzDFPModes, NoDFPNativeResolutionCheck"

9629 the modeline was regected.

8776 does not know about NoDFPNativeResolutionCheck
(WW) NVIDIA(0): Unrecognized ModeValidation token
(WW) NVIDIA(0): "NoDFPNativeResolutionCheck"; ignoring.
...
(WW) NVIDIA(0): Mode "1920x1080i60" is too large for Sharp HDMI (DFP-0);
(WW) NVIDIA(0): discarding.

What Option are you using to get NVIDIA to not check your custom modeline?

Thanks,
Rich
rdeeming is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:01 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.