Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-16-06, 02:03 PM   #1
Joeyp2100
Registered User
 
Join Date: Dec 2006
Posts: 4
Default Monitor doesnt like Drivers

Im on Kubuntu 6.10, GE Force 7800 GT, with a 19" Viewsonic E-90, with current Nvidia Drivers.

I installed the current Nvidia drivers and got no 3d Rendering. So I went into Xorg.conf and changed all NV to Nvidia. When I do so and restart X I am stuck w/ a 800x600 Resolution with no way of changing it. So I try to change the Monitor to a Plug N' Play and restart X. It gives me the Resolution I want, but I lose 3d Rendering and in Xorg.conf all Nvidia becomes NV. So I looked around, and tried to add the resolutions to Xorg.conf with now luck.

Here is my Xorg.conf file:

Section "ServerLayout"
Identifier "Default Layout"
screen 0 "Default Screen" 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "stylus" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"
EndSection

Section "Files"

# path to defoma fonts
FontPath "/usr/share/X11/fonts/misc"
FontPath "/usr/share/X11/fonts/cyrillic"
FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/X11/fonts/Type1"
FontPath "/usr/share/X11/fonts/100dpi"
FontPath "/usr/share/X11/fonts/75dpi"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "extmod"
Load "freetype"
Load "int10"
Load "type1"
Load "vbe"
# load "GLcore"
load "glx"
load "GLcore"
load "v4l"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
option "CoreKeyboard"
option "XkbRules" "xorg"
option "XkbModel" "pc105"
option "XkbLayout" "us"
option "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
option "CorePointer"
option "Device" "/dev/input/mice"
option "Protocol" "ExplorerPS/2"
option "ZAxisMapping" "4 5"
option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"

# /dev/input/event
# for USB
Identifier "stylus"
Driver "wacom"
option "Device" "/dev/wacom"# Change to
option "Type" "stylus"
option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"

# /dev/input/event
# for USB
Identifier "eraser"
Driver "wacom"
option "Device" "/dev/wacom"# Change to
option "Type" "eraser"
option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"

# /dev/input/event
# for USB
Identifier "cursor"
Driver "wacom"
option "Device" "/dev/wacom"# Change to
option "Type" "cursor"
option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "Monitor"
identifier "E90-3"
vendorname "ViewSonic"
modelname "ViewSonic E90"
HorizSync 30-87
VertRefresh 50-180
modeline "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
modeline "640x480@72" 31.5 640 664 704 832 480 489 491 520 -vsync -hsync
modeline "640x480@75" 31.5 640 656 720 840 480 481 484 500 -vsync -hsync
modeline "640x480@85" 36.0 640 696 752 832 480 481 484 509 -vsync -hsync
modeline "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
modeline "800x600@72" 50.0 800 856 976 1040 600 637 643 666 +hsync +vsync
modeline "800x600@75" 49.5 800 816 896 1056 600 601 604 625 +hsync +vsync
modeline "800x600@85" 56.3 800 832 896 1048 600 601 604 631 +hsync +vsync
modeline "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
modeline "832x624@75" 57.284 832 864 928 1152 624 625 628 667 -vsync -hsync
modeline "1024x768@85" 94.5 1024 1072 1168 1376 768 769 772 808 +hsync +vsync
modeline "1024x768@75" 78.8 1024 1040 1136 1312 768 769 772 800 +hsync +vsync
modeline "1024x768@70" 75.0 1024 1048 1184 1328 768 771 777 806 -vsync -hsync
modeline "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
modeline "1024x768@43" 44.9 1024 1032 1208 1264 768 768 776 817 +hsync interlace +vsync
modeline "1152x864@75" 108.0 1152 1216 1344 1600 864 865 868 900 +hsync +vsync
modeline "1152x768@54" 64.995 1152 1178 1314 1472 768 771 777 806 +hsync +vsync
modeline "1280x854" 80.0 1280 1309 1460 1636 854 857 864 896 +hsync +vsync
modeline "1280x1024@75" 135.0 1280 1296 1440 1688 1024 1025 1028 1066 +hsync +vsync
modeline "1280x960@60" 102.1 1280 1360 1496 1712 960 961 964 994 -hsync +vsync
modeline "1280x960@85" 148.5 1280 1344 1504 1728 960 961 964 1011 +hsync +vsync
modeline "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
modeline "1280x960@75" 129.86 1280 1368 1504 1728 960 961 964 1002 -hsync +vsync
modeline "1400x1050@60" 122.61 1400 1488 1640 1880 1050 1051 1054 1087 -hsync +vsync
modeline "1400x1050@75" 155.85 1400 1496 1648 1896 1050 1051 1054 1096 -hsync +vsync
modeline "1600x1200@65" 175.5 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
modeline "1600x1200@60" 162.0 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
modeline "1600x1200@70" 189.0 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
modeline "1792x1344@60" 204.8 1792 1920 2120 2448 1344 1345 1348 1394 -hsync +vsync
modeline "1856x1392@60" 218.3 1856 1952 2176 2528 1392 1393 1396 1439 -hsync +vsync
gamma 1.0
EndSection

Section "Monitor"
identifier "monitor1"
vendorname "ViewSonic"
modelname "ViewSonic E90"
HorizSync 30-87
VertRefresh 50-180
modeline "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
modeline "640x480@72" 31.5 640 664 704 832 480 489 491 520 -vsync -hsync
modeline "640x480@75" 31.5 640 656 720 840 480 481 484 500 -vsync -hsync
modeline "640x480@85" 36.0 640 696 752 832 480 481 484 509 -vsync -hsync
modeline "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
modeline "800x600@72" 50.0 800 856 976 1040 600 637 643 666 +hsync +vsync
modeline "800x600@75" 49.5 800 816 896 1056 600 601 604 625 +hsync +vsync
modeline "800x600@85" 56.3 800 832 896 1048 600 601 604 631 +hsync +vsync
modeline "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
modeline "832x624@75" 57.284 832 864 928 1152 624 625 628 667 -vsync -hsync
modeline "1024x768@85" 94.5 1024 1072 1168 1376 768 769 772 808 +hsync +vsync
modeline "1024x768@75" 78.8 1024 1040 1136 1312 768 769 772 800 +hsync +vsync
modeline "1024x768@70" 75.0 1024 1048 1184 1328 768 771 777 806 -vsync -hsync
modeline "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
modeline "1024x768@43" 44.9 1024 1032 1208 1264 768 768 776 817 +hsync interlace +vsync
modeline "1152x864@75" 108.0 1152 1216 1344 1600 864 865 868 900 +hsync +vsync
modeline "1152x768@54" 64.995 1152 1178 1314 1472 768 771 777 806 +hsync +vsync
modeline "1280x854" 80.0 1280 1309 1460 1636 854 857 864 896 +hsync +vsync
modeline "1280x1024@75" 135.0 1280 1296 1440 1688 1024 1025 1028 1066 +hsync +vsync
modeline "1280x960@60" 102.1 1280 1360 1496 1712 960 961 964 994 -hsync +vsync
modeline "1280x960@85" 148.5 1280 1344 1504 1728 960 961 964 1011 +hsync +vsync
modeline "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
modeline "1280x960@75" 129.86 1280 1368 1504 1728 960 961 964 1002 -hsync +vsync
modeline "1400x1050@60" 122.61 1400 1488 1640 1880 1050 1051 1054 1087 -hsync +vsync
modeline "1400x1050@75" 155.85 1400 1496 1648 1896 1050 1051 1054 1096 -hsync +vsync
modeline "1600x1200@65" 175.5 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
modeline "1600x1200@60" 162.0 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
modeline "1600x1200@70" 189.0 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
modeline "1792x1344@60" 204.8 1792 1920 2120 2448 1344 1345 1348 1394 -hsync +vsync
modeline "1856x1392@60" 218.3 1856 1952 2176 2528 1392 1393 1396 1439 -hsync +vsync
gamma 1.0
EndSection

Section "Device"
identifier "NVIDIA Corporation NVIDIA Default Card"
boardname "NVIDIA GeForce 7 Series"
busid "PCI:1:0:0"
driver "nv"
screen 0
vendorname "NVIDIA"
EndSection

Section "Device"
identifier "device1"
boardname "NVIDIA GeForce 7 Series"
busid "PCI:1:0:0"
driver "nv"
screen 1
vendorname "NVIDIA"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "NVIDIA Corporation NVIDIA Default Card"
Monitor "E90-3"
DefaultDepth 24
SubSection "Display"
depth 24
modes "800x600@56" "800x600@72" "640x480@85" "800x600@75" "640x480@75" "800x600@85" "640x480@72" "800x600@60" "640x480@60" "832x624@75" "1024x768@85" "1024x768@75" "1024x768@70" "1024x768@60" "1024x768@43" "1152x864@75" "1152x768@54" "1280x854" "1280x1024@75" "1280x960@60" "1280x960@85" "1280x1024@60" "1280x960@75" "1400x1050@60" "1400x1050@75" "1600x1200@65" "1600x1200@60" "1600x1200@70" "1792x1344@60" "1856x1392@60"
EndSubSection
EndSection

Section "Screen"
#
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultDepth 24
SubSection "Display"
depth 24
modes "640x480@60" "640x480@72" "640x480@75" "640x480@85" "800x600@56" "800x600@72" "800x600@75" "800x600@85" "800x600@60" "832x624@75" "1024x768@85" "1024x768@75" "1024x768@70" "1024x768@60" "1024x768@43" "1152x864@75" "1152x768@54" "1280x854" "1280x1024@75" "1280x960@60" "1280x960@85" "1280x1024@60" "1280x960@75" "1400x1050@60" "1400x1050@75" "1600x1200@65" "1600x1200@60" "1600x1200@70" "1792x1344@60" "1856x1392@60"
EndSubSection
EndSection

Section "ServerFlags"
EndSection

Thanks in advance.

Last edited by Joeyp2100; 12-16-06 at 11:31 PM.
Joeyp2100 is offline   Reply With Quote
Old 12-16-06, 10:19 PM   #2
whig
550Ti
 
Join Date: Jan 2004
Location: New Zealand
Posts: 854
Default Re: Monitor doesnt like Drivers

I don't know kubuntu but I would delete all the modelines and refresh settings and let the nvidia driver decide what's best. Look in the X log (/var/log/) to see why things don't work.
whig is offline   Reply With Quote
Old 12-16-06, 11:32 PM   #3
Joeyp2100
Registered User
 
Join Date: Dec 2006
Posts: 4
Default Re: Monitor doesnt like Drivers

Here is what I get from the xorg log.

(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce 7800 GT at PCI:1:0:0:
(--) NVIDIA(0): @@@ (CRT-0)
(--) NVIDIA(0): @@@ (CRT-0): 400.0 MHz maximum pixel clock
(II) NVIDIA(0): Assigned Display Device: CRT-0
(WW) NVIDIA(0): No valid modes for "800x600@56"; removing.
(WW) NVIDIA(0): No valid modes for "800x600@72"; removing.
(WW) NVIDIA(0): No valid modes for "640x480@85"; removing.
(WW) NVIDIA(0): No valid modes for "800x600@75"; removing.
(WW) NVIDIA(0): No valid modes for "640x480@75"; removing.
(WW) NVIDIA(0): No valid modes for "800x600@85"; removing.
(WW) NVIDIA(0): No valid modes for "640x480@72"; removing.
(WW) NVIDIA(0): No valid modes for "800x600@60"; removing.
(WW) NVIDIA(0): No valid modes for "640x480@60"; removing.
(WW) NVIDIA(0): No valid modes for "832x624@75"; removing.
(WW) NVIDIA(0): No valid modes for "1024x768@85"; removing.
(WW) NVIDIA(0): No valid modes for "1024x768@75"; removing.
(WW) NVIDIA(0): No valid modes for "1024x768@70"; removing.
(WW) NVIDIA(0): No valid modes for "1024x768@60"; removing.
(WW) NVIDIA(0): No valid modes for "1024x768@43"; removing.
(WW) NVIDIA(0): No valid modes for "1152x864@75"; removing.
(WW) NVIDIA(0): No valid modes for "1152x768@54"; removing.
(WW) NVIDIA(0): No valid modes for "1280x854"; removing.
(WW) NVIDIA(0): No valid modes for "1280x1024@75"; removing.
(WW) NVIDIA(0): No valid modes for "1280x960@60"; removing.
(WW) NVIDIA(0): No valid modes for "1280x960@85"; removing.
(WW) NVIDIA(0): No valid modes for "1280x1024@60"; removing.
(WW) NVIDIA(0): No valid modes for "1280x960@75"; removing.
(WW) NVIDIA(0): No valid modes for "1400x1050@60"; removing.
(WW) NVIDIA(0): No valid modes for "1400x1050@75"; removing.
(WW) NVIDIA(0): No valid modes for "1600x1200@65"; removing.
(WW) NVIDIA(0): No valid modes for "1600x1200@60"; removing.
(WW) NVIDIA(0): No valid modes for "1792x1344@60"; removing.
(WW) NVIDIA(0): No valid modes for "1856x1392@60"; removing.
(WW) NVIDIA(0):
(WW) NVIDIA(0): Unable to validate any modes; falling back to the default mode
(WW) NVIDIA(0): "nvidia-auto-select".
(WW) NVIDIA(0):


So basically, If I have nvidia drivers working it gives me this - If I use nv driver it works fine... but w/o rendering.

Last edited by Joeyp2100; 12-16-06 at 11:52 PM.
Joeyp2100 is offline   Reply With Quote
Old 12-17-06, 03:53 AM   #4
whig
550Ti
 
Join Date: Jan 2004
Location: New Zealand
Posts: 854
Default Re: Monitor doesnt like Drivers

Need to see more of the log, post a bug report please.
whig is offline   Reply With Quote
Old 12-17-06, 11:53 AM   #5
mariojrrr
Registered User
 
Join Date: Dec 2006
Posts: 9
Default Re: Monitor doesnt like Drivers

I have the sama problem.. but here only work 640x480 in suse 10.2... i tried all

my topic with everything: http://forums.suselinuxsupport.de/in...5&#entry205805
mariojrrr is offline   Reply With Quote
Old 12-17-06, 01:26 PM   #6
Joeyp2100
Registered User
 
Join Date: Dec 2006
Posts: 4
Default Re: Monitor doesnt like Drivers

Here is my entire Xorg.log:

Xorg.0.log
Joeyp2100 is offline   Reply With Quote
Old 12-17-06, 01:41 PM   #7
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Monitor doesnt like Drivers

Joeyp2100,
Your CRT is returning bogus information for its EDID. Unless this problem wasn't present in an older driver, this looks like a hardware issue. You can workaround it by setting UseEDID to false in xorg.conf. See the driver README for more details.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 12-17-06, 03:09 PM   #8
Joeyp2100
Registered User
 
Join Date: Dec 2006
Posts: 4
Default Re: Monitor doesnt like Drivers

Add the EDID False line and it all seems to work now.

Thanks a ton!
Joeyp2100 is offline   Reply With Quote

Old 12-18-06, 06:36 PM   #9
NotASquirrel
Certified Non-Sciuridae
 
Join Date: Dec 2006
Location: Generally, not in trees.
Posts: 13
Default Re: Monitor doesnt like Drivers

I have a problem very similar to this one, including the linux distribution (Ubuntu 6.10) and the lines in xorg.log. (Ubuntu is Kubuntu but with gnome not kde for anyone who doesn't do ubuntu)

Only difference is that my screen does not come up at all, it just makes the login screen sound when a corrupted screen appears. If I type my username and password I get the successful login sound as if the desktop has come up.

Also, If I plug an external monitor into the vga port before starting gdm, everything works fine including acceleration and the laptop screen stays blank. After doing this I tried to use the Nvidia X Server Settings tool to enable the second display but it didn't lead to any success.


I have tried disabling EDID but that did not help at all. Xorg seems to be invalidating ALL modes. Maybe I am not turning off EDIDs properly? I have been putting this exact line at the end of the Screen section in xorg.conf:

Option "UseEDID" "FALSE"

I have also tried the following other lines with no success:

# Option "ModeValidation" "NoEdidModes"
# Option "UseEdidFreqs" "FALSE"

# Option "ModeValidation" "DFP-0: NoMaxPClkCheck, NoEdidMaxPClkCheck"
# Option "ModeValidation" "DFP-0: NoDFPNativeResolutionCheck, AllowNon60HzDFPModes, NoMaxPClkCheck, NoEdidMaxPclkCheck, NoHorizSyncCheck, NoVertRefreshCheck, NoWidthAlignmentCheck, NoVirtualSizeCheck, NoEdidModes, NoMaxSizeCheck, NoVesaModes"
EndSection


The other difference between my problem and Joeyp2100, is when my modes are invalidated they look like this:
(WW) NVIDIA(0): No valid modes for "1024x768"; removing.

... while Joeyp2100's look like this:
(WW) NVIDIA(0): No valid modes for "1024x768@60"; removing.

so, no @refreshrate in mine.


If this is a completely different problem, I can move it to a new thread, but it sounded really close.

Thanks for any help in advance!
NotASquirrel is offline   Reply With Quote
Old 12-19-06, 12:38 AM   #10
NotASquirrel
Certified Non-Sciuridae
 
Join Date: Dec 2006
Location: Generally, not in trees.
Posts: 13
Default Re: Monitor doesnt like Drivers

My non-working xorg.conf follows below and is significantly different from the other guy's. Is that a Gnome vs. KDE thing or is my xorg.conf bad?

Specifically mine does not seem to specify refresh rates anywhere:

Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder3)  Wed Nov  1 19:47:17 PST 2006

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
    Identifier     "Default Layout"
    Screen         "Default Screen" 0 0
    InputDevice    "Generic Keyboard"
    InputDevice    "Configured Mouse"
    InputDevice    "stylus" "SendCoreEvents"
    InputDevice    "cursor" "SendCoreEvents"
    InputDevice    "eraser" "SendCoreEvents"
EndSection

Section "Files"

        # path to defoma fonts
    FontPath        "/usr/share/X11/fonts/misc"
    FontPath        "/usr/share/X11/fonts/cyrillic"
    FontPath        "/usr/share/X11/fonts/100dpi/:unscaled"
    FontPath        "/usr/share/X11/fonts/75dpi/:unscaled"
    FontPath        "/usr/share/X11/fonts/Type1"
    FontPath        "/usr/share/X11/fonts/100dpi"
    FontPath        "/usr/share/X11/fonts/75dpi"
    FontPath        "/usr/share/fonts/X11/misc"
    FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
    Load           "i2c"
    Load           "bitmap"
    Load           "ddc"
    Load           "extmod"
    Load           "freetype"
    Load           "glx"
    Load           "int10"
    Load           "type1"
    Load           "vbe"
EndSection

Section "InputDevice"
    Identifier     "Generic Keyboard"
    Driver         "kbd"
    Option         "CoreKeyboard"
    Option         "XkbRules" "xorg"
    Option         "XkbModel" "pc105"
    Option         "XkbLayout" "us"
    Option         "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
    Identifier     "Configured Mouse"
    Driver         "mouse"
    Option         "CorePointer"
    Option         "Device" "/dev/input/mice"
    Option         "Protocol" "ExplorerPS/2"
    Option         "ZAxisMapping" "4 5"
    Option         "Emulate3Buttons" "false"
EndSection

Section "InputDevice"

                                                      # /dev/input/event
                                                      # for USB
    Identifier     "stylus"
    Driver         "wacom"
    Option         "Device" "/dev/wacom"          # Change to 
    Option         "Type" "stylus"
#  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"

                                                      # /dev/input/event
                                                      # for USB
    Identifier     "eraser"
    Driver         "wacom"
    Option         "Device" "/dev/wacom"          # Change to 
    Option         "Type" "eraser"
#  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"

                                                      # /dev/input/event
                                                      # for USB
    Identifier     "cursor"
    Driver         "wacom"
    Option         "Device" "/dev/wacom"          # Change to 
    Option         "Type" "cursor"
#  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"
  Driver        "synaptics"
  Identifier    "TouchPad"
  Option        "Device"        "/dev/input/mouse0"
  Option        "Protocol"      "audo-dev"
  Option       "LeftEdge"      "1700"
  Option       "RightEdge"     "5400"
  Option       "TopEdge"       "1700"
  Option       "BottomEdge"    "4200"
  Option       "FingerLow"     "25"
  Option       "FingerHigh"    "30"
  Option       "MaxTapTime"    "75"
  Option       "MaxTapMove"    "2"
  Option       "TapButton1"    "0"
  Option       "TapButton2"    "2"
  Option       "TapButton3"    "2"
  Option       "VertScrollDelta" "100"
  Option       "MinSpeed"      "0.09"
  Option       "MaxSpeed"      "0.18"
  Option       "AccelFactor"   "0.0015"
  Option       "SHMConfig"     "on"
  Option       "UpDownScrolling"  "on"
  Option       "UpDownRepeat"  "off"
  Option       "ScrollButtonRepeat"  "300"
  Option       "HorizTwoFingerScroll"  "on"
EndSection


Section "Monitor"
    Identifier     "Generic Monitor"
    HorizSync       28.0 - 84.0
    VertRefresh     43.0 - 60.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "NVIDIA Corporation NV36 [GeForce FX Go5700]"
    Driver         "nvidia"
    Option         "LoadKernelModule"  "FALSE"
EndSection

Section "Screen"
    Identifier     "Default Screen"
    Device         "NVIDIA Corporation NV36 [GeForce FX Go5700]"
    Monitor        "Generic Monitor"
    DefaultDepth    24
    SubSection     "Display"
        Depth       1
        Modes      "1680x1050" "1280x854" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       4
        Modes      "1680x1050" "1280x854" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       8
        Modes      "1680x1050" "1280x854" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       15
        Modes      "1680x1050" "1280x854" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       16
        Modes      "1680x1050" "1280x854" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       24
        Modes      "1680x1050" "1280x854" "1024x768" "800x600" "640x480"
    EndSubSection
#    Option         "ModeValidation" "NoEdidModes"
#    Option         "UseEdidFreqs" "FALSE"
#    Option         "UseEDID" "FALSE"
#    Option         "ModeValidation"  "DFP-0: NoMaxPClkCheck, NoEdidMaxPClkCheck"
    Option         "ModeValidation"  "DFP-0: NoDFPNativeResolutionCheck, AllowNon60HzDFPModes, NoMaxPClkCheck, NoEdidMaxPclkCheck, NoHorizSyncCheck, NoVertRefreshCheck, NoWidthAlignmentCheck, NoVirtualSizeCheck, NoEdidModes, NoMaxSizeCheck, NoVesaModes"
EndSection

Section "Extensions"
    Option         "Composite" "Disable"
EndSection
To make my system work perfectly again, I pretty much just have to replace 'nvidia' with 'nv' in the device driver section.
NotASquirrel is offline   Reply With Quote
Old 12-19-06, 03:21 AM   #11
whig
550Ti
 
Join Date: Jan 2004
Location: New Zealand
Posts: 854
Default Re: Monitor doesnt like Drivers

Why aren't you loading the kernel module? That option is more trouble than it's worth.
whig is offline   Reply With Quote
Old 12-19-06, 03:08 PM   #12
NotASquirrel
Certified Non-Sciuridae
 
Join Date: Dec 2006
Location: Generally, not in trees.
Posts: 13
Default Re: Monitor doesnt like Drivers

Sorry, I should have removed my random flailing of options when I posted my xorg.conf. Turning off loading of the driver module was the last thing I tried before giving up and posting here. Before that was disabling nearly every type of resolution validation, and before that were combinations of the different ways of disabling EDIDs.
NotASquirrel is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
NVIDIA Drivers Receive Windows 8 Certification News Archived News Items 0 06-01-12 06:30 AM
Enhance Max Payne 3, Diablo III with GeForce R300 Drivers News Archived News Items 0 05-22-12 07:30 PM
Creative drivers ? SparrowHawk General Hardware 39 11-18-02 09:03 AM
Radeon 9700 not all that? sancheuz Other Desktop Graphics Cards 200 10-12-02 10:31 PM
Nvidia Stereo Drivers Soudontsay NVIDIA Windows Graphics Drivers 2 08-26-02 11:48 AM

All times are GMT -5. The time now is 09:47 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.