Go Back   nV News Forums > Linux Support Forums > General Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-11-06, 07:23 AM   #1
jszhang3
Registered User
 
Join Date: Dec 2006
Posts: 3
Default MCP61 forcedeth and sata_nv interrupt problem

I've got an MCP61P chipset on my asus M2N-MX motherboard
kernel version 2.6.19 from www.kernel.org
The problem is:
when I download data from Internet at high speed(2.XXM/s), sometimes I will get the fllowing message:
"Message from syslogd
Disabling IRQ #16"

then I cannot write file to disk or read file from disk and the harddisk led is always shining. When disk is idle for a long time(half an hour or longer), the problem will also be produced.
I remeber some messages be printed by the kernel
nv_nic_irq +0x1/0x168[fordeth]
nv_generic_interrupte +0x0/0x7a[sata_nv]

IRQ #16 no one care
...

If I insert a pci nic card and rm forcedeth.ko in /lib/modules/2.6.19/..../drivers/net/
everything is ok.


my /proc/interrupt:
CPU0
0: 1009519 IO-APIC-edge timer
1: 12426 IO-APIC-edge i8042
8: 1 IO-APIC-edge rtc
9: 0 IO-APIC-fasteoi acpi
12: 4 IO-APIC-edge i8042
14: 77 IO-APIC-edge libata
15: 0 IO-APIC-edge libata
16: 10273 IO-APIC-fasteoi libata, HDA Intel
17: 247421 IO-APIC-fasteoi libata, nvidia
18: 2 IO-APIC-fasteoi ehci_hcd:usb1
19: 56661 IO-APIC-fasteoi ohci_hcd:usb2
20: 32912 IO-APIC-fasteoi eth0
NMI: 0
LOC: 1009512
ERR: 1
MIS: 0

my lspci is
00:00.0 RAM memory: nVidia Corporation MCP61 Memory Controller (rev a1)
00:01.0 ISA bridge: nVidia Corporation MCP61 LPC Bridge (rev a2)
00:01.1 SMBus: nVidia Corporation MCP61 SMBus (rev a2)
00:01.2 RAM memory: nVidia Corporation MCP61 Memory Controller (rev a2)
00:01.3 Co-processor: nVidia Corporation MCP61 SMU (rev a2)
00:02.0 USB Controller: nVidia Corporation MCP61 USB Controller (rev a2)
00:02.1 USB Controller: nVidia Corporation MCP61 USB Controller (rev a2)
00:04.0 PCI bridge: nVidia Corporation MCP61 PCI bridge (rev a1)
00:05.0 Audio device: nVidia Corporation MCP61 High Definition Audio (rev a2)
00:06.0 IDE interface: nVidia Corporation MCP61 IDE (rev a2)
00:07.0 Bridge: nVidia Corporation MCP61 Ethernet (rev a2)
00:08.0 IDE interface: nVidia Corporation MCP61 SATA Controller (rev a2)
00:08.1 IDE interface: nVidia Corporation MCP61 SATA Controller (rev a2)
00:09.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0b.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0c.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0d.0 VGA compatible controller: nVidia Corporation Unknown device 03d0 (rev a2)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:06.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)


BTW:Audio driver hd_intel emits a high pitch noise and any attempt to change the volume will kill the sound output even my second sound card will refuse to play after that.
jszhang3 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:32 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.