Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-29-07, 02:29 AM   #1
HectorC
Registered User
 
Join Date: Jan 2007
Posts: 1
Default problems installing with kernel 2.6.20

Hi,

I'm trying to install the Nvidia driver using Ingo Molnar's RT kernel 2.6.20 on Fedora Core 6, but the installation fails with this error:

WARNING: could not find /home/hector/Desktop/NV/usr/src/nv/.nv-kernel.o.cmd
for /home/hector/Desktop/NV/usr/src/nv/nv-kernel.o
FATAL: modpost: GPL-incompatible module nvidia.ko uses GPL-only symbol 'paravirt_ops'
make[3]: *** [__modpost] Error 1
make[2]: *** [modules] Error 2
NVIDIA: left KBUILD.
nvidia.ko failed to build!
make[1]: *** [module] Error 1
make: *** [module] Error 2

I found a solution posted here for similar error but related to symbol lockdep_init_map.

Any ideas?

Thanks!

Hector
HectorC is offline   Reply With Quote
Old 01-29-07, 04:34 PM   #2
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: problems installing with kernel 2.6.20

My guess is this problem is specific to kernels built with CONFIG_PARAVIRT; please also see http://www.nvnews.net/vbulletin/show....php?p=1146334.
zander is offline   Reply With Quote
Old 02-05-07, 12:46 PM   #3
robert14
Registered User
 
Join Date: Feb 2007
Posts: 5
Default Re: problems installing with kernel 2.6.20

I don't understand the posts in the link i've disabeled CONFIG_HIGHPTE in .config and recompiled my kernel but it didn't seem to fix the problem for me

Ubuntu 6.10
kernel 2.6.20
robert14 is offline   Reply With Quote
Old 02-05-07, 02:08 PM   #4
isbarak
Registered User
 
Join Date: Jul 2005
Posts: 1
Default Re: problems installing with kernel 2.6.20

Quote:
Originally Posted by robert14
I don't understand the posts in the link i've disabeled CONFIG_HIGHPTE in .config and recompiled my kernel but it didn't seem to fix the problem for me

Ubuntu 6.10
kernel 2.6.20
I am running suse 10.2 and had the same video problem.
I removed the nvidia X11 driver and now it runs justt fine.

My question is, how to resume nvidia 3d accelerator?
isbarak is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Random crashes, NVRM Xid messages Iesos NVIDIA Linux 90 10-04-12 03:27 AM
Corrupted display - 302.17 - Dell Precision T3500 (G98 [Quadro NVS 295]) gbailey NVIDIA Linux 1 06-27-12 10:24 AM
UEFI+Nvidia - NVRM: Your system is not currently configured to drive a VGA console... interzoneuk NVIDIA Linux 0 06-26-12 04:51 AM
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 11:04 AM
Crash when logout from X TGL NVIDIA Linux 10 09-13-02 08:22 PM

All times are GMT -5. The time now is 04:40 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.