Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-23-06, 05:37 PM   #1
rik0
Registered User
 
Join Date: Dec 2006
Posts: 19
Default Gentoo, nvidia-drivers 9631 - X fatal server error

Hi there.

So I recently had to change my motherboard (the old one died), before that I has X working fine with the nvidia graphics card and video playback (via mythtv was pretty smooth). But since I upgraded the motherboard the video was very jerky.. (dropping frames) I decided that perhaps the kernel and nvidia drivers needed re-installing and upgrading. Now I seem to be in a world of pain.

I'm using a Gentoo system which is now running 2.6.19-gentoo-r2 and the nvidia drivers currently installed are 1.0-9631.

I have tried a bunch of things (reinstalling + upgrading as mentioned above) + stopping the on-board graphics card driver from loading... but all to no avail


when i run startx with a log level of 5 I get

-----
(II) Initializing extension GLX

Backtrace:
0: X(xf86SigHandler+0x88) [0x80c6cd8]

Fatal server error:
Caught signal 11. Server aborting
--------


Anyone help me out.. I seem to normally be able to stumble through the linux issues like this but this time I've exhasted most things

x config in

/root/xorg.conf

bug-report attached


Thanks in advance

Rik0
Attached Files
File Type: log nvidia-bug-report.log (96.3 KB, 129 views)
rik0 is offline   Reply With Quote
Old 12-23-06, 05:57 PM   #2
chunkey
#!/?*
 
Join Date: Oct 2004
Posts: 662
Default Re: Gentoo, nvidia-drivers 9631 - X fatal server error

Code:
-----
 (II) Initializing extension GLX
 
 Backtrace:
 0: X(xf86SigHandler+0x88) [0x80c6cd8]
I don't have gentoo, but I seen something like this before.
When I was "playing" with libnvidia-tls.so.1. AFAIK NVIDIA ships two different versions, one for older glibcs and one for newer.... maybe you got the wrong one.

Oh, and:
Code:
Dec 16 19:10:45 midnightserver NVRM: bad caching on address 0xc88b7000: actual 0x163 != expected 0x173
Dec 16 19:10:45 midnightserver NVRM: please see the README section on Cache Aliasing for more information
(But, I think you've seen this already)
chunkey is offline   Reply With Quote
Old 12-23-06, 06:01 PM   #3
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Gentoo, nvidia-drivers 9631 - X fatal server error

(...)
(II) LoadModule: "glx"
(II) Loading /usr/X11R6/lib/modules/extensions/libglx.a
(II) Module glx: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
ABI class: XFree86 Server Extension, version 0.2
(...)


The X server is not loading the NVIDIA GLX extension module; it looks like the NVIDIA Linux graphics driver was not installed correctly.
zander is offline   Reply With Quote
Old 12-23-06, 06:10 PM   #4
chunkey
#!/?*
 
Join Date: Oct 2004
Posts: 662
Default Re: Gentoo, nvidia-drivers 9631 - X fatal server error

@zander:

he uses Xorg... scroll down
chunkey is offline   Reply With Quote
Old 12-23-06, 06:15 PM   #5
rik0
Registered User
 
Join Date: Dec 2006
Posts: 19
Default Re: Gentoo, nvidia-drivers 9631 - X fatal server error

Thanks for the quick replies....

I guess I could always try the legacy-drivers although I don't think the card isn't in the old GPU list..

Hmmm
rik0 is offline   Reply With Quote
Old 12-23-06, 06:17 PM   #6
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Gentoo, nvidia-drivers 9631 - X fatal server error

@chunkey: thanks, I missed that.

@rik0: please ignore my earlier post; this still looks like an installation problem, however, please make sure you don't mix Gentoo and NVIDIA graphics driver packages. I'd recommended that you use Gentoo's driver packages, when available.
zander is offline   Reply With Quote
Old 12-26-06, 05:54 AM   #7
rik0
Registered User
 
Join Date: Dec 2006
Posts: 19
Default Re: Gentoo, nvidia-drivers 9631 - X fatal server error

NO joy yet.

Tried the legacy drivers as suggested and these failed too, although I got the nvidia splash screen before they did. Looking at what my card suggests it is and comparing with the supported cards I still think the new drivers should work.

I have alwys been using the gentoo packages to install the drivers, ie using the ebuilds under the emerge program

eg
emerge nvidia-drivers

reverted back to latest nvidia-drivers

Still stuck with the problem though...

I am sure it is an install problem as well but I just don't have the skills to fix, any pointers would help me out..
thanks in advance
rik0 is offline   Reply With Quote
Old 12-31-06, 02:40 AM   #8
cazou88
Registered User
 
Join Date: Dec 2006
Posts: 1
Default Re: Gentoo, nvidia-drivers 9631 - X fatal server error

Hi !

I've got the same problem but I have no backtrace. It says "Segmentation fault"

which version of gcc did you use to compile X.org and nvidia-drivers ?
cazou88 is offline   Reply With Quote

Old 01-02-07, 06:40 AM   #9
rik0
Registered User
 
Join Date: Dec 2006
Posts: 19
Default Re: Gentoo, nvidia-drivers 9631 - X fatal server error

Hi there


# gcc --version

produces the output

gcc (GCC) 3.3.3 20040412 (Gentoo Linux 3.3.3-r6, ssp-3.3.2-2, pie-8.7.6)


I've decided to try and revert back to the situation I had before (jerky video etc). so i have gone back to an old kernel, and although I am still using the latest (recompiled) nvidia drivers I am not loading the "GLX" module now in the /root/xorg.conf file

Which causes errors but allows xorg to start.

Still looking for help, as the full screen video playback is very jerky so I want to use some sort of hardware optimisation at first not even looking for 3d support yet

does anyone have anymore ideas?
rik0 is offline   Reply With Quote
Old 01-02-07, 10:58 AM   #10
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Gentoo, nvidia-drivers 9631 - X fatal server error

You stated that you're experiencing "full screen video playback is jerky". Are you stating that there are framedrops, or that there is tearing, or something else? How can this problem be reproduced?

Also, please generate and attach an nvidia-bug-report.log.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 01-02-07, 02:20 PM   #11
rik0
Registered User
 
Join Date: Dec 2006
Posts: 19
Default Re: Gentoo, nvidia-drivers 9631 - X fatal server error

Thanks for the reply Lonni

So as you have probably seen from the original post, the original nvidia-bug-report.log output when X failed to start, with the correct /rrot/xorg.conf configuration directives... now I have commented out the load glx module directive I do now start

I don't really know what the GLX module does but I am hoping it will help accelerate video playback by using the nvidia hardware more effectively

I've attached a new nvidia-bug-report.log whilst my machine is usnig this new configuration, although the original log is probably the best one to work from.

NB look at
/var/log/Xorg.0.log
AND
/root/xorg.conf


as for the video, as before it is frame dropping (audio seems fine), and if by tearing you mean I can see a horizontal line every now and again then yes, but this is not as bad as the frame dropping..
cpu is maxing out if I perform a TOP whilst video is playing.

Thasnks in advance

Rik
Attached Files
File Type: log nvidia-bug-report.log (95.6 KB, 98 views)
rik0 is offline   Reply With Quote
Old 01-02-07, 02:28 PM   #12
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Gentoo, nvidia-drivers 9631 - X fatal server error

The GLX module is what provides OpenGL acceleration.

According to your bug report, you're not using the GLX module which ships with the nvidia driver:
(II) LoadModule: "glx"
(II) Loading /usr/X11R6/lib/modules/extensions/libglx.a
(II) Module glx: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
ABI class: XFree86 Server Extension, version 0.2

This suggests that the nvidia driver is not correctly installed.

What kind of video content are you playing, and movie player are you using?
netllama is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Regression with 295.33 and GeForce GT 240 maro NVIDIA Linux 16 06-29-12 06:47 PM
nvidia error and server stuck barbara NVIDIA FreeBSD 3 04-30-12 01:20 PM
nvidia + 2.4.19 gentoo = messed up ulukay NVIDIA Linux 18 11-01-02 11:58 PM
Radeon 9700 not all that? sancheuz Other Desktop Graphics Cards 200 10-12-02 09:31 PM
Mandrake 8.2 Nvidia src.rpm problems Mr_Malcontent NVIDIA Linux 8 09-11-02 09:53 PM

All times are GMT -5. The time now is 04:18 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.