Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-05-07, 10:09 AM   #25
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Gentoo, nvidia-drivers 9631 - X fatal server error

According to the bug report, you're still using the 'classic' TLS library:
libnvidia-tls.so.1 => /usr/lib/libnvidia-tls.so.1

You might want to try manually moving or renaming /usr/lib/libnvidia-tls.so.1 & /usr/lib/libnvidia-tls.so.1.0.9631 such that the new library is used instead.
netllama is offline   Reply With Quote
Old 01-05-07, 11:12 AM   #26
rik0
Registered User
 
Join Date: Dec 2006
Posts: 19
Default Re: Gentoo, nvidia-drivers 9631 - X fatal server error

Thanks again for keeping with me

Are you suggesting I just rename

/usr/lib/libnvidia-tls.so.1.0.9631 to /usr/lib/libnvidia-tls.so.1.0.9631.bak

AND

/usr/lib/libnvidia-tls.so.1 to /usr/lib/libnvidia-tls.so.1.bak

??
if so this seems odd as

ldd /usr/bin/glxinfo
now gives

libnvidia-tls.so.1 => not found

but swaping these 2 filenames around doesn't either as currently one is a symbolic link to the other

# ls -l /usr/lib/libnvidia-tls.so.1
lrwxr-xr-x 1 root root 25 Jan 5 11:38 /usr/lib/libnvidia-tls.so.1 -> libnvidia-tls.so.1.0.9631
# ls -l /usr/lib/libnvidia-tls.so.1.0.9631
-rwxr-xr-x 1 root root 2352 Jan 5 11:38 /usr/lib/libnvidia-tls.so.1.0.9631



Can you let me know what files I should be renaming and to what?
rik0 is offline   Reply With Quote
Old 01-05-07, 11:41 AM   #27
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Gentoo, nvidia-drivers 9631 - X fatal server error

Yes, you should move those libraries out of the directory altogether. You should have libraries with the same names in /usr/lib/tls (which are the 'new' libraries rather than the 'classic'). Do you?
netllama is offline   Reply With Quote
Old 01-05-07, 11:46 AM   #28
rik0
Registered User
 
Join Date: Dec 2006
Posts: 19
Default Re: Gentoo, nvidia-drivers 9631 - X fatal server error

yes I do


midnightserver ~ # ls -l /usr/lib/*tls*
lrwxr-xr-x 1 root root 25 Jan 5 17:37 /usr/lib/libnvidia-tls.so.1 -> libnvidia-tls.so.1.0.9631
-rwxr-xr-x 1 root root 2352 Jan 5 17:37 /usr/lib/libnvidia-tls.so.1.0.9631

/usr/lib/tls:
total 4
lrwxr-xr-x 1 root root 25 Jan 5 17:37 libnvidia-tls.so.1 -> libnvidia-tls.so.1.0.9631
-rwxr-xr-x 1 root root 2324 Jan 5 17:37 libnvidia-tls.so.1.0.9631


I will do as you suggest
rik0 is offline   Reply With Quote
Old 01-05-07, 12:12 PM   #29
rik0
Registered User
 
Join Date: Dec 2006
Posts: 19
Default Re: Gentoo, nvidia-drivers 9631 - X fatal server error

OK I have renamed both those files in /usr/lib you suggested

This allows xorg to start But only because the glx module fails to load (bug log attached)

for good measure then X was started I tried to run glxgears which failed

I then exited out of xorg

This procedure only caused the module to fail to load

to pre-empt your next suggestion I performed

# cp /usr/lib/tls/libnvidia-tls.so.1 /usr/lib/libnvidia-tls.so.1
# ls -l /usr/lib/libnvidia-tls.so.1
-rwxr-xr-x 1 root root 2324 Jan 5 17:57 /usr/lib/libnvidia-tls.so.1
# ldd /usr/bin/glxinfo
/usr/bin/glxinfo: error while loading shared libraries: libnvidia-tls.so.1: cannot handle TLS data
Attached Files
File Type: log nvidia-bug-report.log (120.2 KB, 85 views)
rik0 is offline   Reply With Quote
Old 01-05-07, 12:15 PM   #30
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Gentoo, nvidia-drivers 9631 - X fatal server error

Your system seems to need the classic TLS libraries, yet isn't capable of running them. I'm afraid that I don't have any other suggestions, as this problem seems specific to your environment.
netllama is offline   Reply With Quote
Old 01-05-07, 01:22 PM   #31
rik0
Registered User
 
Join Date: Dec 2006
Posts: 19
Default Re: Gentoo, nvidia-drivers 9631 - X fatal server error

that is a shame thanks for your time & suggestions
if anyone else has any bright ideas then let me know else I'll start crawling around to try and fix myself
rik0 is offline   Reply With Quote
Old 01-05-07, 08:38 PM   #32
arctanx
Registered User
 
Join Date: Jan 2007
Posts: 4
Default Re: Gentoo, nvidia-drivers 9631 - X fatal server error

Well I've experimented with the TLS files, and discovered that the ones in /usr/lib cause a crash. If I remove them, it simply cannot find them. If I move the ones from /usr/lib/tls into /usr/lib, the module fails to load and glxgears gives me an error that the file cannot handle TLS data.
arctanx is offline   Reply With Quote

Old 01-08-07, 04:50 AM   #33
rik0
Registered User
 
Join Date: Dec 2006
Posts: 19
Default Re: Gentoo, nvidia-drivers 9631 - X fatal server error

@arctanx

This is interesting that this is exactly the same issue I am seeing as well, so perhaps this is more than just the odd environment which this issue happens in.

I was thinking about trying the opensource "nv" drivers just to see if they work or fail in the same way. The other thing was potentially trying to completely disable the onboard video, (if I can in the bios) just in case this is causing issues with the driver... doubt it but maybe... Does your system have 2 video cards/an onboard graphics adaptor?
rik0 is offline   Reply With Quote
Old 01-08-07, 11:22 PM   #34
arctanx
Registered User
 
Join Date: Jan 2007
Posts: 4
Default Re: Gentoo, nvidia-drivers 9631 - X fatal server error

Quote:
Originally Posted by rik0
Does your system have 2 video cards/an onboard graphics adaptor?
No, I only have my 6600GT. The nv drivers work, but I haven't gone to the trouble of getting the open source 3d working yet. It's not ideal, since the nVidia drivers _should_ work.
arctanx is offline   Reply With Quote
Old 01-10-07, 09:27 AM   #35
brooi
Registered User
 
Join Date: Jan 2007
Posts: 4
Default Re: Gentoo, nvidia-drivers 9631 - X fatal server error

Looks like I am having a similar issue. After following the Gentoo nvidia install I would receive a fatal error. When I comment out GLX in xorg.conf I am able to start X and use it with no problems except for testing glxgears or glx-info so I have no OpenGL support...

Error when loading X without GLX enabled.
Code:
(EE) NVIDIA(0): Failed to load GLX
    xkb_keycodes             { include "xfree86+aliases(qwerty)" };
    xkb_types                { include "complete" };
    xkb_compatibility        { include "complete" };
    xkb_symbols              { include "pc(pc104)+us" };
    xkb_geometry             { include "pc(pc104)" };
When GLX is enabled, the X log file shows that it gets to this and dies:
Code:
(II) Initializing extension GLX

Backtrace:
I am using the nvidia-drivers and have also tried the nvidia-legacy-drivers

Last edited by brooi; 01-11-07 at 07:14 AM.
brooi is offline   Reply With Quote
Old 01-11-07, 01:39 PM   #36
rik0
Registered User
 
Join Date: Dec 2006
Posts: 19
Default Re: Gentoo, nvidia-drivers 9631 - X fatal server error

This is disappointing we are all seeing the same issues but no one has a resolution, or ability to get more detailed debugging for for the good nvidia guys to look at resolving
rik0 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Regression with 295.33 and GeForce GT 240 maro NVIDIA Linux 16 06-29-12 06:47 PM
nvidia error and server stuck barbara NVIDIA FreeBSD 3 04-30-12 01:20 PM
nvidia + 2.4.19 gentoo = messed up ulukay NVIDIA Linux 18 11-01-02 11:58 PM
Radeon 9700 not all that? sancheuz Other Desktop Graphics Cards 200 10-12-02 09:31 PM
Mandrake 8.2 Nvidia src.rpm problems Mr_Malcontent NVIDIA Linux 8 09-11-02 09:53 PM

All times are GMT -5. The time now is 10:06 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.