Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-18-07, 07:29 AM   #25
ivan49
Registered User
 
Join Date: Jun 2007
Posts: 1
Default Re: Samsung SyncMaster 204B blackouts in DVI mode

Quote:
Originally Posted by WakeFossil
This is how you edit your xorg.conf to activate reduced blanking:

1) Generate the appropriate Modeline:
$ cvt 1600 1200 60 -r
This creates the following output (well not exactly, I edited the comment and the mode name):
# 1600x1200 59.92 Hz (CVT 1.92M3-R) hsync: 74.01 kHz; pclk: 130.25 MHz
ModeLine "1600x1200_59.92_rb" 130.25 1600 1648 1680 1760 1200 1203 1207 1235 +hsync -vsync
Add these two lines in /etc/X11/xorg.conf in Section "Monitor".

In Section "Screen" add to each mode list "1600x1200_59.92_rb" as first entry.

In Section "Device" add this line:
Option "ExactModeTimingsDVI" "yes"
This forces the driver to use the exact mode line and not the closest setting retrieved from EDID (I had quite a hard time figuring that out.)

How to check if Reduced Blanking was activated (apart from the absence of blackouts :-) ) :
Monitor info in the OSD shows a line frequency of 74.1 kHz. (Without Reduced Blanking: 74.9)

Thanks a lot to users pe1chl and kulick from whose postings I got this wisdom.

Enjoy!
Andy a.k.a. WakeFossil
I need help with this one. What exaclty should i write into the xorg.conf??? Im new to linux and my distrib is ubuntu feisty!
ivan49 is offline   Reply With Quote
Old 06-18-07, 07:37 AM   #26
gbil
Registered User
 
Join Date: Mar 2006
Posts: 272
Default Re: Samsung SyncMaster 204B blackouts in DVI mode

Just to note that 206bw *doesn't* have such a problem. They fixed it or is it a 4:3 display bug only?
gbil is offline   Reply With Quote
Old 08-31-07, 06:26 PM   #27
cyb3rj
Registered User
 
Join Date: Aug 2007
Posts: 7
Default Re: Samsung SyncMaster 204B blackouts in DVI mode

Quote:
Originally Posted by WakeFossil
This is how you edit your xorg.conf to activate reduced blanking:

1) Generate the appropriate Modeline:
$ cvt 1600 1200 60 -r
This creates the following output (well not exactly, I edited the comment and the mode name):
# 1600x1200 59.92 Hz (CVT 1.92M3-R) hsync: 74.01 kHz; pclk: 130.25 MHz
ModeLine "1600x1200_59.92_rb" 130.25 1600 1648 1680 1760 1200 1203 1207 1235 +hsync -vsync
Add these two lines in /etc/X11/xorg.conf in Section "Monitor".

In Section "Screen" add to each mode list "1600x1200_59.92_rb" as first entry.

In Section "Device" add this line:
Option "ExactModeTimingsDVI" "yes"
This forces the driver to use the exact mode line and not the closest setting retrieved from EDID (I had quite a hard time figuring that out.)

How to check if Reduced Blanking was activated (apart from the absence of blackouts :-) ) :
Monitor info in the OSD shows a line frequency of 74.1 kHz. (Without Reduced Blanking: 74.9)

Thanks a lot to users pe1chl and kulick from whose postings I got this wisdom.

Enjoy!
Andy a.k.a. WakeFossil
I'm trying this right now; I just got this problem resolved under WinXP. What is that "cvt" command? I'm not able to run it.
cyb3rj is offline   Reply With Quote
Old 08-31-07, 07:38 PM   #28
cestuila
Registered User
 
Join Date: Dec 2006
Posts: 17
Default Re: Samsung SyncMaster 204B blackouts in DVI mode

here:
http://www.uruk.org/~erich/projects/cvt/
cestuila is offline   Reply With Quote
Old 10-04-07, 06:48 AM   #29
cyb3rj
Registered User
 
Join Date: Aug 2007
Posts: 7
Default Re: Samsung SyncMaster 204B blackouts in DVI mode

I am again combating "snow" and blanking.

$ uname -a
Linux *** 2.6.20-16-generic #2 SMP Sun Sep 23 18:31:23 UTC 2007 x86_64 GNU/Linux

There are two distinct changes I made:
1. I reinstalled Kubuntu because reiserfs was not agreeing with me.
2. I updated my kernel from 2.6.20-15-generic to 2.6.20-16-generic.

Maybe another change affected me -- I uninstalled "Powerstrip" from my windows partition. After doing so, I notice that in XP I need to reconfigure the custom timing every time I login. When Powerstrip was installed I did not need to. Does anyone know if Powerstrip does something to flash settings to graphics cards?

I have recompiled cvt under the new kernel and got the exact same modeline. That mode is the only mode I list for each setting (xorg.conf attached).

The actions I see from this point are
1) Boot into the previous kernel and see if the problem persists
2) Reinstall Powerstrip in case it set a persistent setting in the graphics card
3) buy a new monitor

__
JW
(GeForce 7900 GS KO, SyncMaster 204B)
Attached Files
File Type: txt xorg.conf.txt (4.5 KB, 256 views)
cyb3rj is offline   Reply With Quote
Old 10-04-07, 05:38 PM   #30
cestuila
Registered User
 
Join Date: Dec 2006
Posts: 17
Default Re: Samsung SyncMaster 204B blackouts in DVI mode

Section "Device"
Identifier "eVGA GeForce 7900 GS KO"
Driver "nvidia"
#Option "ExactModeTimingsDVI" "yes"

Why #Option "ExactModeTimingsDVI" "yes" ?

must be uncommented !!

Also you must run "nvidia-settings" and check if the driver
take care of your timings:

-X Server Display Configuration
-Advanced
-Mode Name : should be "1600x1200_59.92_rb" in your case
cestuila is offline   Reply With Quote
Old 10-04-07, 06:24 PM   #31
cyb3rj
Registered User
 
Join Date: Aug 2007
Posts: 7
Default Re: Samsung SyncMaster 204B blackouts in DVI mode

Quote:
Originally Posted by cestuila
Section "Device"
Identifier "eVGA GeForce 7900 GS KO"
Driver "nvidia"
#Option "ExactModeTimingsDVI" "yes"

Why #Option "ExactModeTimingsDVI" "yes" ?

must be uncommented !!

Also you must run "nvidia-settings" and check if the driver
take care of your timings:

-X Server Display Configuration
-Advanced
-Mode Name : should be "1600x1200_59.92_rb" in your case
I intended to update this after running my machine all day. I have not had any trouble now. "ExactModeTimingsDVI" is still commented. In "X Server Display Configuration | Advanced" my settings are as follows:
Code:
Resolution:  Auto
Mode Name:  nvidia-auto-select
Panning:  1600x1200
...
Color Depth:  Millions of Colors
MetaMode:  2 - nvidia-auto-select +0+0
I point out the "MetaMode" because my custom mode line is also there. I'm going to assume (!) that since there is only one mode line, that is what it is using.

So the big difference appears to be leaving ExactModeTimingsDVI commented. That seems contrary... and I don't get it.

If this makes sense to anyone, I'll happily read your explanation.

cestuila -- thank you for pointing out these settings and responding. I appreciate it.

__
JW
cyb3rj is offline   Reply With Quote
Old 10-04-07, 06:52 PM   #32
cestuila
Registered User
 
Join Date: Dec 2006
Posts: 17
Default Re: Samsung SyncMaster 204B blackouts in DVI mode

Found here:
http://us.download.nvidia.com/XFree8...ppendix-b.html

Option "ExactModeTimingsDVI" "boolean"

Forces the initialization of the X server with the exact timings specified in the ModeLine. Default: false (for DVI devices, the X server initializes with the closest mode in the EDID list).
cestuila is offline   Reply With Quote

Old 10-05-07, 05:51 AM   #33
cyb3rj
Registered User
 
Join Date: Aug 2007
Posts: 7
Default Re: Samsung SyncMaster 204B blackouts in DVI mode

Quote:
Originally Posted by cestuila
Found here:
http://us.download.nvidia.com/XFree8...ppendix-b.html

Option "ExactModeTimingsDVI" "boolean"

Forces the initialization of the X server with the exact timings specified in the ModeLine. Default: false (for DVI devices, the X server initializes with the closest mode in the EDID list).
Wow. Thanks for the really quick response.

My curiosity about the contradiction is that I've specified an exact timing, but have left that option commented (thus defaulting to "false"). In doing so, everything appears to be working just fine.

I'm not trying to complain that my system appears to be working, that's for sure. I just find it strange that a "plain" 1600x1200 causes problems, but this exact mode timing -- with "ExactModeTimingsDVI" set to false -- appears to make everything work. I'll take it, but it doesn't make sense (and that's what bugs me).

Thanks again for the really quick response, I'm bookmarking that site so I can learn more.
cyb3rj is offline   Reply With Quote
Old 11-17-07, 04:16 PM   #34
Darkvater
Registered User
 
Join Date: Feb 2005
Posts: 57
Default Re: Samsung SyncMaster 204B blackouts in DVI mode

Wow, this is really weird. I had this exact problem with a Samsung 205BW as I mentioned earlier. Gladly I could "fix" it by changing the timing option in the NVidia panel.

But now I've got a new PC with an integrated graphics card, an Intel 3100 (came with the G33 motherboard chipset). As soon as I connected the DVI connection blackouts, flickering started and happened every second orso, basically rendering the whole computer useless.

I was about to mail Samsung support for an RMA or something, when I thought I'd try the Powerstrip tip someone posted here. I Installed the program and instantly the blackouts stopped!! I didn't even change any settings which I actually wanted to. Does anyone know what is going on? What did Powerstrip change without my knowledge?

(Windows XP SP2, Intel G33 motherboard, Core Duo 2 E6750, 2GB DDR2, Samsung 205BW 1680x1050@60Hz)
Darkvater is offline   Reply With Quote
Old 11-24-07, 08:57 AM   #35
Darkvater
Registered User
 
Join Date: Feb 2005
Posts: 57
Default Re: Samsung SyncMaster 204B blackouts in DVI mode

Sadly, I have to retract my previous statement, flickering is still present. Turning off the monitor, waiting for 5 seconds and turning it back on seems to temporarily solve the problem
Darkvater is offline   Reply With Quote
Old 11-24-07, 03:06 PM   #36
kriko
openSuSE11
 
kriko's Avatar
 
Join Date: Aug 2005
Location: Europe, Slovenia, Koper
Posts: 515
Default Re: Samsung SyncMaster 204B blackouts in DVI mode

Return it back. Btw, where was yours manufactured?
I found this thread after buying a 204b and never had such problem (using it for 4 months), using dual-link DVI cable (neither with vga).
kriko is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
320.17 can't detect video modes on Lenovo laptop tadawson NVIDIA Linux 13 07-14-12 01:40 AM
$139.99 - Samsung SyncMaster EX2020X 20' LED LCD Monitor - 16:9 - 5 ms News 20-Inch 0 06-10-12 01:17 PM
Error messages... HELP!!!! Imperito NVIDIA Linux 3 09-24-02 10:46 PM
Nvidia GF4 MX 440 + Mandrake tomchristopher NVIDIA Linux 3 08-18-02 09:42 AM
nVidia drivers + Red Hat Linux 7.3 Error404 NVIDIA Linux 17 08-16-02 11:34 AM

All times are GMT -5. The time now is 03:02 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.