Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-07-03, 05:06 AM   #1
Kristov
Registered User
 
Join Date: Mar 2003
Posts: 2
Unhappy NVIDIA bugs...

Here some problem I've encounter with nvidia driver.

First of All here is my config :
Riva TNT2 XFree 4.3.0 Mandrake 9.1RC2 (kernel 2.4.21)

I've compiled the NVIDIA_KERNEL and NVIDIA_GLX from source (1.0-4191) with gcc 3.2.2 (with flag IGNORE_CC_MISMATCH)

All works after modifying my XFree86 config file (driver="nvidia" and load GLX) ...

But here are my problems (without nvidia driver but default one from XFree(nv) all is correct) :

- when I launch an application that require OpenGL, sometimes (50% of the time) it's hang completely my computer (in fact my computer seem to work fine (downloads, servers, etc...), except that keyboard and mouse doesn't work anymore

- when I launch an application that require OpenGL but didn't hang my computer (the other 50% of the time), all seems hang for about 2-3 seconds and after that delay everything works fine

- finally when I set in GNOME a theme with textures over control (like smokey-blue), the textures are corrupted (works fine without NVIDIA driver)

So if someone could tells me : "Yes that's NVIDIA driver issues and it will be corrected in other releases", I would thank him :-)

Christophe.
Kristov is offline   Reply With Quote
Old 03-07-03, 08:57 AM   #2
erwos
Registered User
 
Join Date: Nov 2002
Posts: 78
Default

The 4191 drivers are known to be buggy and slow due to the removal of XRENDER. Wait for the new release, and downgrade to the 31XX series until then.

Also, make sure you aren't using SBA or FWs.

-Erwos
erwos is offline   Reply With Quote
Old 03-07-03, 09:55 AM   #3
Kristov
Registered User
 
Join Date: Mar 2003
Posts: 2
Default Thank you for your answer

What does SBA and FW mean ?

Christophe.
Kristov is offline   Reply With Quote
Old 03-07-03, 03:59 PM   #4
borgzilla
Linux Assimilator
 
Join Date: Aug 2002
Location: Scottsdale, AZ
Posts: 72
Default

SBA = Side Band Addressing
FW = Fast Writes

That's something that does nothing as many other features which we can find in our expensive video cards.
borgzilla is offline   Reply With Quote
Old 03-07-03, 07:04 PM   #5
BekA
Registered User
 
Join Date: Mar 2003
Posts: 3
Default How to check that ?

How can I check wheter I use FW and/or SBA ?

thx
BekA is offline   Reply With Quote
Old 03-07-03, 08:52 PM   #6
borgzilla
Linux Assimilator
 
Join Date: Aug 2002
Location: Scottsdale, AZ
Posts: 72
Default

type this in console
cat /proc/driver/nvidia/agp/status
borgzilla is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM
Rumor regarding lack of 680 availability ViN86 Rumor Mill 6 05-09-12 04:48 PM
rh7.3 and nvidia vcrispo NVIDIA Linux 11 07-31-02 08:57 PM

All times are GMT -5. The time now is 03:54 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.