Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-02-07, 12:20 PM   #1
malus983
Registered User
 
Join Date: Nov 2006
Posts: 3
Default suspend2 with drivers 9746

Hi all,
I have a problem with suspend to ram. My notebook is a sony vaio fs315m with gpu nvidia geforce go 6400 turbo cache. My OS is gnu/linux gentoo kernel 2.6.19-suspend2 patched by gentoo and latest drivers of nvidia (9746).
Suspend to disk works perfectly but suspend to ram give a black screen on resume and the system crash (it does not reply to any ping or ssh session). It is strange that with nvidia drivers 8774 any suspend works (suspend ti disk works perfectly, suspend to ram fails sometimes).

ps: sorry for bad english
Any ideas???

malus
malus983 is offline   Reply With Quote
Old 01-04-07, 03:38 PM   #2
lsm
Registered User
 
Join Date: Sep 2005
Posts: 4
Default Re: suspend2 with drivers 9746

Quote:
Originally Posted by malus983
Hi all,
I have a problem with suspend to ram. My notebook is a sony vaio fs315m with gpu nvidia geforce go 6400 turbo cache. My OS is gnu/linux gentoo kernel 2.6.19-suspend2 patched by gentoo and latest drivers of nvidia (9746).
Suspend to disk works perfectly but suspend to ram give a black screen on resume and the system crash (it does not reply to any ping or ssh session). It is strange that with nvidia drivers 8774 any suspend works (suspend ti disk works perfectly, suspend to ram fails sometimes).

ps: sorry for bad english
Any ideas???

malus
I confirm, same observed here with a Sony Vaio vfs790. Suspend to Ram stopped functioning with 9xxx series nvidia driver. black screen upon resume. Works great with 8774, so I'm stuck at that release.

I don't use suspend2, so I can't comment on suspend-to-disk.
lsm is offline   Reply With Quote
Old 01-10-07, 07:00 PM   #3
malus983
Registered User
 
Join Date: Nov 2006
Posts: 3
Default Re: suspend2 with drivers 9746

Quote:
Originally Posted by lsm
I confirm, same observed here with a Sony Vaio vfs790. Suspend to Ram stopped functioning with 9xxx series nvidia driver. black screen upon resume. Works great with 8774, so I'm stuck at that release.

I don't use suspend2, so I can't comment on suspend-to-disk.
Hi lsm
Here nobody reply to us!
I hope that as soon as possible somebody reply. I don't understand why nobody ask or answer about our problem! I cant believe that only I and you have this problem!!!

nvidia staff... any ideas?

malus
malus983 is offline   Reply With Quote
Old 01-11-07, 04:22 AM   #4
stef
Registered User
 
Join Date: Jul 2005
Posts: 9
Default Re: suspend2 with drivers 9746

Hi,
I don't use suspend2 but I use suspend to ram and suspend to disk functions included in 2.6.19.1 vanilla kernel with a Toshiba Tecra S3 laptop running Slackware 11.
My card is a 6600 Go PCI-E
I can confirm that with the latest Nvidia driver I can't resume correctly: the display stay black.
As you have mentioned and as I have experienced too, all is fine with 8774/8776 drivers.
The only annoying thing is that I had to patch the drivers with a Gentoo patch in order to compile them against 2.6.19 kernel.

Regards,
Stefano
stef is offline   Reply With Quote
Old 01-11-07, 09:00 PM   #5
meldroc
Registered User
 
Join Date: Apr 2003
Location: Somewhere in Colorado
Posts: 19
Default Re: suspend2 with drivers 9746

I'm encountering the same issue. I just installed version 9746 of the nvidia drivers on my laptop (an Asus A8Js with an NVidia Geforce Go 7700 w/ 512MB) which is running Ubuntu Edgy. Using an older version of the nvidia drivers (whatever version comes with Edgy Eft by default), suspend and worked fine, but now when I do a suspend, then resume, the display's totally wigged out, crashing X, with stripes or other garbage on the screen. Usually, I'm able to restart X by restarting kdm or using Ctrl-Alt-Backspace and then it comes back, though system stability's affected.
meldroc is offline   Reply With Quote
Old 01-12-07, 11:09 AM   #6
meldroc
Registered User
 
Join Date: Apr 2003
Location: Somewhere in Colorado
Posts: 19
Default Re: suspend2 with drivers 9746

Just to follow up, I tried some of the suggested fixes here: http://www.nvnews.net/vbulletin/show...hlight=suspend.

It made for slightly better behavior in that I was able to resume from suspend-to-RAM successfully a few times, but my system was still unstable afterwards, and the virtual terminals were mangled (Running Ubuntu Edgy, using their framebuffer console at 1024x768).

I gave up and reverted to Edgy's default drivers (8776), which means I can't run Beryl, but suspend works correctly, which is important on a laptop.

Nvidia developers, please fix this.
meldroc is offline   Reply With Quote
Old 01-14-07, 10:14 AM   #7
stef
Registered User
 
Join Date: Jul 2005
Posts: 9
Default Re: suspend2 with drivers 9746

>I gave up and reverted to Edgy's default drivers (8776), which means I can't run
>Beryl, but suspend works correctly, which is important on a laptop.

It is also possible to run Beryl with 8776 using Xgl!
You can find a very detailed howto here:

http://wiki.beryl-project.org/wiki/I..._Edgy_with_XGL
stef is offline   Reply With Quote
Old 01-14-07, 10:38 AM   #8
krionius
Asus 8800GTS 320M
 
krionius's Avatar
 
Join Date: Jul 2003
Location: Budapest, HU
Posts: 249
Default Re: suspend2 with drivers 9746

Quote:
Originally Posted by stef
>I gave up and reverted to Edgy's default drivers (8776), which means I can't run
>Beryl, but suspend works correctly, which is important on a laptop.

It is also possible to run Beryl with 8776 using Xgl!
You can find a very detailed howto here:

http://wiki.beryl-project.org/wiki/I..._Edgy_with_XGL
Is Xgl suspend2 compatible using nvidia drivers?
__________________
SK - Java Classic RPG http://zaza.uw.hu/mrp/index.html http://linuxrpgs.blogspot.com
Asus GF8800GTS 320M DDR3 PCI-E - nvidia 169.09
Abit KN9 SLI (nforce570),AMD64 X2 3800+@4800+,2x1GB 800MHz DDR2,160G SATA2 WesternDigital,430W Chieftec PSU
gentoo linux (since 2003) 2006.1 amd64 kernel 2.6.22-suspend2 X.Org 7.3 | gnome 2.20.0, kde 3.5.5, beryl 0.2.1

Samsung SyncMaster 913N@1240, Tatung "32 @1080i, Pinnacle PCTV Rave, Pioneer DVR110D
Abit AN-M2HD NVidia 7050PV Noiseless HTPC, Ubuntu Linux 7.10 64bit kernel 2.6.23.8, nvidia 169.04, FSP Zen 300W,
Thermaltake Sonic Tower, AMD64 X2 4200+, 2GB DDR2, 400G SATA2 WD, Asus TVTuner (saa7134) Silent Linux HTPC

Asus TravelMate 4100 NVidia 6200 Go, Ubuntu Linux 8 32bit kernel 2.6.24, nvidia 169.12, Intel32 1.6G, 1.5GB DDR2,
krionius is offline   Reply With Quote

Old 01-14-07, 09:21 PM   #9
malus983
Registered User
 
Join Date: Nov 2006
Posts: 3
Default Re: suspend2 with drivers 9746

Quote:
Originally Posted by krionius
Is Xgl suspend2 compatible using nvidia drivers?
yes of course!!!
A lots of people use xgl, beryl, suspend, suspend2, swsusp ecc with nvidia drivers also with differents drivers
Our problem is a specific case!

malus
malus983 is offline   Reply With Quote
Old 01-30-07, 05:57 PM   #10
skalman
Registered User
 
Join Date: Jan 2007
Posts: 1
Default Re: suspend2 with drivers 9746

Quote:
Originally Posted by meldroc
...but now when I do a suspend, then resume, the display's totally wigged out, crashing X, with stripes or other garbage on the screen.
I'm having the same problems with my nVidia GeForce 6200 Go card running Gentoo and kernel 2.6.17-suspend2-r6. Downgraded to nvidia-drivers-1.0.9631 and hibernation works again.
skalman is offline   Reply With Quote
Old 02-12-07, 02:06 PM   #11
kevin_vacit2
Registered User
 
Join Date: Feb 2007
Posts: 1
Default Re: suspend2 with drivers 9746

I can confirm the problem as well. Running on an Asus A6K laptop with gentoo's suspend2 sources and kernel version 2.6.19-suspend2-r2-ginger. Video card is a nVidia 6200go.

Suspend2disk works without issues.

Suspend2Ram doesn't work from X at all with all 9xxx drivers. Suspending to ram initially works, but resuming results in a completely black screen and unresponsive system, Caps-lock doesn't light the led and the only way to exit is a hard powerdown.

Suspending to Ram from console-mode only without the nvidia module loaded does work, except that the LCD's backlight fails to turn on.

Reverting back to 8776 driver solves the problem for now.
kevin_vacit2 is offline   Reply With Quote
Old 03-20-07, 10:17 PM   #12
asdfasdfa
Registered User
 
Join Date: Feb 2007
Posts: 12
Default Re: suspend2 with drivers 9746

Guys, I am having this issue as well with the 9xxx series of drivers. What I realized is that it actually resumes after a couple of minutes. To test this - go into suspend (S3) then resume. Your display should be black, and Hard drive light might be on for approx. 30sec. Then your system will seem dormant (no keyboard use e.t.c). At this point, wait for approx 5 to 10min and see what happens. My system resumes after about 6min with full functionality. Maybe you guys give up before the system actually resumes. This is an issue I've raised with the nvidia devs. I think they can help us with this issue.
asdfasdfa is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
NVIDIA Drivers Receive Windows 8 Certification News Archived News Items 0 06-01-12 05:30 AM
Enhance Max Payne 3, Diablo III with GeForce R300 Drivers News Archived News Items 0 05-22-12 06:30 PM
Creative drivers ? SparrowHawk General Hardware 39 11-18-02 08:03 AM
Radeon 9700 not all that? sancheuz Other Desktop Graphics Cards 200 10-12-02 09:31 PM
Nvidia Stereo Drivers Soudontsay NVIDIA Windows Graphics Drivers 2 08-26-02 10:48 AM

All times are GMT -5. The time now is 05:22 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.