Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-05-07, 11:32 AM   #1
beezly
Registered User
 
Join Date: Jan 2004
Posts: 10
Default FX5200, Athlon 64, 9746, Twinview, running very slow

I have an AMD Athlon64 (running as 32 bit), Ubuntu 6.10 and a GeForce FX5200 running with Twinview turned on. I have the 9746 drivers installed and working.

Running 2D it is fine, but when I run 3D applications everything grinds to a crawl.

glxinfo says;

name of display: :0.0
display: :0 screen: 0
direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.4

and

OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce FX 5200/AGP/SSE2/3DNOW!
OpenGL version string: 2.1.0 NVIDIA 97.46

and I definitely using the correct libraries;

andy@terrapin:~$ ldd `which glxinfo` | grep GL
libGL.so.1 => /usr/lib/libGL.so.1 (0xb7e91000)
libGLU.so.1 => /usr/lib/libGLU.so.1 (0xb7e17000)
libGLcore.so.1 => /usr/lib/libGLcore.so.1 (0xb7250000)

andy@terrapin:~$ ls -l /usr/lib/libGL.so.1
lrwxrwxrwx 1 root root 17 2007-01-02 11:28 /usr/lib/libGL.so.1 -> libGL.so.1.0.9746

Interestingly, the problem only manifests itself when I am using a 3d application. The symptoms are that the 3d application tends to take up 100% of a CPU, and any updates to other windows (or the root window) are *incredibly* slow (I can watch a terminal in another window scroll up pixel-row by row!).

The only slightly wacky option in my x.org file is;

Option "AddARGBGLXVisuals" "True"

In the Device section.

Cheers,

Andrew
beezly is offline   Reply With Quote
Old 01-05-07, 11:34 AM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: FX5200, Athlon 64, 9746, Twinview, running very slow

First, see:
http://www.nvnews.net/vbulletin/showthread.php?t=46678

Specifically which applications trigger this problem?
Does this reproduce if you are not using the Composite extension?

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 01-05-07, 11:38 AM   #3
beezly
Registered User
 
Join Date: Jan 2004
Posts: 10
Default Re: FX5200, Athlon 64, 9746, Twinview, running very slow

Wow! Thanks for the very quick reply...

The output from the bug script is attached.

FYI, I have tried with the ARGB thing turned off, same results.

Any OpenGL application will reproduce the problem, so far I have tried glxgears, and second life.

I will try disabling composite and post again.

Cheers,

Andrew
Attached Files
File Type: gz nvidia-bug-report.log.gz (31.2 KB, 100 views)
beezly is offline   Reply With Quote
Old 01-05-07, 11:45 AM   #4
beezly
Registered User
 
Join Date: Jan 2004
Posts: 10
Default Re: FX5200, Athlon 64, 9746, Twinview, running very slow

I tried turning off Composite, it has made no difference
beezly is offline   Reply With Quote
Old 01-05-07, 12:04 PM   #5
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: FX5200, Athlon 64, 9746, Twinview, running very slow

I don't see anything unusual in the bug report that you posted. Can you generate a new one which includes the changes that you made to xorg.conf?

Also, can you check in the BIOS to see whether there is an AGP aperature option (or any other AGP specific options)?

Have you verified that you're using the latest BIOS for the motherboard?

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 01-05-07, 12:17 PM   #6
beezly
Registered User
 
Join Date: Jan 2004
Posts: 10
Default Re: FX5200, Athlon 64, 9746, Twinview, running very slow

Hello,

Ive checked I am using the latest BIOS.

The AGP Aperture was set to 512MB. I have changed it to 128MB but itś made no difference.

Cheers,

Andrew
beezly is offline   Reply With Quote
Old 01-05-07, 12:20 PM   #7
beezly
Registered User
 
Join Date: Jan 2004
Posts: 10
Default Re: FX5200, Athlon 64, 9746, Twinview, running very slow

Here is the output from nvidia-bug-report.sh
Attached Files
File Type: gz nvidia-bug-report.log.gz (27.5 KB, 113 views)
beezly is offline   Reply With Quote
Old 01-05-07, 12:43 PM   #8
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: FX5200, Athlon 64, 9746, Twinview, running very slow

Is this problem only present when using Twinview (multiple display devices)?
If you set NvAGP to 0 in xorg.conf, does that make any difference?

Thanks,
Lonni
netllama is offline   Reply With Quote

Old 01-08-07, 06:10 AM   #9
beezly
Registered User
 
Join Date: Jan 2004
Posts: 10
Default Re: FX5200, Athlon 64, 9746, Twinview, running very slow

Hi Lonni,

I see the same behaviour with TwinView disabled (ie output only to one monitor), and also with NvAGP set to 0.

Cheers,

Andrew
beezly is offline   Reply With Quote
Old 01-08-07, 06:46 AM   #10
beezly
Registered User
 
Join Date: Jan 2004
Posts: 10
Default Re: FX5200, Athlon 64, 9746, Twinview, running very slow

I have some more information that might be useful;

Running glxgears sometimes results in smooth operation for a few seconds and then it suddenly gets worse (slow to respond to keypresses, mouse input, etc.). glxgears -printfps shows;

Code:
andy@terrapin:~$ glxgears -printfps
2881 frames in 5.0 seconds = 576.181 FPS
2933 frames in 5.0 seconds = 586.446 FPS
andy@terrapin:~$ glxgears -printfps
805 frames in 5.1 seconds = 157.202 FPS
26 frames in 5.2 seconds =  5.032 FPS
27 frames in 5.0 seconds =  5.377 FPS
27 frames in 5.2 seconds =  5.218 FPS
33 frames in 5.0 seconds =  6.564 FPS
26 frames in 5.0 seconds =  5.184 FPS
26 frames in 5.0 seconds =  5.183 FPS
Also, if I run top in another window whilst running glxgears, I can see that X takes up 100% of a CPU, the glxgears process about 60% of a cpu. Around 45% of a cpu is taken up serving software interrupts! (surely that can't be right for something as simple as glxgears!).

Cheers,

Andrew
beezly is offline   Reply With Quote
Old 01-08-07, 09:16 AM   #11
lyon
Registered User
 
Join Date: Jan 2007
Posts: 2
Default Re: FX5200, Athlon 64, 9746, Twinview, running very slow

Hi All,
I have installed a new Geforce 5200 Nvidia card from PNY.
Rendering on the local display is working. However, remote
xwindows (on a mac)
is not rendering Java3d output. The GLX versions on the local and remote
displays are different (see below). I would like to debug this
problem by de-installing the nvidia card and using local
CPU (i.e. slow) rendering in order to make sure that all is OK.
I have an intel mobo and am running Fedora 6. I had
done a:
yum install kmod-nvidia
setsebool -P allow_execmod=1
init 3
nvidia-config-display enable
init 5

Since this is a 3rd party vendor card, I tried a
rpm -Va

The glxinfo follows. Am I doing something dumb?

Thanks!
- Doug

glxinfo
name of display: 192.168.1.152:0.0
display: 192.168.1.152:0 screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
GLX_EXT_import_context, GLX_SGI_make_current_read
client glx vendor string: SGI
client glx version string: 1.4
client glx extensions:
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory,
GLX_MESA_copy_sub_buffer, GLX_MESA_swap_control,
GLX_MESA_swap_frame_usage, GLX_OML_swap_method, GLX_OML_sync_control,
GLX_SGI_make_current_read, GLX_SGI_swap_control, GLX_SGI_video_sync,
GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer,
GLX_SGIX_visual_select_group, GLX_EXT_texture_from_pixmap
GLX version: 1.2
GLX extensions:
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_SGI_make_current_read
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: NVIDIA GeForce4 MX OpenGL Engine
OpenGL version string: 1.1 NVIDIA-1.4.18
OpenGL extensions:
GL_ARB_imaging, GL_ARB_multitexture, GL_ARB_point_parameters,
GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
GL_ARB_texture_env_combine, GL_ARB_texture_env_crossbar,
GL_ARB_texture_env_dot3, GL_ARB_texture_mirrored_repeat,
GL_ARB_texture_rectangle, GL_ARB_transpose_matrix, GL_ARB_window_pos,
GL_EXT_abgr, GL_EXT_bgra, GL_EXT_blend_color, GL_EXT_blend_minmax,
GL_EXT_blend_subtract, GL_EXT_clip_volume_hint,
GL_EXT_draw_range_elements, GL_EXT_fog_coord, GL_EXT_multi_draw_arrays,
GL_EXT_point_parameters, GL_EXT_rescale_normal, GL_EXT_secondary_color,
GL_EXT_separate_specular_color, GL_EXT_stencil_wrap,
GL_EXT_texture_edge_clamp, GL_EXT_texture_env_add,
GL_EXT_texture_lod_bias, GL_EXT_texture_rectangle, GL_APPLE_packed_pixels,
GL_ATI_texture_env_combine3, GL_ATIX_texture_env_combine3,
GL_IBM_texture_mirrored_repeat, GL_NV_blend_square,
GL_NV_texgen_reflection, GL_NV_texture_rectangle, GL_SGIS_generate_mipmap,
GL_SGIS_texture_edge_clamp, GL_SGIS_texture_lod, GL_SUN_multi_draw_arrays
lyon is offline   Reply With Quote
Old 01-09-07, 07:52 AM   #12
beezly
Registered User
 
Join Date: Jan 2004
Posts: 10
Default Re: FX5200, Athlon 64, 9746, Twinview, running very slow

FYI - I've just rebuilt the machine using the AMD64 Ubuntu 6.10 release, and then upgraded to the latest drivers. The problem still exists.
beezly is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:26 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.