Go Back   nV News Forums > Linux Support Forums > General Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-05-07, 04:33 PM   #1
tikcop1
Registered User
 
Join Date: Jan 2007
Posts: 4
Default refresh rate of monitor

Hello

I am running Mandriva 2007 PowerPack.

After upgrading drivers to version 9631 (GeForce FX 5200) I can have only 50 MHz refresh rate (1024*768).

Using default drivers 8774 I can have without any difficuly 1024*768 at 85 MHz on my monitor - that is Flatron 795FT Plus.

I wanted to upgrade drivers in order to be able to launch AIGLX & 3d desktop.

As you can imagine 50MHz rate is extremely difficult and harmful to work with.

I can't change it using mcc nor modifying xorg.conf.

I will realy appreciate a lot someone help!! I am attaching the bug report, xorg.conf & dmesg

My best regards,
Tomasz

[root@localhost ~]# rpm -qa | grep nvidia
nvidia-devel-9631-1plf2007.0
nvidia-kernel-2.6.17-5mdv-8774-1mdk
nvidia-9631-1plf2007.0
dkms-nvidia-9631-1plf2007.0
Attached Files
File Type: gz logs & conf.tar.gz (24.5 KB, 137 views)
tikcop1 is offline   Reply With Quote
Old 01-05-07, 06:45 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: refresh rate of monitor

How or where are you determining that you're getting 50Hz?

If this problem persists with 1.0-9746, please start X with the following command:
startx -- -logverbose 6

and then generate a new bug report.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 01-06-07, 01:24 PM   #3
tikcop1
Registered User
 
Join Date: Jan 2007
Posts: 4
Default Re: refresh rate of monitor

Lonni

Please find attached bug report. Report has been generated just after driver installation. I run the driver installation package in init 3 mode.

I am using KDE desktop. Can check it on KDesktop configuration (right click on screen and select proper tab).

I have revised myself bug report and noticed something that puzzled me a little bit
When building kernel folowing warning has appeared. In fact there are some other

WARNING: Symbol version dump /usr/src/linux-2.6.17-5mdv/Module.symvers
is missing; modules will have no dependencies and modversions.

Do I properly installed driver? Or I miss something? In xorg.log I' ve noticed so subdirectory nvidia does not longer exist. GLX is loaded anyway. Of course I can erase the line in xorg config file to avoid that error, but maybe that is a hint?

(II) LoadModule: "/usr/lib/xorg/modules/extensions/nvidia/libglx.so" (glx)
(WW) LoadModule: given non-canonical module name "/usr/lib/xorg/modules/extensions/nvidia/libglx.so"
(II) Loading /usr/lib/xorg/modules/extensions/nvidia/libglx.so
(EE) Unable to open /usr/lib/xorg/modules/extensions/nvidia/libglx.so
(II) UnloadModule: "glx"
(EE) Failed to load module "/usr/lib/xorg/modules/extensions/nvidia/libglx.so" (open failed, 2)
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions/libglx.so

I have also played a little bit with modelines in xorg conf and see so can establish different refresh rate but not the requested one, usually there are about 50-60 Mhz which is still not satisfactory.

The most promising one was
Modeline "1024x768@85" 94.50 1024 1072 1168 1376 768 769 772 808 +HSync +Vsync

After some other modeline modification I've notice the error in some log so monitor is going to use auto nvidia refresh line 1024*768 50 Mhz.

As you have more experience I am sure can help me to get requested 1024 768 85 Mhz.

Looking forward to hear from you
My best regards,
Tomasz
Attached Files
File Type: gz bug report.tar.gz (31.5 KB, 135 views)
tikcop1 is offline   Reply With Quote
Old 01-06-07, 04:14 PM   #4
tikcop1
Registered User
 
Join Date: Jan 2007
Posts: 4
Default Re: refresh rate of monitor

Lonnie

It's unbelievable but I am running 1024 768 85 Mhz. I did it all the time!

Just I've chcecked specs of my monitor and learned so pressing OSD button in front panel will present me horizontal and vertical refresh rate.
I see 68,7kHz/ 85,0Hz, while KDE says so I am running now with 50 Hz. I made several different settings in KDE. Monitor reacted accordingly, but every time there was a bias about 30 Hz between KDE and monitor refresh value.

When using drivers 8774 there was no bias.

I am sorry for bothering you. Thanks for your kind reply.

I would appreciate so you will tell me what that warning means

WARNING: Symbol version dump /usr/src/linux-2.6.17-5mdv/Module.symvers
is missing; modules will have no dependencies and modversions.

Just in case I am sending the latest bug report

My best regards,
Tomasz
Attached Files
File Type: gz bug report.tar.gz (30.2 KB, 137 views)
tikcop1 is offline   Reply With Quote
Old 01-06-07, 04:57 PM   #5
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: refresh rate of monitor

This is a KDE bug (misreporting of the refresh rate). The warning you posted is harmless with respect to NVIDIA driver functionality.
netllama is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Refresh rate fix for all Detonator drivers AshG NVIDIA Windows Graphics Drivers 45 04-27-03 04:55 PM
GeForce4 and dual monitor refresh rates elusive NVIDIA GeForce 7, 8, And 9 Series 1 10-04-02 02:47 AM
New 40.41 refresh rate fix ???? Smokey NVIDIA Windows Graphics Drivers 8 08-30-02 01:32 PM
Refresh rate fix for opengl? Zarich NVIDIA Windows Graphics Drivers 1 08-29-02 02:47 PM
Multi monitor refresh rate problem ascully General Hardware 6 07-31-02 02:56 PM

All times are GMT -5. The time now is 02:16 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.