Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-05-07, 05:49 PM   #1
JeffxxxPete
Registered User
 
Join Date: Oct 2002
Location: Champaign, IL
Posts: 11
Default XIO: Fatal IO error 104 with 'start x'

Hi, after installing the x86-1.0-9746 driver, Im getting bounced back to console(init 3) when starting X. I can run the native nv driver, where all is well, with the exception of OpenGl.

Ive checked previous posts relating to this issue, but the solutions are to no avail. Attached is the nvidia-bug-report.log and the nvidia-installer.log report. Thank you in advance for your help.


Jeff



Hardware:
Micron Millennia (desktop)
nVidia GeForce 2 Integrated GPU


OS:
Mandriva 2007
kernel 2.6.17.-5mdv
Attached Files
File Type: zip nvidia-installer.zip (4.4 KB, 100 views)
File Type: zip nvidia-bug-report.zip (19.8 KB, 93 views)
JeffxxxPete is offline   Reply With Quote
Old 01-05-07, 06:49 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: XIO: Fatal IO error 104 with 'start x'

In your bug report, I see:
(WW) NVIDIA(0): The NVIDIA GeForce2 Integrated GPU GPU installed in this
(WW) NVIDIA(0): system is supported through the NVIDIA 1.0-96xx Legacy
(WW) NVIDIA(0): drivers. Please visit
(WW) NVIDIA(0): http://www.nvidia.com/object/unix.html for more
(WW) NVIDIA(0): information. The 1.0-9746 NVIDIA driver will ignore this
(WW) NVIDIA(0): GPU. Continuing probe...
netllama is offline   Reply With Quote
Old 01-05-07, 10:55 PM   #3
JeffxxxPete
Registered User
 
Join Date: Oct 2002
Location: Champaign, IL
Posts: 11
Default Re: XIO: Fatal IO error 104 with 'start x'

Installed the 1.0-7184 driver as directed, able to get in, however, have the same OpenGl problems and receiving the error: "Glx is not supported with the composite extension" when logging off.


Jeff

Last edited by JeffxxxPete; 01-05-07 at 11:17 PM.
JeffxxxPete is offline   Reply With Quote
Old 01-05-07, 11:26 PM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: XIO: Fatal IO error 104 with 'start x'

You should be using the 1.0-96xx legacy driver (per the driver README), not 1.0-7184 which isn't meant for your GPU.
netllama is offline   Reply With Quote
Old 01-06-07, 06:39 PM   #5
JeffxxxPete
Registered User
 
Join Date: Oct 2002
Location: Champaign, IL
Posts: 11
Default Re: XIO: Fatal IO error 104 with 'start x'

I previously tried the 9629 and 9631 drivers, however, icons on the desktop and system tray would randomly appear/re-appear, so I thought they were unstable for my system. However, using the 7184 driver, and editing the xorg.conf file under the section 'Composite' 'Option' "Extension" to "disable", has enabled OpenGl programs and made the system reliable.

Last edited by JeffxxxPete; 01-09-07 at 04:38 PM.
JeffxxxPete is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Microsoft explained why they killed start button AthlonXP1800 Microsoft Windows 8 19 10-28-12 10:07 AM
Base mosaic and rotation? happyfunbot NVIDIA Linux 5 07-13-12 01:23 PM
Nero5.5.9.9 & "Empty Start Menu Entries" bug !!! cenkog General Software 2 09-21-02 01:57 AM
Debian sid w/ nForce - X won't start questioncolon NVIDIA Linux 16 08-05-02 11:35 AM

All times are GMT -5. The time now is 12:29 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.