Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-07-07, 05:26 PM   #1
rja
Registered User
 
Join Date: Jan 2007
Posts: 4
Default 9746 8800GTS kernel bug leaving X-session

boot to runlevel 3

startx -- -logverbose 6

NVIDIA logo is displayed and X-session starts properly.
Logout from X-session (doesn't seem to matter how long X is running).
Screen goes black, but green light is still lit on monitor, so not in power saving
mode.
Load average goes over 10.
After a few seconds there is a "beep" sound.
Screen stays black.
dmesg and syslog have:

BUG: soft lockup detected on CPU#0!
[<c04051db>] dump_trace+0x69/0x1af
[<c0405339>] show_trace_log_lvl+0x18/0x2c
[<c04058ed>] show_trace+0xf/0x11
[<c04059ea>] dump_stack+0x15/0x17
[<c044da6d>] softlockup_tick+0xad/0xc4
[<c042e57a>] update_process_times+0x39/0x5c
[<c0418914>] smp_apic_timer_interrupt+0x5c/0x64
[<c0404ad3>] apic_timer_interrupt+0x1f/0x24
DWARF2 unwinder stuck at apic_timer_interrupt+0x1f/0x24
Leftover inexact backtrace:
[<f9849b1e>] _nv004862rm+0x52/0x58 [nvidia]
[<f984a37b>] _nv008243rm+0x37/0x5c [nvidia]
[<f9849b38>] _nv004850rm+0x14/0x24 [nvidia]
[<f984bb0a>] _nv000120rm+0xee/0x114 [nvidia]
[<f984a3cb>] _nv008250rm+0x2b/0x34 [nvidia]
[<f98534d4>] _nv000216rm+0x18/0x2c [nvidia]
[<f984f857>] _nv000183rm+0xb/0x34 [nvidia]
[<f984a318>] _nv000309rm+0x80/0x98 [nvidia]
[<f984a308>] _nv000309rm+0x70/0x98 [nvidia]
[<f984a2a8>] _nv000309rm+0x10/0x98 [nvidia]
[<f984a042>] _nv003901rm+0x186/0x1c4 [nvidia]
[<f9aaa69e>] _nv004950rm+0x46/0xac [nvidia]
[<f983e578>] _nv003391rm+0xbc/0x348 [nvidia]
[<f983e561>] _nv003391rm+0xa5/0x348 [nvidia]
[<f999d03b>] _nv000871rm+0x4b/0x60 [nvidia]
[<f9948178>] _nv000917rm+0x810/0x98c [nvidia]
[<f98445ee>] _nv002536rm+0x2d2/0x534 [nvidia]
[<f98445a8>] _nv002536rm+0x28c/0x534 [nvidia]
[<f98a66c6>] _nv007005rm+0x196/0x2c0 [nvidia]
[<f98a66de>] _nv007005rm+0x1ae/0x2c0 [nvidia]
[<f9844e25>] _nv002668rm+0x471/0x720 [nvidia]
[<f983fa66>] _nv003371rm+0x32/0x38 [nvidia]
[<f9a2b30f>] _nv007213rm+0x23/0x28 [nvidia]
[<f980f943>] _nv011974rm+0x83/0xc4 [nvidia]
[<f983db2e>] _nv003397rm+0x12/0x18 [nvidia]
[<f9846846>] rm_change_res_mode+0x32/0xe8 [nvidia]
[<f98468d3>] rm_change_res_mode+0xbf/0xe8 [nvidia]
[<f9848e74>] _nv002552rm+0x304/0x770 [nvidia]
[<f9b5b6e5>] os_pci_read_dword+0x2b/0x34 [nvidia]
[<f984680c>] rm_ioctl+0x1c/0x24 [nvidia]
[<c04e8a82>] copy_from_user+0x40/0x6c
[<f9b59083>] nv_kern_ioctl+0x2fc/0x36d [nvidia]
[<c045fec9>] free_pgtables+0x90/0xa3
[<f9b592f1>] nv_kern_vma_release+0x6c/0x132 [nvidia]
[<f9b59129>] nv_kern_unlocked_ioctl+0x18/0x1d [nvidia]
[<f9b59111>] nv_kern_unlocked_ioctl+0x0/0x1d [nvidia]
[<c047f1d7>] do_ioctl+0x1f/0x62
[<c047f464>] vfs_ioctl+0x24a/0x25c
[<c047f4c2>] sys_ioctl+0x4c/0x66
[<c0404013>] syscall_call+0x7/0xb

Can still login remotely with ssh to shutdown.

I have nvidia-bug-reports both before the BUG (while X-session is running) and
after the BUG (while screen is blank and logged in remotely with ssh).
IF i can figure out how to attach a file...

BFGR88640GTSE BFG Nvidia GeForce 8800 GTS
Asrock 939DUAL-VSTA with latest BIOS
AMD Athlon64 3700+
Hannsg HW191D monitor
Linux goth.rogera.net 2.6.18-1.2869.fc6 #1 SMP Wed Dec 20 14:51:19 EST 2006 i686 athlon i386 GNU/Linux

Fedora Core 6 with atrpms packages
lirc-kmdl-2.6.18-1.2869.fc6-0.8.1-65_cvs20061130.fc6.at
[root@goth ~]# rpm -qa | grep -i nvidia | sort
nvidia-graphics-1.0.9746-17.at
nvidia-graphics9746-1.0_9746-84.fc6.at
nvidia-graphics9746-devel-1.0_9746-84.fc6.at
nvidia-graphics9746-kmdl-2.6.18-1.2869.fc6-1.0_9746-84.fc6.at
nvidia-graphics9746-libs-1.0_9746-84.fc6.at
nvidia-graphics-devel-1.0.9746-17.at
nvidia-graphics-devices-1.0-5.fc6.at
nvidia-graphics-helpers-0.0.17-18.fc6.at

Would it help debugging if I:

reported this problem somewhere else (this is my first post to nvnews)?
didn't load the lirc modules?
didn't boot with vga=792?
loaded fewer modules in xorg.conf?

Any other suggestions?
Attached Files
File Type: zip nvidia-bug-reports.zip (66.2 KB, 121 views)
rja is offline   Reply With Quote
Old 01-07-07, 05:39 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: 9746 8800GTS kernel bug leaving X-session

Yes, I'd be curious whether this problem persists if you are not booting with vga=792 (and/or vesafb support).

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 01-07-07, 06:08 PM   #3
rja
Registered User
 
Join Date: Jan 2007
Posts: 4
Default Re: 9746 8800GTS kernel bug leaving X-session

Yes, Lonni, removing the vga=792 works around the problem.

I had tried to search for "8800 kernel bug", but didn't get any hits.

Now, After searching for "8800", I found this thread that also mentions
not using framebuffer consoles:

http://www.nvnews.net/vbulletin/show...highlight=8800

Thanks for the quick and accurate response.

If a future version of the nvidia linux drivers allows G80's to work with
framebuffer consoles, I hope that it gets mentioned in the release notes.
rja is offline   Reply With Quote
Old 01-08-07, 11:49 AM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: 9746 8800GTS kernel bug leaving X-session

Thanks, I've opened bug 280128 for this issue.
netllama is offline   Reply With Quote
Old 03-09-07, 03:22 PM   #5
rja
Registered User
 
Join Date: Jan 2007
Posts: 4
Default Re: 9746 8800GTS kernel bug leaving X-session - fixed with 9755

After upgrading from 9746 to 9755, I can boot an 8800GTS with vga=792.

[root@goth ~]# cat /proc/cmdline
ro root=LABEL=/ 3 vga=792

I can run startx and logout repeatedly without a kernel bug. It just drops back to the normal console prompt.

kernel-2.6.19-1.2911.6.5.fc6
nvidia-graphics-1.0.9755-18.at
nvidia-graphics9755-1.0_9755-86.fc6.at
nvidia-graphics9755-devel-1.0_9755-86.fc6.at
nvidia-graphics9755-kmdl-2.6.19-1.2911.6.5.fc6-1.0_9755-86.fc6.at
nvidia-graphics9755-libs-1.0_9755-86.fc6.at
nvidia-graphics-devel-1.0.9755-18.at
nvidia-graphics-devices-1.0-5.fc6.at
nvidia-graphics-helpers-0.0.18-19.fc6.at

Thanks for taking care of this.
rja is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Random crashes, NVRM Xid messages Iesos NVIDIA Linux 90 10-04-12 03:27 AM
Corrupted display - 302.17 - Dell Precision T3500 (G98 [Quadro NVS 295]) gbailey NVIDIA Linux 1 06-27-12 10:24 AM
UEFI+Nvidia - NVRM: Your system is not currently configured to drive a VGA console... interzoneuk NVIDIA Linux 0 06-26-12 04:51 AM
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 11:04 AM
Crash when logout from X TGL NVIDIA Linux 10 09-13-02 08:22 PM

All times are GMT -5. The time now is 04:16 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.