Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-08-07, 12:13 PM   #1
darkroom7
Registered User
 
Join Date: Jan 2007
Posts: 3
Default Using 2 nvidia cards for dual display but second display is blank

I have an AGP GeForce FX5200 and a PCI RIVA TNT2 Model 64/Model 64 Pro. I'm trying to use both at the same time in a dual monitor setup (normal mode, not xinerama) where i can drag windows between the monitors but when i maximize the window it only fills the monitor it is on, not both monitors. This was working just fine before I upgraded from SuSE 10.0 to 10.1 so I know its possible, but I don't have my old xorg.conf file.

The problem right now is that the AGP FX5200 side comes up just fine, but the PCI TNT2 side remains blank. I can move the cursor between the monitors but when I move to the PCI TNT2 side the cursor changes from the pointer to the X cursor (like when KDE isn't running and you just have X-windows). So there is no actual desktop on the TNT2 side and I can't drag windows there or actually do anything on that size besides move the mouse cursor around.

I'm using the legacy driver 1.0.7184 because the newer drivers don't support the TNT2. So both devices are using the legacy driver. This is a little tangent, but is it possible to use 2 nvidia drivers at the same time, like the legacy driver for the TNT2 and a newer driver for the FX5200? Can I just rename the nvidia_drv.o to nvidia-legacy_drv.o or something and then install the newer driver with it? Or maybe unpack the .run installer and change a few lines in the source files to give the module a new name and then compile it so they don't conflict?



== Here are some hopefully useful parts of xorg.conf: ==

Code:
Section "Monitor"
  Identifier   "Monitor[0]"
  VendorName   "SONY"
  ModelName    "CPD-G220R"
  #Option       "CalcAlgorithm" "XServerPool"
  DisplaySize  310 230
  HorizSync    30-85
  Option       "DPMS"
  VertRefresh  48-170
  #UseModes     "Modes[0]"
EndSection

Section "Monitor"
  Identifier   "Monitor[1]"
  VendorName   "SAMTRON"
  ModelName    "76DF77DF"
  #Option       "CalcAlgorithm" "XServerPool"
  DisplaySize  320 240
  HorizSync    30-70
  VertRefresh  50-160
  #UseModes     "Modes[1]"
EndSection


Section "Modes"
  Identifier   "Modes[0]"
EndSection

Section "Modes"
  Identifier   "Modes[1]"
EndSection


Section "Device"
  Identifier   "Device[0]"
  VendorName   "NVidia"
  BoardName    "GeForce FX 5200 (0x0322)"
  BusID        "PCI:1:5:0"
  Driver       "nvidia"
  Option       "NoFlip" "True"
  Option       "RenderAccel" "True"
  Option       "DPMS"
  Option       "IgnoreEDID" "1"
  Option       "DisableGLXRootClipping" "True"
  #Option       "TwinView"
  #Option       "TwinViewOrientation" "LeftOf"
  #Option       "MetaModes" "1280x1024, 1280x1024"
  #Option       "SecondMonitorHorizSync" "30-70"
  #Option       "SecondMonitorVertRefresh" "50-160"
  Screen 0
EndSection

Section "Device"
  Identifier   "Device[1]"
  VendorName   "NVidia"
  BoardName    "RIVA TNT2 Model 64/Model 64 Pro"
  BusID        "PCI:0:11:0"
  Driver       "nvidia"
  Option       "NoFlip" "True"
  Option       "RenderAccel" "True"
  Option       "DPMS"
  Option       "IgnoreEDID" "1"
  Option       "DisableGLXRootClipping" "True"
  Screen 1
EndSection


Section "Screen"
  Identifier   "Screen[0]"
  Device       "Device[0]"
  Monitor      "Monitor[0]"
  DefaultDepth 24
  SubSection "Display"
    Depth      24
    Modes      "1280x1024" "1024x768" "800x600"
  EndSubSection
EndSection

Section "Screen"
  Identifier   "Screen[1]"
  Device       "Device[1]"
  Monitor      "Monitor[1]"
  DefaultDepth 24
  SubSection "Display"
    Depth      24
    Modes      "1280x1024" "1024x768" "800x600"
  EndSubSection
EndSection


Section "ServerLayout"
  Identifier   "Layout[all]"
  InputDevice  "Keyboard[0]" "CoreKeyboard"
  InputDevice  "Mouse[1]" "CorePointer"
  Option       "Xinerama"
  Screen 0      "Screen[0]" 0 0
  Screen 1      "Screen[1]" RightOf "Screen[0]"
EndSection


Section "DRI"
    Group      "video"
    Mode       0660
EndSection

Section "Extensions"
  Option       "Composite" "off"
EndSection


== Here are some hopefully useful parts of nvidia-bug-report.log ==

Code:
Date: Mon Jan  8 11:42:30 EST 2007
uname: Linux neuromancer 2.6.16.27-0.6-default #1 Wed Dec 13
 09:34:50 UTC 2006 i686 athlon i386 GNU/Linux

____________________________________________

/proc/driver/nvidia/version
NVRM version: NVIDIA Linux x86 Kernel Module  1.0-7184  Tue
Aug  1 18:38:58 PDT 2006
GCC version:  gcc version 4.1.0 (SUSE Linux)

____________________________________________

/proc/driver/nvidia/cards/0
Model:           RIVA TNT2 Model 64/Model 64 Pro
IRQ:             10
Video BIOS:      03.05.00.10.00
Card Type:       PCI

____________________________________________

/proc/driver/nvidia/cards/1
Model:           GeForce FX 5200
IRQ:             11
Video BIOS:      04.34.20.56.51
Card Type:       AGP

____________________________________________

/proc/driver/nvidia/agp/card
Fast Writes:     Supported
SBA:             Supported
AGP Rates:       4x 2x 1x
Registers:       0x1f000217:0x0f000104

____________________________________________

/proc/driver/nvidia/agp/host-bridge
Host Bridge:     PCI device 1022:700e
Fast Writes:     Supported
SBA:             Supported
AGP Rates:       4x 2x 1x
Registers:       0x0f000217:0x00000104

____________________________________________

/proc/driver/nvidia/agp/status
Status:          Enabled
Driver:          AGPGART
AGP Rate:        4x
Fast Writes:     Disabled
SBA:             Disabled

____________________________________________

...

/proc/driver/nvidia/registry
VideoMemoryTypeOverride: 1
EnableVia4x: 0
EnableALiAGP: 0
NvAGP: 3
ReqAGPRate: 15
EnableAGPSBA: 0
EnableAGPFW: 0
SoftEDIDs: 1
Mobile: 4294967295
ResmanDebugLevel: 4294967295
FlatPanelMode: 0
DevicesConnected: 0
VideoEnhancement: 0
RmLogonRC: 1
ModifyDeviceFiles: 1
DeviceFileUID: 0
DeviceFileGID: 0
DeviceFileMode: 438
VbiosFromROM: 0
RemapLimit: 0
UseCPA: 4294967295

____________________________________________

/proc/cmdline
root=/dev/md0 vga=0x31a resume=/dev/hda5 splash=silent
Attached Files
File Type: gz nvidia-bug-report.log.tar.gz (30.9 KB, 85 views)

Last edited by darkroom7; 01-08-07 at 12:30 PM. Reason: added nvidia-bug-report.log file
darkroom7 is offline   Reply With Quote
Old 01-09-07, 09:22 AM   #2
darkroom7
Registered User
 
Join Date: Jan 2007
Posts: 3
Default Re: Using 2 nvidia cards for dual display but second display is blank

i guess no one else has any idea what might cause my second monitor to not display a desktop? i'm assuming its a configuration problem, since this setup worked for me before. am i in the wrong place?

i've also noticed that if i turn xinerama on, while the FX5200 is still the only side to display anything, the login box is split in half between my two screens, as it should be, but when i mouse over to the blank TNT2 side monitor and hover over where the other half of the login username/password fields are the cursor changes from the X cursor to the text cursor. so it seems like the desktop is really under there but the screen is just not rendered for some reason.

any ideas?
darkroom7 is offline   Reply With Quote
Old 01-09-07, 02:15 PM   #3
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Using 2 nvidia cards for dual display but second display is blank

You can only use one NVIDIA driver version at a time. I don't see anything in your bug report that would suggest a driver problem. This seems like a window manager configuration issue.
netllama is offline   Reply With Quote
Old 01-10-07, 01:03 PM   #4
darkroom7
Registered User
 
Join Date: Jan 2007
Posts: 3
Default Re: Using 2 nvidia cards for dual display but second display is blank

thanks for the reply. i actually just got this working today. you're right, there was a window manager config problem. both monitors have desktops now. thanks again.
darkroom7 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Russian Masterpieces Put on Display Using NVIDIA GPU Technology News Archived News Items 0 06-25-12 04:10 PM
[Ubuntu] nVidia driver 1.0.8762 and black screen Manthis NVIDIA Linux 5 05-26-12 07:03 PM
302.07 (beta) for Linux x86/x86_64 released AaronP NVIDIA Linux 0 05-02-12 09:55 AM
Glx mrbig1344 NVIDIA Linux 7 09-30-02 06:45 AM

All times are GMT -5. The time now is 10:50 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.