Go Back   nV News Forums > Linux Support Forums > General Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-26-04, 02:46 PM   #1
FragOnly
Registered User
 
Join Date: Sep 2004
Posts: 17
Default Random X Server crashes

Hello, I am expierence random X server crashes.
They can happen anywhere from 5 minutes to about 48 hours. Nothing seems to trigger them, they just happen.
Logs dont report any errors. When X crashes it doenst report any errors. All programs that were running just report that they lost the x server and are closing.

This happens under multiple window managers, (fvwm, fluxbox, kde), and under multiple versions of X (XFree86, Xorg 6.7 and 6.8)

I am running a Asus mother board. With a GeForce FX 5600 and a Intel Pentium 4.

I have run memtest and it reports no errors.
FragOnly is offline   Reply With Quote
Old 09-26-04, 07:32 PM   #2
whig
550Ti
 
Join Date: Jan 2004
Location: New Zealand
Posts: 854
Default Re: Random X Server crashes

One thing: use the latest production kernel and compile it yourself. Distribution kernels may have security fixes but not all the general bug fixes.
whig is offline   Reply With Quote
Old 09-26-04, 10:22 PM   #3
holmes
Registered User
 
holmes's Avatar
 
Join Date: Aug 2004
Location: El Paso, TX
Posts: 692
Default Re: Random X Server crashes

When you say X server crashes does that mean that it freezes or reboots completely, etc? I recently upgraded my kernel from a distro specific 2.6.3-x to the latest 2.6.8.1 ... All I can say is that the 2.6.8.1 kernel is a FAR better kernel. I've yet to experience any kind of stability problems. UT2004 and Americas Army run beautifully too... Might want to give it a shot..
__________________

The Rig
ASRock 970 Extreme3 AM3+
AMD Athlon II x2 260
DDR3-1600 (2x2GB) Kingston HyperX
Western Digital caviar 1TB
ECS GeForce GT 220 1GB
Cooler Master Storm Scout ATX case
Corsair 750W PSU
holmes is offline   Reply With Quote
Old 09-27-04, 01:26 PM   #4
FragOnly
Registered User
 
Join Date: Sep 2004
Posts: 17
Default Re: Random X Server crashes

When i say X server crashes I mean, screen goes back to console mode (im a firm beleaver of running in console, and launching x from there ) with no errors, no log errors, and thats about it. No lock ups, i can happily restart X and it'll work until it crashes again.
FragOnly is offline   Reply With Quote
Old 10-05-04, 10:24 AM   #5
froycard
Registered User
 
Join Date: Apr 2003
Posts: 12
Send a message via ICQ to froycard Send a message via Yahoo to froycard
Default Re: Random X Server crashes

Yesterday I posted this thread at LINUX FORUM (http://www.linuxforums.org/forum/topic-25393.html) , maybe you like to share your thoughts about what I said:

I had to give up trying to set up this distro (MANDRAKE 10, download version) since I couldn't make it work fine on my NVIDIA mobo PC.

It seems that distro wass plagued with a bunch of bugs so that my PC froze every now and then. As long as you don't install the correct drivers (NVIDIA OFFICIAL DRIVERS) the system seems stable, but you can't do a lot without XWindow 3D applicantions (at least for me, that I like to take the most out of my hardware) and without setting up a 5.1 Speaker system. I guess if you stick with a basic system, u can live with it (I guess).

If you install any of this NFORCE or VIDEO NVIDIA drivers you can download off Internet (at www.nvidia.com) prepare to experience erratic behavior and constant XWindows freezings. I could see that only by installing NFORCE (for the sound card), the computer froze just before you could ever login on to the Linux Prompt.

Maybe I need to further tweak those drivers so it could make my system more stable or get rid of those hanging problems.

On the other hands, I could install RED HAT ver. 9 on my computer and the drivers for the NVIDIA mobo and my FX5200 and I can see astonishing that my computer works pretty fine, and without getting all of those abovementioned issues.

I posted this new thread in order to discuss and share views or opinions with all of ppl that have the same Mandrake problem running on a Nvidia based mobo.

For the gurus and whoever needs more info about my system, these are my specs:

MOBO: BIOSTAR M7NGC
CPU: AMD ATHLON XP 2200+
RAM: 512 MB
HARDDISK: WD 80GB / Partition: 5GB
*** VIDEO CARD: NVIDIA FX 5200


later

Froy (from Venezuela)

ps: Excuse my English, folks
froycard is offline   Reply With Quote
Old 10-29-04, 12:47 PM   #6
FragOnly
Registered User
 
Join Date: Sep 2004
Posts: 17
Default Re: Random X Server crashes :(

I tried disabling AGP totaly, and thought it'd been fixed but it crashed again last night, same old crash. No errors nothing to report, just "lost" x server.
FragOnly is offline   Reply With Quote
Old 10-29-04, 02:33 PM   #7
froycard
Registered User
 
Join Date: Apr 2003
Posts: 12
Send a message via ICQ to froycard Send a message via Yahoo to froycard
Default Re: Random X Server crashes

Just download the Mandrake 10.1 Community Edition... far more stable and supports NVIDIA new drivers... give it a try...

Froy

froycard is offline   Reply With Quote
Old 10-29-04, 05:44 PM   #8
holmes
Registered User
 
holmes's Avatar
 
Join Date: Aug 2004
Location: El Paso, TX
Posts: 692
Default Re: Random X Server crashes

The only way I got rid of stability problems with MDK 10.0 and the default 2.6.3-7 kernel was compiling in a new one. Currently running 2.6.7 kernel and I couldn't be happier. Haven't tried MDK 10.1 though...
__________________

The Rig
ASRock 970 Extreme3 AM3+
AMD Athlon II x2 260
DDR3-1600 (2x2GB) Kingston HyperX
Western Digital caviar 1TB
ECS GeForce GT 220 1GB
Cooler Master Storm Scout ATX case
Corsair 750W PSU
holmes is offline   Reply With Quote

Old 01-07-07, 09:16 AM   #9
lyon
Registered User
 
Join Date: Jan 2007
Posts: 2
Default Re: Random X Server crashes

Hi All,
I would like to disable all graphic card opengl
hardware acceleration in order to properly debug
my nvida card under Fedora 6. Right now, I can
run xwindows, remotely, but, for some reason, Java3D is
not running (throwing interesting Java exceptions).

How do I fix it so that Xwindows renders opengl in software on the
local machine and only transmits bit maps to the remote display?

I am running XWindows on the mac and connecting to the
Fedora box remotely.

Thanks!
Regards,
- Doug Lyon
lyon is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fujitsu Marries GPUs and Xeon in High-Density HPC Server News Archived News Items 0 06-13-12 06:30 PM
X Server 1.11.3(Ubuntu 12.04) crashes just after start on Geforce 9400(driver 295.40) peat NVIDIA Linux 1 05-10-12 06:00 AM
Random loot packs are the best-selling item in free-to-play City of Heroes News Archived News Items 0 05-06-12 11:00 AM
Crashes now? Imperito NVIDIA Linux 4 10-09-02 11:23 PM
XF86COnifg-4 configuring and server crashes JoeJaz100 NVIDIA Linux 2 10-01-02 09:49 AM

All times are GMT -5. The time now is 06:57 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.