Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-30-06, 12:55 PM   #1
budurahm
Registered User
 
Join Date: Dec 2006
Posts: 1
Default 8800GTX & SuSe 10.2 = BlackScreen

Anyone out there got SUSE 10.2 & the Nvidia GeForce 8800GTX working together.
I tried the drivers supplied but SUSE just hangs with a black screen when you try to restart X


Edit: Well after many hours of playing with Xorg.conf and trying all kinds of stuff.. I've gotten the 3D working to a degree. 3D Screensavers work at full speed
and the NVidia logo appears at boot.. but If you log off, it hangs at a blackscreen.. have to shutdown/restart.. cant logout
and none of the 3D Desktop effects work.. can't enable em.. pfft..

I really don't know why I keep trying to get 3D working in linux... sucker for pain I guess..

Thanks
Happy NewYears

Last edited by budurahm; 12-30-06 at 09:37 PM.
budurahm is offline   Reply With Quote
Old 12-31-06, 03:05 AM   #2
triplah
Registered User
 
Join Date: Dec 2006
Posts: 4
Default Re: 8800GTX & SuSe 10.2 = BlackScreen

I'm getting the same behaviour. I've included a log from before the hang, and one i grabbed through ssh after the hang.

distro is gentoo. other info looks to be in the log files
Attached Files
File Type: txt nvidia-bug-report.log-after.txt (66.0 KB, 136 views)
File Type: txt nvidia-bug-report.log-before.txt (66.1 KB, 114 views)

Last edited by triplah; 12-31-06 at 04:11 AM. Reason: fixed attachments
triplah is offline   Reply With Quote
Old 01-12-07, 01:46 AM   #3
triplah
Registered User
 
Join Date: Dec 2006
Posts: 4
Default Re: 8800GTX & SuSe 10.2 = BlackScreen

i'm aware this was posted over new years / christmas break

so this is a bump.

cheers
triplah is offline   Reply With Quote
Old 01-12-07, 11:50 AM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: 8800GTX & SuSe 10.2 = BlackScreen

I don't see anything in your 'after' bug report that suggests an nvidia driver bug. In fact, I don't see any signs of problems at all. Are you sure that this bug report was generated while the problem was present?

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 01-12-07, 03:40 PM   #5
derbuffer
Registered User
 
Join Date: Dec 2006
Posts: 10
Default Re: 8800GTX & SuSe 10.2 = BlackScreen

Hi budurahm

First you've to install the nvidia-97.46 driver (download it at the nvidia-driver-homepage)

Then edit the /boot/grub/menu.lst

change the vga= parameter to vga=normal.

This should work.

Greetings
derbuffer is offline   Reply With Quote
Old 01-12-07, 04:30 PM   #6
triplah
Registered User
 
Join Date: Dec 2006
Posts: 4
Default Re: 8800GTX & SuSe 10.2 = BlackScreen

Quote:
Originally Posted by netllama
I don't see anything in your 'after' bug report that suggests an nvidia driver bug. In fact, I don't see any signs of problems at all. Are you sure that this bug report was generated while the problem was present?

Thanks,
Lonni
Hi netllama,

I would have questioned my own sanity too if it wasnt for the fact that it only happens with the new nvidia drivers and my 8800GTX. This doesnt occur using the vga driver.

The bug report was definatly dumped WHILE the display was blackscreened and locked. I had too ssh in to get the report.

I'll try derbuffer's advice and post back. cheers

dpn
triplah is offline   Reply With Quote
Old 01-12-07, 04:32 PM   #7
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: 8800GTX & SuSe 10.2 = BlackScreen

Actually, if disabling the console framebuffer eliminates the problem, then this is a known bug.
netllama is offline   Reply With Quote
Old 01-12-07, 04:42 PM   #8
triplah
Registered User
 
Join Date: Dec 2006
Posts: 4
Default Re: 8800GTX & SuSe 10.2 = BlackScreen

Quote:
Originally Posted by netllama
Actually, if disabling the console framebuffer eliminates the problem, then this is a known bug.

well, sorry i didnt find out about that. because vga=normal instead of my previous mode has got it working (of sorts) now.

Cheers!

dpn
triplah is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Geforce 440 Go, SuSE 8.0, and new Nvidia drivers loudawg NVIDIA Linux 4 06-01-04 12:54 AM
My SuSE 8.0 just totally BROKE. Help please!!! sephiroth762 NVIDIA Linux 6 10-09-02 02:30 PM
Suse 8.1 and Nvidia drivers tombraider500 NVIDIA Linux 4 10-06-02 11:19 AM
Newbie - Compiling my own for SuSe 8.0 jocephus19 NVIDIA Linux 5 09-01-02 09:38 PM
Trouble with SuSE 8 & NVIDIA latest driver bughill NVIDIA Linux 3 08-20-02 12:31 PM

All times are GMT -5. The time now is 07:12 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.