Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-10-07, 12:54 PM   #1
tim.stephens
Registered User
 
Join Date: Jan 2007
Posts: 2
Default FC6 (2.6.18-1.2869.fc6) + FX5200 + 9742 nvidia driver = black screen when X starts

Hello,

I've had no luck getting the nvidia drivers (tried several versions) to work on my Fedora Core 6 system. The stock nv driver installed with Fedora Core 6 works great.

When I use the nvidia driver, after start X then screen goes black and nothing is visable after that. I am unable to switch to any of the virtual consoles, but SSH still works.

This same hardware configuration worked great on Fedora 2, which I believe was running with the 8776 driver.

Kernel: 2.6.18-1.2869.fc6
MSI FX5200 AGP card
MAG LCD monitor attached to VGA port of FX5200
Chaintech 7NIL2 motherboard
AMD Athlon Processor

Attached is my nvidia-bug-report.log file that was generated after running startx -- -logverbose 6. I did not see any glaring issues with the log file.

Any help would be much appreciated.
Attached Files
File Type: zip nvidia.zip (28.8 KB, 142 views)
tim.stephens is offline   Reply With Quote
Old 01-10-07, 02:42 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: FC6 (2.6.18-1.2869.fc6) + FX5200 + 9742 nvidia driver = black screen when X starts

I have a few questions:
0) Does this problem persist with 1.0-9746 as well?
1) Have you verified that you're using the latest motherboard BIOS?
2) If you set NvAGP to 0 in xorg.conf does that help?

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 01-11-07, 12:58 PM   #3
tim.stephens
Registered User
 
Join Date: Jan 2007
Posts: 2
Default Re: FC6 (2.6.18-1.2869.fc6) + FX5200 + 9742 nvidia driver = black screen when X start

Using the same 9742 driver, setting NvAGP to 0 fixed the problem.

I am going to continue debugging this issue and report my findings.

I was not successful in upgrading the flash bios due to not having a floppy drive installed on the PC. This motherboard has an on-board flash BIOS updater (phoenix/awardbios) that needs to load the BIOS off a floppy. I will attempt the BIOS upgrade this weekend.

If the BIOS upgrade does not fix the issue, I will then upgrade to the 1.0-9746 driver.

Any other steps I should take, now that we know this has something to do with the AGP?

Thanks for your help

-Tim
tim.stephens is offline   Reply With Quote
Old 01-11-07, 01:05 PM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: FC6 (2.6.18-1.2869.fc6) + FX5200 + 9742 nvidia driver = black screen when X starts

You could test with different values for NvAGP, or try setting a lower AGP rate either in the driver (see the README for details) or in your BIOS (if possible). However, this looks like an AGP problem, and not an nvidia driver problem based on the information here.
netllama is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
[9800gt] Xorg black screen after installing nvidia driver HacKurx NVIDIA Linux 1 06-07-12 02:29 PM
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 09:35 PM
Redhat 8.0 NVIDIA works - INSTRUCTIONS STEEL1 NVIDIA Linux 267 04-15-03 07:48 PM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 09:49 AM
nvidia + 2.4.19 gentoo = messed up ulukay NVIDIA Linux 18 11-02-02 12:58 AM

All times are GMT -5. The time now is 02:40 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.