Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-12-07, 08:44 PM   #1
tmorin
Registered User
 
Join Date: Jan 2007
Posts: 2
Smile Solved? - 1440x900 left 1/10th side of screen is blank

Check out this thread as its closer to getting solved. - Basically the nvidia driver cant run my display at 75 hz even though the display supports it. Somehow the nvidia driver is using a 75 Hz refresh rate during the login manager screen and switching to 60 hz for the desktop.

http://www.kde-forum.org/thread.php?...1375#post61375


I've installed the legacy nvidia drivers for the Geforce4 MX4400 i have. I have a viewsonic display. The nvidia splash screen also has a black strip on the left hand side. I can switch to 1024x768 and get the full (fuzzy) screen. but not the native resolution. I'm using Suse 10.2.

I also tried an option in the xorg.conf file Option "ModeValidation" "NoDFPNativeResolutionCheck: this didn't have any effect.

Update : used nvidia installer to uninstall and start again. No change
ran nvidia-settings from a shell. attached are the error messages dumped to the shell by nvidia-settings.

I'm using the NVIDIA-Linux-x86-1.0-9631-pkg1 drivers

updated the log file while x was in verbose 6 mode.

Update: tried adding this to the Device section of xorg.conf >> reboot >> no change

Option "ExactModeTimingsDVI"
Option "ModeValidation" "NoDFPNativeResolutionCheck"

Update: Tried adding Option "NvAGP" "1" to the Device section >> reboot >> no change

Update: Tried adding Option "ModeValidation" "NoEdidDFPMaxSizeCheck" to the Device section >> reboot >> no change

Hmm ... I'm getting no errors in the nvidia log file and the 1440x900 mode has been validated by the driver.


Update: Either of these two options being enabled shift my screen back to the left. However the vertical size of the screen is now a little to large and the screen is fuzzy.
# Option "UseEDIDFreqs" "FALSE"
# Option "ModeValidation" "NoEdidModes"

relevant part of xorg.conf file :

Section "Modes"
Identifier "Modes[0]"
ModeLine "1440x900" 127.0 1440 1536 1688 1936 900 901 904 937 +hsync +vsync
EndSection

Section "Monitor"
Identifier "Monitor[0]"
VendorName "--> LCD"
ModelName "1440X900@70HZ"
UseModes "Modes[0]"
DisplaySize 305 230
HorizSync 30.0 - 90.0
VertRefresh 58.0 - 72.0
Option "CalcAlgorithm" "XServerPool"
Option "DPMS"
EndSection

Section "Device"
Identifier "Device[0]"
Driver "nvidia"
VendorName "NVIDIA"
BoardName "GeForce4 MX 4000"
Screen 0
# Option "UseEDIDFreqs" "FALSE"
# Option "ModeValidation" "NoEdidModes"
# Option "UseEDIDDpi" "FALSE"
# Option "IgnoreEDID" "true"
# Option "ModeValidation" "NoEdidDFPMaxSizeCheck"
# Option "NvAGP" "1"
# Option "ExactModeTimingsDVI"
# Option "ModeValidation" "NoDFPNativeResolutionCheck"
EndSection

Section "Screen"
Identifier "Screen[0]"
Device "Device[0]"
Monitor "Monitor[0]"
DefaultDepth 24
SubSection "Display"
Depth 15
Modes "1440x900" "1366x768" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1440x900" "1366x768" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1440x900" "1366x768" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1440x900" "1366x768" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
EndSection

Ok Steps I took to at least get KDE to align itself properly on my screen. I now have native resolution for KDE. The nvidia splash screen and user logon screens are still shifted to the right.

>> I connected my monitor directly to my graphics card - not through my KVM (Belkin Flip).
>> uninstalled nvidia drivers using nvidia-install --uninstall
>> reboot
>>installed nvidia drivers using sh NVIDIA-Linux-x86-1.0-9631-pkg1.run -q as stated on nvidia's website for users of Suse.
>> reboot
>> no visible change
>> went into KDE desktop configuration tool >> selected Display >> set to 1440x900
>> bang screen snapped to the display
>> launched nvidia-settings, it is now "auto select" for resolution. it shows 1440x900 as the resolution.

reboot and did the same for root's desktop

my xorg.conf file now looks like this: (modeline's were removed by sax2 it appears)

# /.../
# SaX generated X11 config file
# Created on: 2007-01-13T14:18:03-0600.
#
# Version: 8.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [ISaX] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "Files"
FontPath "/usr/share/fonts/misc:unscaled"
FontPath "/usr/share/fonts/local"
FontPath "/usr/share/fonts/75dpi:unscaled"
FontPath "/usr/share/fonts/100dpi:unscaled"
FontPath "/usr/share/fonts/Type1"
FontPath "/usr/share/fonts/URW"
FontPath "/usr/share/fonts/Speedo"
FontPath "/usr/share/fonts/PEX"
FontPath "/usr/share/fonts/cyrillic"
FontPath "/usr/share/fonts/latin2/misc:unscaled"
FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
FontPath "/usr/share/fonts/latin2/Type1"
FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
FontPath "/usr/share/fonts/baekmuk:unscaled"
FontPath "/usr/share/fonts/japanese:unscaled"
FontPath "/usr/share/fonts/kwintv"
FontPath "/usr/share/fonts/truetype"
FontPath "/usr/share/fonts/uni:unscaled"
FontPath "/usr/share/fonts/CID"
FontPath "/usr/share/fonts/ucs/misc:unscaled"
FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/misc:unscaled"
FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/Type1"
FontPath "/usr/share/fonts/misc/sgi:unscaled"
FontPath "/usr/share/fonts/xtest"
FontPath "/opt/kde3/share/fonts"
FontPath "unix/:7100"
InputDevices "/dev/gpmdata"
InputDevices "/dev/input/mice"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail" "on"
EndSection

Section "Module"
Load "dbe"
Load "type1"
Load "freetype"
Load "extmod"
Load "glx"
Load "v4l"
EndSection

Section "InputDevice"
Driver "kbd"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "us"
Option "XkbModel" "pc104"
Option "XkbRules" "xfree86"
EndSection


Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "Buttons" "5"
Option "Device" "/dev/input/mice"
Option "Name" "Colorado USB Optical Mouse"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection


Section "Monitor"
Option "CalcAlgorithm" "XServerPool"
DisplaySize 408 255
HorizSync 30-82
Identifier "Monitor[0]"
ModelName "VIEWSONIC VX1935WM"
Option "DPMS"
VendorName "VSC"
VertRefresh 43-85
UseModes "Modes[0]"
EndSection


Section "Modes"
Identifier "Modes[0]"
EndSection


Section "Screen"
DefaultDepth 24
SubSection "Display"
Depth 15
Modes "1440x900" "1366x768" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1440x900" "1366x768" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1440x900" "1366x768" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1440x900" "1366x768" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection


Section "Device"
BoardName "GeForce4 MX 4000"
BusID "1:0:0"
Driver "nvidia"
Identifier "Device[0]"
VendorName "NVIDIA"
EndSection


Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
Screen "Screen[0]"
EndSection


Section "DRI"
Group "video"
Mode 0660
EndSection

Section "Extensions"
EndSection


I still have to get the nvidia splash screen to align itself properly.

Tim

Last edited by tmorin; 01-15-07 at 10:28 PM. Reason: Update again
tmorin is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
NVS3100 (Thinkpad T410) blank screen on resume NvFuchs NVIDIA Linux 2 05-15-12 02:02 PM

All times are GMT -5. The time now is 02:07 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.