Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-14-07, 05:14 AM   #1
xenesis
Registered User
 
Join Date: Jan 2007
Posts: 4
Default [Geforce 7950GT] Wrong color depth on KUbuntu

Hello,
I have installed the recent drivers from Nvidia on my KUbuntu system. However there is a strange problem:
After starting up KDE, the color depth is 16bit (I can see that because the wallpaper looks strange). Everything else works, even 3D (tested with the OpenGL Screensavers), expect that it looks ugly because of the color depth.
But when I run the nvidia-settings tool, my screen suddenly switches to the right 24bit color depth.
Strange isn't it?
I have tried several settings in my xorg.conf (including commenting out every mode witch uses less than a 24bit color depth), but it still doesn't work.

Any idea what i should do?
I attach my xorg.conf, nvidia-installer.log, nvidia-bug-report.log in this ZIP file
Nvidia.zip

PS: to the nvidia-developers: could you add the Geforce 7950 GT to the "supported cards list". Because this card doesn't appear there but it seems to work with the current driver.
xenesis is offline   Reply With Quote
Old 01-19-07, 07:21 AM   #2
xenesis
Registered User
 
Join Date: Jan 2007
Posts: 4
Default Re: [Geforce 7950GT] Wrong color depth on KUbuntu

Ok, i have found out the following:
I stopped my KDE via
Code:
sudo /etc/init.d/kdm stop
and then did once
Code:
sudo /etc/init.d/kdm start
this gave me again 16bit colors
but using
Code:
startx
gave my the correct 24bit colors
confusing isn't it?

Furthermore i found this line in my Xorg.log file:
Code:
(--) PCI:*(6:0:0) nVidia Corporation unknown chipset (0x0295) rev 161, Mem @ 0xfd000000/24, 0xd0000000/28, 0xfc000000/24, I/O @ 0xec00/7, BIOS @ 0xfebe0000/17
Does this mean the 7950GT is really not supported?
When will it be supported?
xenesis is offline   Reply With Quote
Old 01-19-07, 10:50 AM   #3
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: [Geforce 7950GT] Wrong color depth on KUbuntu

Check /usr/kde/*/share/config/kdm/kdmrc and look at the ServerCmd and ServerArgsLocal lines to see if either of them specify a depth of 16bpp.

Your GeForce 7950GT is supported. The "nVidia Corporation unknown chipset" message comes from the pci.ids file, which is not maintained by NVIDIA.
AaronP is offline   Reply With Quote
Old 01-19-07, 02:07 PM   #4
xenesis
Registered User
 
Join Date: Jan 2007
Posts: 4
Default Re: [Geforce 7950GT] Wrong color depth on KUbuntu

Thanks for your answer. However it didn't help.
I found the file kdmrc under /etc/kde3/kdm
There was nothing under ServerCmd and ServerArgsLocal that would force KDE to use 16bit color. However i am doubting now it is 16bit.

I just wanted to try around and wrote to ServerArgsLocal:
Code:
ServerArgsLocal = -depth 24
That didn't work. As i restarted a short time the screen had really 24bit. But only for one second, then it switched back.

Ok, as i said, i am doubting now, that my strange colors are really 16bit.
Because i added
Code:
ServerArgsLocal = -depth 16
And then i realized: This gave me not the screen than before. So the colors i see without this option are NOT 16bit but some other wrong color (It isn't 8 bit, for this it looks to good )

Unfortunately i can't send you a screenshot, because when i take a screenshot and open it again in windows, it looks like 24bit color. But i have taken a photo via my digi cam.
Click image for larger version

Name:	IMG_0054.JPG
Views:	232
Size:	37.0 KB
ID:	23622

I'll test now if it works if i use VGA instead of DVI to connect my monitor.
Who knows perhaps it works...
[EDIT] It does also not work with VGA
xenesis is offline   Reply With Quote
Old 02-10-07, 10:20 AM   #5
Turb
Registered User
 
Join Date: Feb 2007
Posts: 5
Default Re: [Geforce 7950GT] Wrong color depth on KUbuntu

I have the same problem after upgrading my linux kernel and my nvidia drivers to latest. I have a Geforce 3 Ti 200 video card.

The free nv driver works fine.

I now (the problem is since 2.6.19) have a 2.6.20 kernel on Debian Sid.
Turb is offline   Reply With Quote
Old 02-11-07, 04:33 AM   #6
xenesis
Registered User
 
Join Date: Jan 2007
Posts: 4
Default Re: [Geforce 7950GT] Wrong color depth on KUbuntu

My solution was this: i deactivated the boot splash screen. Then it worked.

I don't know wether you have a splash screen, but if you have one try to deactivate it.
It seems the problem occurs when the framebuffer and the nvidia is used.
xenesis is offline   Reply With Quote
Old 02-12-07, 04:36 AM   #7
Turb
Registered User
 
Join Date: Feb 2007
Posts: 5
Default Re: [Geforce 7950GT] Wrong color depth on KUbuntu

My splash screen is deactivated.

When you say "framebuffer", do you mean linux kernel framebuffer support?

Note: in fact, your photo is not exactly the same. Your green is near to be correct and mine becomes red.
Turb is offline   Reply With Quote
Old 03-18-07, 07:24 AM   #8
unimatrix
Registered User
 
Join Date: Mar 2007
Posts: 21
Default Re: [Geforce 7950GT] Wrong color depth on KUbuntu

I have the same problem.
It happened after I switched from GDM to KDM. I've tried reinstalling KDM but that didn't really help.
Oh and by the way, this is not a bit depth problem. It's something even more strange. Notice how it only affects black parts of the screen?
Anyway, a temporary solution is to reboot the xserver (Ctrl+Alt+Backspace) right at the login screen. It is annoying nonetheless...

PS: I think this is a (not very active) debate about a similar problem: http://ubuntuforums.org/showthread.php?p=2183387
unimatrix is offline   Reply With Quote

Old 03-18-07, 01:45 PM   #9
a7v
Registered User
 
Join Date: Jun 2005
Posts: 67
Default Re: [Geforce 7950GT] Wrong color depth on KUbuntu

Quote:
Originally Posted by xenesis
Ok, i have found out the following:
I stopped my KDE via
Code:
sudo /etc/init.d/kdm stop
and then did once
Code:
sudo /etc/init.d/kdm start
this gave me again 16bit colors
but using
Code:
startx
gave my the correct 24bit colors
confusing isn't it?

Furthermore i found this line in my Xorg.log file:
Code:
(--) PCI:*(6:0:0) nVidia Corporation unknown chipset (0x0295) rev 161, Mem @ 0xfd000000/24, 0xd0000000/28, 0xfc000000/24, I/O @ 0xec00/7, BIOS @ 0xfebe0000/17
Does this mean the 7950GT is really not supported?
When will it be supported?
Like others have already said... KDM passes some extra argument to the X server. Check KDM's config files, or try "sudo kdm-config".

You might also want to run "sudo update-pciids".
__________________
Computer stuff I've owned at one time or another:
CPUs: K6-3 400, Duron 600, Thunderbird 1400, Barton 2500, Duron 1800, A-64 3700+, C2D E7200
Motherboards: Shuttle Via MVP, Asus A7V, Asus A7V133, Asus N8X-VM400, Abit NF7, Abit UL8, Asus P5Q Pro
Graphics Cards: TNT2, GF 2 MX, GF 2 Pro, GF4 MX, GF FX 5500, GF 6600, GF 7600 GT, GF 9800GT
a7v is offline   Reply With Quote
Old 03-22-07, 01:49 AM   #10
unimatrix
Registered User
 
Join Date: Mar 2007
Posts: 21
Talking Re: [Geforce 7950GT] Wrong color depth on KUbuntu

I think I've finaly fixed it!

I had some weird options in the Screen section of xorg.conf, so i've comented that out. When I restarted the computer, the colors were back to normal.
Quote:
Section "Screen"
Identifier "Default Screen"
Device "NVIDIA Corporation NV43 [GeForce 6600]"
Monitor "Generic Monitor"
DefaultDepth 24
Option "DPMS"
# Option "TripleBuffer" "true"
Option "AddARGBGLXVisuals" "True"
Option "RenderAccel" "true"
# Option "backingstore" "true"
Option "AllowGLXWithComposite" "true"
EDIT: Please ignore this post. This does NOT work.

Last edited by unimatrix; 03-25-07 at 03:11 PM.
unimatrix is offline   Reply With Quote
Old 03-23-07, 05:11 PM   #11
Turb
Registered User
 
Join Date: Feb 2007
Posts: 5
Default Re: [Geforce 7950GT] Wrong color depth on KUbuntu

Quote:
Originally Posted by a7v
Like others have already said... KDM passes some extra argument to the X server. Check KDM's config files, or try "sudo kdm-config".

You might also want to run "sudo update-pciids".
Thanks for your help, but my problem remains

That's the same when I use kdm or xinit.

I don't have options quoted before, unfortunately.

... and with my GeForce III, I can only use 96xx drivers, but I suppose the problem would be the same.
Turb is offline   Reply With Quote
Old 03-25-07, 03:09 PM   #12
unimatrix
Registered User
 
Join Date: Mar 2007
Posts: 21
Default Re: [Geforce 7950GT] Wrong color depth on KUbuntu

Sorry about my previous post... It turns out it didn't work for me aswell
It somehow worked the first time, but i dont know why, or it was probably something else (maybe i didnt take a good look). The problem remains.

I did figure out though, that by switching to another session and then back again is the same as restarting X-server (Ctrl+Alt+Fx, then Ctrl+Alt+F7 .. x is any number from 1 to 12, except 7 of course). Although it isnt any quicker than restarting the X server.

Also, I would like to point out that this problem most likely isn't limited to "Geforce 7950GT" as this thread is titled. I myself have a GeForce 6600.

And another thing... I was wondering why only black colors get corrupted? It's like the colors are somehow shifted.

PS: This might be a stupid question, but.... What monitors are you using? The border of the monitor on that picture looks exactly the same as mine: Samsung SyncMaster 192T
unimatrix is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:57 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.