Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-14-07, 09:17 PM   #1
vipjun
Registered User
 
Join Date: Jan 2007
Posts: 1
Default UseDisplayDevice and ConnectedMonitor breaking Twin View

It seems that the only way I can get Twinview to work is by commenting out

#Option "UseDisplayDevice" "DFP"
#Option "ConnectedMonitor" "DFP, CRT"

However, it is using my CRT monitor as the primary instead of the DFP.

Im using Dapper 6.06
Driver version 8776
Geforece FX 5200 on 2 of the same HC194D LCD monitors. one dvi the other vga.

When I try to use
Option "UseDisplayDevice and #Option "ConnectedMonitor

It detects CRT as 350mhz and cannot find the monitor.

I have some logs. hope someone can point me to a solution. Maybe a non twinview solution I hear is possible.

xorg.conf

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "stylus" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"
Option "Xinerama" "Off"
EndSection

Section "Files"

# path to defoma fonts
FontPath "/usr/share/X11/fonts/misc"
FontPath "/usr/share/X11/fonts/cyrillic"
FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/X11/fonts/Type1"
FontPath "/usr/share/X11/fonts/100dpi"
FontPath "/usr/share/X11/fonts/75dpi"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ExplorerPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"

# /dev/input/event
# for USB
Identifier "stylus"
Driver "wacom"
Option "Device" "/dev/wacom" # Change to
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"

# /dev/input/event
# for USB
Identifier "eraser"
Driver "wacom"
Option "Device" "/dev/wacom" # Change to
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"

# /dev/input/event
# for USB
Identifier "cursor"
Driver "wacom"
Option "Device" "/dev/wacom" # Change to
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Device"
Identifier "NVIDIA Corporation NV34 [GeForce FX 5200]"
Driver "nvidia"
Option "TwinView" "1"
Option "TwinViewOrientation" "RightOf"
Option "SecondMonitorHorizSync" "31-81"
Option "SecondMonitorVertRefresh" "56-75"
Option "UseEdidFreqs" "false"
#Option "MetaModes" "1280x1024, 1280x1024; 800x600, 800x600"
Option "UseDisplayDevice" "DFP"
Option "ConnectedMonitor" "DFP, CRT"
EndSection
Section "Monitor"
Identifier "HC194D"
Option "DPMS"
EndSection
Section "Screen"
Identifier "Default Screen"
Device "NVIDIA Corporation NV34 [GeForce FX 5200]"
Monitor "HC194D"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x640" "640x480" "640x400"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x640" "640x480" "640x400"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x640" "640x480" "640x400"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x640" "640x480" "640x400"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x640" "640x480" "640x400"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x640" "640x480" "640x400"
EndSubSection
EndSection


Xorg.0.log

(II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "ConnectedMonitor" "DFP, CRT"
(**) NVIDIA(0): Option "UseEdidFreqs" "false"
(**) NVIDIA(0): Option "TwinView" "1"
(**) NVIDIA(0): Option "TwinViewOrientation" "RightOf"
(**) NVIDIA(0): Option "SecondMonitorHorizSync" "31-81"
(**) NVIDIA(0): Option "SecondMonitorVertRefresh" "56-75"
(**) NVIDIA(0): Option "UseDisplayDevice" "DFP"
(**) NVIDIA(0): Enabling RENDER acceleration
(**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID has been
(**) NVIDIA(0): disabled on all display devices.
(WW) NVIDIA(0): No TwinView "MetaModes" specified; will fall back to Display
(WW) NVIDIA(0): SubSection modes.
(**) NVIDIA(0): TwinView enabled
(**) NVIDIA(0): ConnectedMonitor string: "DFP, CRT"
(II) NVIDIA(0): NVIDIA GPU GeForce FX 5200 at PCI:1:0:0
(--) NVIDIA(0): VideoRAM: 131072 kBytes
(--) NVIDIA(0): VideoBIOS: 04.34.20.27.00
(II) NVIDIA(0): Detected AGP rate: 4X
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce FX 5200 at PCI:1:0:0:
(--) NVIDIA(0): HSD HC194D (CRT-0)
(--) NVIDIA(0): HSD HC194D (DFP-0)
(--) NVIDIA(0): HSD HC194D (CRT-0): 350.0 MHz maximum pixel clock
(--) NVIDIA(0): HSD HC194D (DFP-0): 135.0 MHz maximum pixel clock
(--) NVIDIA(0): HSD HC194D (DFP-0): Internal Single Link TMDS
(II) NVIDIA(0): Option "UseDisplayDevice" "DFP" converted to "DFP-0".
(WW) NVIDIA(0): TwinView requested, but only 1 display devices found.
(II) NVIDIA(0): Assigned Display Device: DFP-0
(WW) NVIDIA(0): No valid modes for "1280x1024"; removing.
(WW) NVIDIA(0): No valid modes for "1024x768"; removing.
(WW) NVIDIA(0): No valid modes for "832x624"; removing.
(WW) NVIDIA(0): No valid modes for "800x600"; removing.
(WW) NVIDIA(0): No valid modes for "720x400"; removing.
(WW) NVIDIA(0): No valid modes for "640x640"; removing.
(WW) NVIDIA(0): No valid modes for "640x400"; removing.
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0): "640x480"
(II) NVIDIA(0): Virtual screen size determined to be 640 x 480
(--) NVIDIA(0): DPI set to (85, 86); computed from "UseEdidDpi" X config option
(--) Depth 24 pixmap format is 32 bpp
(II) do I need RAC? No, I don't.
(II) resource ranges after preInit:
[0] 0 0 0xe8000000 - 0xefffffff (0x8000000) MX[b]
[1] 0 0 0xfd000000 - 0xfdffffff (0x1000000) MX[b]
[2] -1 0 0x00100000 - 0x2fffffff (0x2ff00000) MX[b]E(B)
[3] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[4] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[5] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[6] -1 0 0xfeafe000 - 0xfeafefff (0x1000) MX[b]
[7] -1 0 0xfeaffc00 - 0xfeaffdff (0x200) MX[b]
[8] -1 0 0xfebff400 - 0xfebff4ff (0x100) MX[b]
[9] -1 0 0xfebff800 - 0xfebff9ff (0x200) MX[b]
[10] -1 0 0x30000000 - 0x300003ff (0x400) MX[b]
[11] -1 0 0xfebffc00 - 0xfebfffff (0x400) MX[b]
[12] -1 0 0xf8000000 - 0xf7ffffff (0x0) MX[b]O
[13] -1 0 0xfe8e0000 - 0xfe8fffff (0x20000) MX[b](B)
[14] -1 0 0xe8000000 - 0xefffffff (0x8000000) MX[b](B)
[15] -1 0 0xfd000000 - 0xfdffffff (0x1000000) MX[b](B)
[16] 0 0 0x000a0000 - 0x000affff (0x10000) MS[b](OprD)
[17] 0 0 0x000b0000 - 0x000b7fff (0x8000) MS[b](OprD)
[18] 0 0 0x000b8000 - 0x000bffff (0x8000) MS[b](OprD)
[19] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[20] -1 0 0x00000000 - 0x000000ff (0x100) IX[b]
[21] -1 0 0x0000d080 - 0x0000d0bf (0x40) IX[b]
[22] -1 0 0x0000d400 - 0x0000d40f (0x10) IX[b]
[23] -1 0 0x0000d480 - 0x0000d483 (0x4) IX[b]
[24] -1 0 0x0000d800 - 0x0000d807 (0x IX[b]
[25] -1 0 0x0000d880 - 0x0000d883 (0x4) IX[b]
[26] -1 0 0x0000dc00 - 0x0000dc07 (0x IX[b]
[27] -1 0 0x0000e080 - 0x0000e0bf (0x40) IX[b]
[28] -1 0 0x0000e400 - 0x0000e4ff (0x100) IX[b]
[29] -1 0 0x0000e000 - 0x0000e01f (0x20) IX[b]
[30] -1 0 0x0000ffa0 - 0x0000ffaf (0x10) IX[b]
[31] -1 0 0x0000ec00 - 0x0000ec1f (0x20) IX[b]
[32] -1 0 0x0000e880 - 0x0000e89f (0x20) IX[b]
[33] -1 0 0x0000e800 - 0x0000e81f (0x20) IX[b]
[34] 0 0 0x000003b0 - 0x000003bb (0xc) IS[b](OprU)
[35] 0 0 0x000003c0 - 0x000003df (0x20) IS[b](OprU)
(II) NVIDIA(0): Setting mode "640x480"
(II) Loading extension NV-GLX
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(**) Option "dpms"
(**) NVIDIA(0): DPMS enabled
(II) Loading extension NV-CONTROL
(==) RandR enabled
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) Initializing built-in extension XEVIE
(II) Initializing extension GLX
error opening security policy file /etc/X11/xserver/SecurityPolicy
(**) Option "CoreKeyboard"
(**) Generic Keyboard: Core Keyboard
(**) Option "Protocol" "standard"
(**) Generic Keyboard: Protocol: standard
(**) Option "AutoRepeat" "500 30"
(**) Option "XkbRules" "xorg"
(**) Generic Keyboard: XkbRules: "xorg"
(**) Option "XkbModel" "pc104"
(**) Generic Keyboard: XkbModel: "pc104"
(**) Option "XkbLayout" "us"
(**) Generic Keyboard: XkbLayout: "us"
(**) Option "CustomKeycodes" "off"
(**) Generic Keyboard: CustomKeycodes disabled
(**) Option "Protocol" "ExplorerPS/2"
(**) Configured Mouse: Device: "/dev/input/mice"
(**) Configured Mouse: Protocol: "ExplorerPS/2"
(**) Option "CorePointer"
(**) Configured Mouse: Core Pointer
(**) Option "Device" "/dev/input/mice"
(**) Option "Emulate3Buttons" "true"
(**) Configured Mouse: Emulate3Buttons, Emulate3Timeout: 50
(**) Option "ZAxisMapping" "4 5"
(**) Configured Mouse: ZAxisMapping: buttons 4 and 5
(**) Configured Mouse: Buttons: 9
(**) Option "SendCoreEvents"
(**) stylus: always reports core events
(**) stylus device is /dev/wacom
(**) stylus is in absolute mode
(**) stylus: forcing TabletPC ISD V4 protocol
(**) WACOM: suppress value is 2
(**) Option "BaudRate" "9600"
(**) stylus: serial speed 9600
(**) Option "SendCoreEvents"
(**) cursor: always reports core events
(**) cursor device is /dev/wacom
(**) cursor is in relative mode
(**) cursor: forcing TabletPC ISD V4 protocol
(**) WACOM: suppress value is 2
(**) Option "BaudRate" "9600"
(**) cursor: serial speed 9600
(**) Option "SendCoreEvents"
(**) eraser: always reports core events
(**) eraser device is /dev/wacom
(**) eraser is in absolute mode
(**) eraser: forcing TabletPC ISD V4 protocol
(**) WACOM: suppress value is 2
(**) Option "BaudRate" "9600"
(**) eraser: serial speed 9600
(II) XINPUT: Adding extended input device "eraser" (type: Wacom Eraser)
(II) XINPUT: Adding extended input device "cursor" (type: Wacom Cursor)
(II) XINPUT: Adding extended input device "stylus" (type: Wacom Stylus)
(II) XINPUT: Adding extended input device "Configured Mouse" (type: MOUSE)
(II) XINPUT: Adding extended input device "Generic Keyboard" (type: KEYBOARD)
(II) XINPUT: Adding extended input device "NVIDIA Event Handler" (type: Other)
(**) Option "Device" "/dev/wacom"
(EE) xf86OpenSerial: Cannot open device /dev/wacom
No such file or directory.
Error opening /dev/wacom : No such file or directory
(EE) xf86OpenSerial: Cannot open device /dev/wacom
No such file or directory.
Error opening /dev/wacom : No such file or directory
(**) Option "Device" "/dev/wacom"
(EE) xf86OpenSerial: Cannot open device /dev/wacom
No such file or directory.
Error opening /dev/wacom : No such file or directory
(EE) xf86OpenSerial: Cannot open device /dev/wacom
No such file or directory.
Error opening /dev/wacom : No such file or directory
(**) Option "Device" "/dev/wacom"
(EE) xf86OpenSerial: Cannot open device /dev/wacom
No such file or directory.
Error opening /dev/wacom : No such file or directory
(EE) xf86OpenSerial: Cannot open device /dev/wacom
No such file or directory.
Error opening /dev/wacom : No such file or directory
(II) Configured Mouse: ps2EnableDataReporting: succeeded
vipjun is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:34 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.