Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-18-07, 10:49 PM   #13
eusanpe
Registered User
 
Join Date: Mar 2006
Posts: 14
Default Re: M1710 Console Issues w/Nvidia Driver

Mine does it all of the time. I was messing around with beryl and I had a typo in my startx file. I tried to start X then failed and the screen was garbled.

After I boot, the console is fine.
If I start X, the console is fine running Multi-Gnome-Terminal and it runs fine if I switch consoles <ctrl><alt>f2, etc..
If I exit X the console is garbled as fyxim's monitor picture shows. Only one time did it not do that and I was shocked. I tried it again and it reverted back to the garbled screen.
If I exit X to the console and get the garbled text, I can type sudo reboot and my system will reboot. If I type startx again, it just stays black.

Last edited by eusanpe; 01-19-07 at 09:41 AM.
eusanpe is offline   Reply With Quote
Old 01-19-07, 04:38 AM   #14
fyxim
Registered User
 
Join Date: Oct 2006
Posts: 7
Default Re: M1710 Console Issues w/Nvidia Driver

Quote:
Originally Posted by netllama
Yes, mine has the 7950GTX. So you're stating that this only reproduces after X has been in use for some extended period of time? Can you quantify how long?
It's not "only", but the chance is greater. If I try kill X right after the nvidia logo has disapperad, the chance is about 20%. If I use X for extended period of time (about one hour), it will most likely occur. Have you tried testing our xorg.conf? Both me and eusanpe is using Beryl, but I get the same problem with other window managers. Have you tried loaded the glx module?

Quote:
Originally Posted by eusanpe
Mine does it all of the time. I was messing around with beryl and I had a typo in my startx file. It tried to start X then failed and the screen was garbled.
I had the same problem, couldn't get xorg to work becouse of the garbled screen, I had to ssh and read the log file to see where the typo was in my configuration. Here, the problem always appear for me.

Last edited by fyxim; 01-19-07 at 11:13 AM.
fyxim is offline   Reply With Quote
Old 01-19-07, 11:13 AM   #15
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: M1710 Console Issues w/Nvidia Driver

Does this only reproduce when using Beryl and/or the Composite extension?
netllama is offline   Reply With Quote
Old 01-20-07, 03:11 AM   #16
ofourdan
Registered User
 
Join Date: Aug 2003
Location: France
Posts: 16
Default Re: M1710 Console Issues w/Nvidia Driver

Quote:
Originally Posted by netllama
I'm not having any success reproducing this problem here on an M1710. When I console switch away from X there is no corruption. There's also no corruption when exiting X.
Right. Switching VT doesn't trigger the problem.

You have to kill the server to trigger the bug. Either do a /etc/init.d/gdm restart or just crtl+alt+backspace to kill the X server.
ofourdan is offline   Reply With Quote
Old 01-20-07, 09:52 AM   #17
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: M1710 Console Issues w/Nvidia Driver

Does this only reproduce when using Beryl and/or the Composite extension?
netllama is offline   Reply With Quote
Old 01-20-07, 10:40 AM   #18
fyxim
Registered User
 
Join Date: Oct 2006
Posts: 7
Default Re: M1710 Console Issues w/Nvidia Driver

Quote:
Originally Posted by netllama
Does this only reproduce when using Beryl and/or the Composite extension?
I disabled both and the problem still occurs for me.
fyxim is offline   Reply With Quote
Old 01-23-07, 10:39 PM   #19
eusanpe
Registered User
 
Join Date: Mar 2006
Posts: 14
Default Re: M1710 Console Issues w/Nvidia Driver

*bump*
eusanpe is offline   Reply With Quote
Old 01-24-07, 10:18 AM   #20
energyman76b
Registered User
 
Join Date: Dec 2002
Location: Clausthal/Germany
Posts: 1,104
Default Re: M1710 Console Issues w/Nvidia Driver

what happens, if you don't load the 'wfb' module?
energyman76b is offline   Reply With Quote

Old 01-25-07, 05:08 PM   #21
eusanpe
Registered User
 
Join Date: Mar 2006
Posts: 14
Default Re: M1710 Console Issues w/Nvidia Driver

The same thing happens.

Thanks,
Tony
eusanpe is offline   Reply With Quote
Old 01-29-07, 04:47 PM   #22
eusanpe
Registered User
 
Join Date: Mar 2006
Posts: 14
Default Re: M1710 Console Issues w/Nvidia Driver

Are fyxim and myself the only ones with this type of laptop, with the 7950 GTX card who are having the same problem even though we are running different versions of Linux with different kernels?

What happened to netllama? Any news?

Thanks,
Tony
eusanpe is offline   Reply With Quote
Old 01-29-07, 04:49 PM   #23
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: M1710 Console Issues w/Nvidia Driver

I'm still unable to reproduce this here.
netllama is offline   Reply With Quote
Old 01-30-07, 03:32 AM   #24
ofourdan
Registered User
 
Join Date: Aug 2003
Location: France
Posts: 16
Default Re: M1710 Console Issues w/Nvidia Driver

Quote:
Originally Posted by eusanpe
Are fyxim and myself the only ones with this type of laptop, with the 7950 GTX card who are having the same problem even though we are running different versions of Linux with different kernels?
I'm able to reproduce this on my own M1710 laptop, using Ubuntu and Linux kernel 2.6.19.x, and on all similar laptops I've seen at work, using Debian Etch and its stock kernel. All using the 7950GTX card and the nVidia 9746 driver.
ofourdan is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
UEFI+Nvidia - NVRM: Your system is not currently configured to drive a VGA console... interzoneuk NVIDIA Linux 0 06-26-12 04:51 AM
Console Killers News Archived News Items 0 06-11-12 10:10 PM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 08:49 AM
Official Linux driver 1.0-3123 thread bammbamm808 NVIDIA Linux 126 12-05-02 06:21 PM
Nvidia driver 1.0-3123 VIA 4x issues. dcstimm NVIDIA Linux 8 09-29-02 08:34 PM

All times are GMT -5. The time now is 06:47 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.