Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Closed Thread
 
Thread Tools
Old 05-23-07, 04:50 AM   #301
kriko
openSuSE11
 
kriko's Avatar
 
Join Date: Aug 2005
Location: Europe, Slovenia, Koper
Posts: 515
Default Re: beryl black windows bug

@jdeslip: Yes, it doesn't fix it.

Quote:
All these without BackingStore I guess... With BackingStore in 9755 you can switch to kwin without XIDs??
@djdoo: Exactly! Something is different in 100.14.06 and Xorg keeps "freezing" (mouse is still moving around, but I can't kill it)
kriko is offline  
Old 05-23-07, 05:27 PM   #302
djdoo
*BANNED*
 
djdoo's Avatar
 
Join Date: Jan 2007
Location: Athens, Hellas
Posts: 160
Default Re: beryl black windows bug

I use 100.14.06 not for any reason but cause I feel changing those drivers all the time has no meaning. They have the same performance for me and same bugs...
So I left the new beta running...

Now I have some good news from terry's tests in NVreg for PCI-X cards but we have some things to check further... When we 'll have the full picture I 'll tell you...!
djdoo is offline  
Old 05-23-07, 05:34 PM   #303
Jupiter1tx
Old User
 
Jupiter1tx's Avatar
 
Join Date: May 2007
Posts: 43
Default Re: beryl black windows bug

Quote:
Originally Posted by djdoo
I use 100.14.06 not for any reason but cause I feel changing those drivers all the time has no meaning. They have the same performance for me and same bugs...
So I left the new beta running...

Now I have some good news from terry's tests in NVreg for PCI-X cards but we have some things to check further... When we 'll have the full picture I 'll tell you...!
Please let me know word on those test. Just so you know i have made a
FAQ using some of your research. It is located here.
http://www.opencompositing.org/viewtopic.php?f=51&t=439

Let me know if you prefer your name not be associated with this FAQ.
__________________
Core i7 920 | Asus P6TD | Patriot Viper 1600 6GB | Antec Quattro 850W
Geforce 8800GTX OC2 768MB | Dell 22" LCD | Nautilus 500/Swiftech GTZ
GCC 4.3.3 | 2.6.29-zenx | Xorg-7.4 | KDE-4.2 | Compiz-Fusion
Jupiter1tx is offline  
Old 05-23-07, 05:51 PM   #304
energyman76b
Registered User
 
Join Date: Dec 2002
Location: Clausthal/Germany
Posts: 1,104
Default Re: beryl black windows bug

Quote:
Originally Posted by djdoo
I use 100.14.06 not for any reason but cause I feel changing those drivers all the time has no meaning. They have the same performance for me and same bugs...
So I left the new beta running...

Now I have some good news from terry's tests in NVreg for PCI-X cards but we have some things to check further... When we 'll have the full picture I 'll tell you...!
please. PCI Express IS NOT PCI-X

TWO completly different slots!

Don't confuse them!
energyman76b is offline  
Old 05-23-07, 05:54 PM   #305
ktulu77
Registered User
 
Join Date: Jun 2006
Posts: 6
Unhappy Re: beryl black windows bug

Hi all !
I've tested the post 255 settings :
I don't have the black window bug anymore but the system is lagging :
I have a hard drive access and beryl lag a lot.
without beryl, no problem.
I have a pci express 6600GT so I didn't test the agp settings.
what can I do to have better performance ?
thanks
ktulu77 is offline  
Old 05-23-07, 05:57 PM   #306
djdoo
*BANNED*
 
djdoo's Avatar
 
Join Date: Jan 2007
Location: Athens, Hellas
Posts: 160
Default Re: beryl black windows bug

Quote:
Originally Posted by Jupiter1tx
Please let me know word on those test. Just so you know i have made a
FAQ using some of your research. It is located here.
http://www.opencompositing.org/viewtopic.php?f=51&t=439

Let me know if you prefer your name not be associated with this FAQ.
OK man you asked it...
Here's your job... in your modprobe.conf.local add the following stuff:

options nvidia NVreg_VideoMemoryTypeOverride=0 NVreg_NvAGP=0 NVreg_ReqAGPRate=0 NVreg_SoftEDIDs=0 NVreg_DevicesConnected=1 NVreg_VbiosFromROM=1 NVreg_SaveVBios=1 NVreg_EnableBrightnessControl=1

Also use option "NvAGP" "0" in xorg.conf and agp=off in boot settings
Reboot...
And tell me your results, check if 3d performance in games and smoothness overall is improved!! More testers better results!

Now for my name no problem! Just add Jim before 'djdoo' nick!
djdoo is offline  
Old 05-23-07, 06:06 PM   #307
Jupiter1tx
Old User
 
Jupiter1tx's Avatar
 
Join Date: May 2007
Posts: 43
Default Re: beryl black windows bug

Quote:
Originally Posted by ktulu77
Hi all !
I've tested the post 255 settings :
I don't have the black window bug anymore but the system is lagging :
I have a hard drive access and beryl lag a lot.
without beryl, no problem.
I have a pci express 6600GT so I didn't test the agp settings.
what can I do to have better performance ?
thanks
Nothing really. When using those techniques to overcome the
black window bug, performance suffers.

The only thing that SHOULD BE DONE is for Nvidia to FIX THE PROBLEM
before THE BUG'S ONE YEAR ANNIVERSARY which is quickly approaching.

I have now started informing my users to consider one of the new fancy
ATI cards because Nvidia is unable to fix a MAJOR flaw in their product.
__________________
Core i7 920 | Asus P6TD | Patriot Viper 1600 6GB | Antec Quattro 850W
Geforce 8800GTX OC2 768MB | Dell 22" LCD | Nautilus 500/Swiftech GTZ
GCC 4.3.3 | 2.6.29-zenx | Xorg-7.4 | KDE-4.2 | Compiz-Fusion
Jupiter1tx is offline  
Old 05-23-07, 06:07 PM   #308
djdoo
*BANNED*
 
djdoo's Avatar
 
Join Date: Jan 2007
Location: Athens, Hellas
Posts: 160
Default Re: beryl black windows bug

Quote:
Originally Posted by ktulu77
Hi all !
I've tested the post 255 settings :
I don't have the black window bug anymore but the system is lagging :
I have a hard drive access and beryl lag a lot.
without beryl, no problem.
I have a pci express 6600GT so I didn't test the agp settings.
what can I do to have better performance ?
thanks
You set all settings for xorg.conf and beryl options the same time?
Cause everything must be set properly and same time!
You re the first reporting significant loss of performance...
I need more info... driver version, beryl version, X version, Distro.
Check out if you missed something of settings especially XGL binding
Also BackingStore works on your PC?? Check without it cause kriko has an 6600 gt AGP and can't use BackingStore... maybe you face the same problem! check if CPU usage is at 100% with beryl running...
djdoo is offline  

Old 05-23-07, 06:08 PM   #309
kriko
openSuSE11
 
kriko's Avatar
 
Join Date: Aug 2005
Location: Europe, Slovenia, Koper
Posts: 515
Default Re: beryl black windows bug

Quote:
Also use option "NvAGP" "0" in xorg.conf and agp=off in boot settings
This will completely disable agp support, so If you have an agp card, it is not recommended, overall performance will drop, even in 2d mode.

Use of agp=off is only necessary when you have agpgart module compiled into kernel and you would like to use nvidia agp driver.
kriko is offline  
Old 05-23-07, 06:11 PM   #310
djdoo
*BANNED*
 
djdoo's Avatar
 
Join Date: Jan 2007
Location: Athens, Hellas
Posts: 160
Default Re: beryl black windows bug

Quote:
Originally Posted by Jupiter1tx
Nothing really. When using those techniques to overcome the
black window bug, performance suffers.

.
No I think he has another problem than what you think.
And believe me performance doesn't suffer at all!!
In 3d games I get better performance than with Nvidia mode! Just beryl is slightly less "smooth"...
djdoo is offline  
Old 05-23-07, 06:13 PM   #311
djdoo
*BANNED*
 
djdoo's Avatar
 
Join Date: Jan 2007
Location: Athens, Hellas
Posts: 160
Default Re: beryl black windows bug

Quote:
Originally Posted by kriko
This will completely disable agp support, so If you have an agp card, it is not recommended, overall performance will drop, even in 2d mode.

Use of agp=off is only necessary when you have agpgart module compiled into kernel and you would like to use nvidia agp driver.
These settings are tested for PCI Ex. cards!! Don't get comfused...
djdoo is offline  
Old 05-23-07, 06:17 PM   #312
kriko
openSuSE11
 
kriko's Avatar
 
Join Date: Aug 2005
Location: Europe, Slovenia, Koper
Posts: 515
Default Re: beryl black windows bug

@djdoo: ktulu77 seems to have same performance issue as me (though he has pci-e card). Beryl is lagging under heavy load (disk I/O, CPU intensive tasks). It only does that when using that workaround (AIGLX), it is smooth if nvidia rendering platform is selected, but then we hit black-window bug. My recommendation is to not use beryl at all (I stopped using it too) until nvidia fix this.
kriko is offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Why Windows 8 could be the next Vista News Archived News Items 0 06-15-12 11:30 AM
Like XP or Vista: how will businesses treat Windows 8? News Archived News Items 0 06-06-12 10:10 AM
NVIDIA Brings 18 Years of Experience to Windows 8 News Archived News Items 0 06-03-12 07:20 AM
Sync it up: Hands on with the preview of Windows 8's cloud sync service News Archived News Items 0 06-02-12 09:30 PM
$15 Windows 8 upgrades available from Microsoft through January 2013 News Archived News Items 0 06-01-12 12:50 PM

All times are GMT -5. The time now is 01:06 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.