Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-19-07, 06:15 PM   #1
charlweed
Registered User
 
charlweed's Avatar
 
Join Date: Jan 2007
Location: SF Bay
Posts: 7
Default XvMC and dual head or TV out. Is this possible?

Hi,
I have a crt multisync monitor and a NTSC tv. I would like mythtv to use the tv as its display. It ALMOST works if I use Xinerama and set the display to "1", but I must use XvMC to get acceptable performance. When I use xvmc, the GUI shows up on the TV, but I get no video on the tv at all, just a blank screen.
Is there a configuration that will work? My xorg.conf:


# Xorg configuration created by Listbox

Section "ServerLayout"
Identifier "Dual head configuration"
Screen 0 "Screen0" 0 0
Screen 1 "Screen1" Below "Screen0"
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
Option "Xinerama" "on"
Option "Clone" "off"
EndSection

Section "Files"

# Multiple FontPath entries are allowed (they are concatenated together)
# By default, a font server independent of the X server is
# used to render fonts.
FontPath "unix/:7100"
ModulePath "/usr/lib/xorg/modules/extensions/nvidia,/usr/lib/xorg/modules/extensions,/usr/lib/xorg/modules"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "v4l"
Load "synaptics"
# Load "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
# Option "dpms"
Identifier "Monitor0"
VendorName "NEC Vendor"
ModelName "NEC MultiSync 90"
DisplaySize 370 270
HorizSync 31.0 - 96.0
VertRefresh 55.0 - 160.0
EndSection

Section "Monitor"
Identifier "Monitor1"
VendorName "Monitor Vendor"
ModelName "Crappy Television"
HorizSync 30.0 - 50.0
VertRefresh 60.0 - 60.0
EndSection

Section "Device"
Identifier "CRT"
Driver "nvidia"
VendorName "nVidia Corporation"
BoardName "nVidia Corporation NV43 [GeForce 6200]"
BusID "PCI:2:0:0"
Option "RenderAccel" "true"
Option "AllowGLXWithComposite" "true"
Screen 0
EndSection

Section "Device"
Identifier "TV"
Driver "nvidia"
VendorName "nVidia Corporation"
BoardName "nVidia Corporation NV43 [GeForce 6200]"
BusID "PCI:2:0:0"
Option "RenderAccel" "true"
Option "AllowGLXWithComposite" "true"
Screen 1
EndSection

Section "Screen"
Identifier "Screen0"
Device "CRT"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Modes "1024x768" "800x600" "640x480"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "Screen"
Identifier "Screen1"
Device "TV"
Monitor "Monitor1"
DefaultDepth 24
Option "TVStandard" "NTSC-M"
Option "ConnectedMonitor" "TV"
Option "TVOutFormat" "SVIDEO"
Option "TVOverScan" "0.5"
SubSection "Display"
Modes "800x600"
Viewport 0 0
Depth 24
EndSubSection
EndSection
charlweed is offline   Reply With Quote
Old 01-19-07, 06:35 PM   #2
PenGun
Registered User
 
Join Date: Jan 2006
Posts: 93
Default Re: XvMC and dual head or TV out. Is this possible?

DISPLAY=":0.1" the command.

Is this how you set it? If not I imagine it's a xine issue.

I use mplayer thusly:

DISPLAY=":0.1" nice -n -19 mplayer -vo xvmc:bobdeint:queue -vc ffmpeg12mc %f

For .vob .ts .evo (HD-DVD) and .vdr.

I use that line in the midnight commander, works very well.
PenGun is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:20 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.