Go Back   nV News Forums > Linux Support Forums > NVIDIA FreeBSD

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-23-07, 03:31 AM   #1
Zomers
Registered User
 
Join Date: Jan 2007
Posts: 6
Default 9629 & 9631 both not installing on FBSD 6.2

Hi all ;-)

Tried to install 9631 (I have compat5x installed). Gives me this code:

Code:
rm: /lib/modules/extensions/libglx.so.1: Not a directory
*** Error code 1

Stop in /tmp/NVIDIA-FreeBSD-x86-1.0-9631/x11/extension.
*** Error code 1

Stop in /tmp/NVIDIA-FreeBSD-x86-1.0-9631/x11.
*** Error code 1

Stop in /tmp/NVIDIA-FreeBSD-x86-1.0-9631.
Tried to install 9629, gives me this code:

Code:

rm: /lib/modules/extensions/libglx.so.1: Not a directory
*** Error code 1

Stop in /tmp/NVIDIA-FreeBSD-x86-1.0-9629/x11/extension.
*** Error code 1

Stop in /tmp/NVIDIA-FreeBSD-x86-1.0-9629/x11.
*** Error code 1

Stop in /tmp/NVIDIA-FreeBSD-x86-1.0-9629.
I have the Geforce 400, so I need to install the legacy driver.

Would anybody happen to know how I can fix this?

Thank you in advance for your time and attention ;-)
Zomers is offline   Reply With Quote
Old 01-23-07, 02:09 PM   #2
h0nke
Registered User
 
Join Date: Jan 2007
Posts: 4
Default Re: 9629 & 9631 both not installing on FBSD 6.2

I am having the exact same problem. Hopefully someone knows whats wrong so we can both be happy.
h0nke is offline   Reply With Quote
Old 01-23-07, 04:22 PM   #3
adamk75
Registered User
 
Join Date: Nov 2006
Posts: 228
Default Re: 9629 & 9631 both not installing on FBSD 6.2

You need to set X11BASE to /usr/X11R6 (which is done differently depending on the shell you use) before running make install.

Adam
adamk75 is offline   Reply With Quote
Old 01-24-07, 04:57 AM   #4
Zomers
Registered User
 
Join Date: Jan 2007
Posts: 6
Default Re: 9629 & 9631 both not installing on FBSD 6.2

Quote:
Originally Posted by adamk75
You need to set X11BASE to /usr/X11R6 (which is done differently depending on the shell you use) before running make install.

Adam
Thanks Adam ;-) It didn't work on the 9631, but it did work on the 9629.

But now I face another problem: my refresh rate is much too low. With the original FBSD driver I could put it to 75Hz, but now with this driver (and AGP and 3d acceleration enabled) in my desktop settings the maximum refresh rate is 52Hz (@1280x1024). My monitor allows for horizontal 30 - 82 kHz, vertical 56-76Hz. I have included that in xorg.conf, but still I can't select a higher refresh rate in my desktop. Like said, with the FBSD driver it did work, and on XP it also works (so my card and monitor should be able to handle it).

Would you happen to have any clue why this is?

Thanks again ;-)
Zomers is offline   Reply With Quote
Old 01-24-07, 06:24 AM   #5
adamk75
Registered User
 
Join Date: Nov 2006
Posts: 228
Default Re: 9629 & 9631 both not installing on FBSD 6.2

Sorry, that's one thing I can't help with :-) I suggest starting a new topic and hoping someone from nVidia responds.

Adam
adamk75 is offline   Reply With Quote
Old 01-24-07, 01:17 PM   #6
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: 9629 & 9631 both not installing on FBSD 6.2

@Zomers: it's possible that this problem is related to the dynamic display configurability feature of current drivers; please see the documentation on the DynamicTwinview X driver option in the README for details (e.g. http://us.download.nvidia.com/freebs...hapter-04.html and http://us.download.nvidia.com/freebs...ppendix-d.html).
zander is offline   Reply With Quote
Old 01-25-07, 05:16 AM   #7
Zomers
Registered User
 
Join Date: Jan 2007
Posts: 6
Default Re: 9629 & 9631 both not installing on FBSD 6.2

Quote:
Originally Posted by zander
@Zomers: it's possible that this problem is related to the dynamic display configurability feature of current drivers; please see the documentation on the DynamicTwinview X driver option in the README for details (e.g. http://us.download.nvidia.com/freebs...hapter-04.html and http://us.download.nvidia.com/freebs...ppendix-d.html).
Thank you very much, Zanders: this appeared to do the trick:


Option "DynamicTwinView" "0"



Now I have one more question: my screen is still blurry; it is not so crystal clear as it is under XP (look at the fonts for example). Would you happen to know how I can solve this? Currently it's running at 1280x1024 @ 75Hz. Since the three screenprints are to large to attach to this message, I've uploaded them to mytempdir:

http://www.mytempdir.com/1184771
http://www.mytempdir.com/1184775
http://www.mytempdir.com/1184788


Thanks again for your help ;-)
Zomers is offline   Reply With Quote
Old 01-25-07, 12:36 PM   #8
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: 9629 & 9631 both not installing on FBSD 6.2

The screenshots look fine; are you using a CRT or a DFP? If you're using a DFP, is it connected via DVI or SUBD? You may want to start X with -logverbose 6 and take a closer look at the information on mode validation, etc., provided by the NVIDIA X driver.
zander is offline   Reply With Quote

Old 01-25-07, 01:00 PM   #9
Zomers
Registered User
 
Join Date: Jan 2007
Posts: 6
Default Re: 9629 & 9631 both not installing on FBSD 6.2

Quote:
Originally Posted by zander
The screenshots look fine; are you using a CRT or a DFP? If you're using a DFP, is it connected via DVI or SUBD? You may want to start X with -logverbose 6 and take a closer look at the information on mode validation, etc., provided by the NVIDIA X driver.
Hi Zander ;-)

Thanks for your reply.

I was afraid of you saying the screenshot looked fine; I doubted it could demonstrate clearly enough what I am seeing. I've uploaded one made under XP; can you see the difference now? The last of the three links in my first post shows that under BSD the fonts are much bolder than under XP (although, under XP, *in this screenshot* they are also a little bold: in practice they are not; I have no clue why the last screenshot still makes it look like under XP they are also too bold).

I am using a 19" HP (f1904) LCD/TFT-screen. Not with DVI, so I am assuming it is then SUBD (I have no clue what it means ). It's the same cable that was also connected to my CRT-monitors.

Starting X with -logverbose 6? Sure, if I can find out how (I am still very new to BSD )

This is the screenshot I uploaded, made under XP:

http://www.mytempdir.com/1185463

Thanks again for your kind help ;-)
Zomers is offline   Reply With Quote
Old 01-27-07, 02:09 PM   #10
Zomers
Registered User
 
Join Date: Jan 2007
Posts: 6
Default Re: 9629 & 9631 both not installing on FBSD 6.2

I think I found the solution (for 95%)

It's over here:

http://www.bsdforums.org/forums/showthread.php?p=223232

I think it's much better now, although still not 100% perfect.
Zomers is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:17 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.