Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-28-07, 09:24 AM   #13
Linuxhippy
Registered User
 
Join Date: Feb 2004
Posts: 585
Default Re: 6600GT Terrible 2D performance

the problem is that it would be possible to write accalerating drivers - but no one at nvidia cares. Their focus shifted away from 2D performance a long, long time ago.

Sadly my card is 99.70% of its lifetime used for 2D stuff.

lg Clemens
Linuxhippy is offline   Reply With Quote
Old 01-29-07, 11:21 PM   #14
_john_i_
gtx260/8200M G/DIY Linux
 
Join Date: Aug 2004
Location: Austin, TX USA
Posts: 137
Default Re: 6600GT Terrible 2D performance

Quote:
Originally Posted by Linuxhippy
the problem is that it would be possible to write accalerating drivers - but no one at nvidia cares. Their focus shifted away from 2D performance a long, long time ago.

Sadly my card is 99.70% of its lifetime used for 2D stuff.

lg Clemens

Linuxhippy,

I'm sorry to say I now feel the same way you do.

I've used nothing but Nvidia cards since the TNT1 days, and when I switched to Linux over 8 years ago I was happy to bring my Nvidia cards with me. I've owned many tnt/tnt2/geforce/geforce2/geforce3,etc. over the years, and been very happy with them.

However since I purchased this 6600GT card a year and a half ago I have been completely miserable and disappointed with this font situation. I would have never believed that my old geforce3 could outperform this card on simple daily 2d usage until I experienced it for myself.

Sure, I could turn off subpixel rendering, but I shouldn't have to. Looking at grey-AA on my beautiful flat panel make my eyes want to bleed.

I recently bought a notebook that happened to have an ATI X700 in it, and it works wonderfully! While the openGL / Games are not up to par with the nvidia drivers, it isn't bad, and serves my needs. For most of my daily work, though I still use my desktop, and when I upgrade my desktop next month, I am going with ATI.

Sad but true.

--John
_john_i_ is offline   Reply With Quote
Old 02-01-07, 03:37 PM   #15
ewildgoose
Registered User
 
Join Date: Dec 2005
Posts: 6
Default Re: 6600GT Terrible 2D performance

OK, I shelled out some more on an Nvidia 7600GS and although I have to say that this thing is a good deal faster, the slow down still kicks in if I enable the RGB anti-aliased fonts? 2D scrolling is very "laggy", ie you get just a hint of delay as you are scrolling. GTK apps are much worse still...

It could be some other setting on the computer I guess... Will have to try a live distro to compare...

Can anyone here confirm the opposite, ie that they have an Nvidia card, an LCD screen and they are using RGB anti-aliasing and they *have* got really fast scrolling that is at least as good as windows on arthritic hardware?

Cheers
ewildgoose is offline   Reply With Quote
Old 02-01-07, 06:48 PM   #16
PenGun
Registered User
 
Join Date: Jan 2006
Posts: 93
Default Re: 6600GT Terrible 2D performance

It's KDE Jim, not life as we know it.
PenGun is offline   Reply With Quote
Old 02-06-07, 05:34 PM   #17
Linuxhippy
Registered User
 
Join Date: Feb 2004
Posts: 585
Default Re: 6600GT Terrible 2D performance

I now own a Intel-945GM (onboard!!) gpu and I don't suffer any of these 2D performance problems I had before with my NVidia based desktop!
Linuxhippy is offline   Reply With Quote
Old 02-07-07, 11:05 AM   #18
Nebulus
Registered User
 
Join Date: Jan 2005
Posts: 23
Default Re: 6600GT Terrible 2D performance

You can solve slow 2D Font Redering under KDE, by disable the antialiased Fonts completly (in KDE Control Center).

And instead install a patched freetype-2.2.1, with patented font Rendering enabled. (It is disabled by default) You must recompile freetype-2.2.1 from Source.


Here is a little Hint, how to do this:

DOWNLOAD:
http://download.savannah.gnu.org/rel...-2.2.1.tar.bz2

PATCH:
Enable Patented Font Rendering with patchfile freetype-2.2.1_patented_fonts.patch.txt
tar xvfj freetype-2.2.1.tar.bz2
patch -p0 < freetype-2.2.1_patented_fonts.patch

COMPILE:
./configure --prefix=/usr &&
make &&
make install

Make shure your /usr/lib/libfreetype.so.6.3.10 has been updated !
Restart X11.

Thats all, if you now install the copyrighted microsoft ttf fonts on your linux system, you have good looking fonts, without antialiased switched on. And the Best, it looks a loot better than before.
Nebulus is offline   Reply With Quote
Old 02-07-07, 03:03 PM   #19
_john_i_
gtx260/8200M G/DIY Linux
 
Join Date: Aug 2004
Location: Austin, TX USA
Posts: 137
Default Re: 6600GT Terrible 2D performance

Quote:
Originally Posted by Nebulus
You can solve slow 2D Font Redering under KDE, by disable the antialiased Fonts completly (in KDE Control Center).

And instead install a patched freetype-2.2.1, with patented font Rendering enabled. (It is disabled by default) You must recompile freetype-2.2.1 from Source.
I've done it both ways, and I personally think the fonts look better without the patented rendering. Instead I use an xft patch that provides much better (like cleartype) rendering.

Regardless of the rendering in freetype subpixel looks far superior.
_john_i_ is offline   Reply With Quote
Old 02-08-07, 04:20 AM   #20
BarnyJr
Registered User
 
Join Date: Jan 2007
Posts: 2
Default Re: 6600GT Terrible 2D performance

Quote:
Originally Posted by Nebulus
You can solve slow 2D Font Redering under KDE, by disable the antialiased Fonts completly (in KDE Control Center).

And instead install a patched freetype-2.2.1, with patented font Rendering enabled. (It is disabled by default) You must recompile freetype-2.2.1 from Source.


Here is a little Hint, how to do this:

DOWNLOAD:
http://download.savannah.gnu.org/rel...-2.2.1.tar.bz2

PATCH:
Enable Patented Font Rendering with patchfile Attachment 23944
tar xvfj freetype-2.2.1.tar.bz2
patch -p0 < freetype-2.2.1_patented_fonts.patch

COMPILE:
./configure --prefix=/usr &&
make &&
make install

Make shure your /usr/lib/libfreetype.so.6.3.10 has been updated !
Restart X11.

Thats all, if you now install the copyrighted microsoft ttf fonts on your linux system, you have good looking fonts, without antialiased switched on. And the Best, it looks a loot better than before.
Well I followed these instructions on my opensuse 10.2 system, and it broke my X!

When I try to start X, it says "Could not start kdeinit. Check your installation". Ctrl-Alt-Bksp gets me back to the console and it says the following:

INPUT_METHOD is not set or empty (no user selected input method).
Trying to start a default input method for the local en_US.UTF-8 ....
There is no default input method for the current locale.
xset: bad font path element (#416), possible causes are:
Directory does not exist or has wrong permissions
Directory missing fonts.dir
Incorrect font server address or syntax
startkde: Starting up...
ksplash: symbol lookup error: /usr/lib/libXft.so.2: undefined symbol: FT_Library_SetLcdFilter
Could not start kdeinit. Check your installation.
Warning: conect() failed: No such file or directory
kbuildsycoca running...
kded [kdeinit]: symbol lookup error: /usr/lib/libXft.so.2: undefined symbol: FT_Library_SetLcdFilter


------------
After following your directions, I actually found a page on the opensuse documentation that tells me the preferred way of doing it for my distro. How can I "undo" what your instructions had me do? I've tried everything I know and I'm sure I'm just missing something simple. I found the libXft.so.2 file but don't know how to do anything with it.

Hope you or someone can help!
BarnyJr is offline   Reply With Quote

Old 02-08-07, 04:42 AM   #21
kriko
openSuSE11
 
kriko's Avatar
 
Join Date: Aug 2005
Location: Europe, Slovenia, Koper
Posts: 515
Default Re: 6600GT Terrible 2D performance

I think opensuse already has patented font rendering, you just have to enable it in config file.

In your case do:
#make uninstall

and reinstall freetype package from cd/dvd or smart (internet repo) like this:
#smart reinstall freetype freetype2
kriko is offline   Reply With Quote
Old 02-08-07, 04:56 PM   #22
BarnyJr
Registered User
 
Join Date: Jan 2007
Posts: 2
Default Re: 6600GT Terrible 2D performance

Well I had to go about it in a slightly more roundabout manner by completely replacing the freetype packages using rpm with the --replacepkgs option, but you got me headed in that direction. Thanks for the help!
BarnyJr is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Boost Your Performance Goals 10x ' This Week on inside* Publications News Archived News Items 0 05-13-12 05:20 PM
NVIDIA Unleashes the GeForce GTX 670 Graphics Card ' Performance Perfected (WCCFTECH) News GeForce GTX 670 Reviews 0 05-10-12 08:40 AM
My UT2003 Tweak Guide DXnfiniteFX Gaming Central 48 10-30-02 11:59 PM
Linux performance of ut2003 Please Read... Linewbie NVIDIA Linux 17 09-23-02 09:02 AM
so let's try this again in the new forum - bad performance with correctly inst.driver neutrino NVIDIA Linux 11 08-01-02 04:19 PM

All times are GMT -5. The time now is 12:18 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.