Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-31-07, 06:27 PM   #13
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Nvidia 8776/9746 with 2.6.20-rc5

Which kernel option was causing problems, MTRR support or AGPGART frontend support?
zander is offline   Reply With Quote
Old 01-31-07, 07:05 PM   #14
wormite
Registered User
 
Join Date: Jan 2007
Posts: 19
Default Re: Nvidia 8776/9746 with 2.6.20-rc5

Actually I just tested it.. And it doesn't work
This thing is getting the better of me.

And sorry for my English, that setting was in the Gentoo wiki page, so I recompile the kernel according to that, which means
MTRR and AGPGART were ENABLED when I test.
wormite is offline   Reply With Quote
Old 01-31-07, 07:44 PM   #15
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Nvidia 8776/9746 with 2.6.20-rc5

Is this problem really specific to Linux 2.6.20-rc*?
zander is offline   Reply With Quote
Old 01-31-07, 07:57 PM   #16
wormite
Registered User
 
Join Date: Jan 2007
Posts: 19
Default Re: Nvidia 8776/9746 with 2.6.20-rc5

Yes, I think so.
When I was using Ubuntu edgy, which is using 2.6.17.10, it wasn't producing the problem, but of course, the kernel was provided by ubuntu itself.
Then I started compiling the kernels, started from 2.6.20-rc5.
I'm using the same configuration as ubuntu used at the first time, then I altered some SATA settings(irrelevant to nvidia driver)
Since when I started using my own kernel, my 3d program has this corruption problem(beryl, game savage)

OK now I'm recompiling the kernel without the apgart enabled, see if it works with nvdia's own NVaGP.

Do you think I should try 2.6.19.2?

BTW, I saw that Quodra is in the legacy list, so should I use a legacy driver?
Mine is quodra 110m using 8776
wormite is offline   Reply With Quote
Old 01-31-07, 09:22 PM   #17
wormite
Registered User
 
Join Date: Jan 2007
Posts: 19
Default Re: Nvidia 8776/9746 with 2.6.20-rc5

Ok, just finished the testing. apgart doesn't affect it.
Now I'm trying to have the MTRR tested.
wormite is offline   Reply With Quote
Old 02-16-07, 04:24 PM   #18
wormite
Registered User
 
Join Date: Jan 2007
Posts: 19
Default Re: Nvidia 8776/9746 with 2.6.20-rc5

Ok, new updates for this problem, 2.6.20 not working. For the MTRR thing I can't change the option in my bios.
BTW, the problem for the picture attached in this thread(the second picture , for the desktop) is, there are strange black lines(or rectangles or whatever you wanna call them) in the top part of the screen. Just for those who can't see anything wrong for that screen shot.
wormite is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 09:35 PM
Rumor regarding lack of 680 availability ViN86 Rumor Mill 6 05-09-12 05:48 PM
ATI R300 & nVidia NV30 - Different visions Uttar Rumor Mill 6 09-06-02 12:19 PM
rh7.3 and nvidia vcrispo NVIDIA Linux 11 07-31-02 09:57 PM

All times are GMT -5. The time now is 12:36 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.