Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-28-07, 09:19 AM   #13
MichaelH
Registered User
 
Join Date: Jan 2007
Posts: 26
Default Re: GeForce 7600 GS blank screen on reboot

This file has the NVIDIA driver in it. I think I finally got a good one.
Attached Files
File Type: zip Xorg.0.log.zip (3.5 KB, 91 views)
File Type: zip nvidia-bug-report.log.zip (21.3 KB, 96 views)

Last edited by MichaelH; 01-28-07 at 11:09 AM.
MichaelH is offline   Reply With Quote
Old 01-28-07, 12:26 PM   #14
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: GeForce 7600 GS blank screen on reboot

The only thing that I see is a failure to load the nvidia kernel module.
netllama is offline   Reply With Quote
Old 01-28-07, 01:08 PM   #15
MichaelH
Registered User
 
Join Date: Jan 2007
Posts: 26
Default Re: GeForce 7600 GS blank screen on reboot

In looking at the bug-report, it appears that the nvidia driver is loaded. Then later unloaded because the error is: Screens found but no usable configuration. What would cause that?

I am also noticing in looking through my logs that there is an error about adding iommu=memaper=2 to the options. I also see that since the it can't get a good aperture, that it appears to be using 64MB of system ram as video ram. Could this be the reason for the error?
MichaelH is offline   Reply With Quote
Old 01-28-07, 01:10 PM   #16
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: GeForce 7600 GS blank screen on reboot

No, the kernel module is not unloaded because the screens don't have a usable configuration, its the other way around.

You shouldn't need to specify an IOMMU just to start X. If you do, that's a BIOS bug.

At this point, there isn't any clear information in your bug report to indicate why X is failing. If you could setup a serial console that might capture any kernel messages that were generated when the system hangs.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 01-28-07, 06:05 PM   #17
MichaelH
Registered User
 
Join Date: Jan 2007
Posts: 26
Default Re: GeForce 7600 GS blank screen on reboot

Well, I upgraded to kernel 2.6.19_1.2895. I ran the nvidia installer and built the driver successfully. It also installed the 3D libs fine. When I started X it failed due to a signal 11. Looks like this happend during the loading of the GLX libs.

Attached it the nvidia-bug-report.
Attached Files
File Type: zip nvidia-bug-report.log.zip (18.7 KB, 91 views)
MichaelH is offline   Reply With Quote
Old 01-28-07, 06:36 PM   #18
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: GeForce 7600 GS blank screen on reboot

What is the output from the following command:
rpm -q xorg-x11-server-sdk pkgconfig
netllama is offline   Reply With Quote
Old 01-28-07, 07:39 PM   #19
MichaelH
Registered User
 
Join Date: Jan 2007
Posts: 26
Default Re: GeForce 7600 GS blank screen on reboot

Here it is:

[mwhall@TAZ ~]$ rpm -q xorg-x11-server-sdk pkgconfig
package xorg-x11-server-sdk is not installed
pkgconfig-0.21-1.fc6

Hope that helps.

Michael
MichaelH is offline   Reply With Quote
Old 01-28-07, 07:45 PM   #20
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: GeForce 7600 GS blank screen on reboot

Looks like you didn't read or follow the sticky posts:
http://www.nvnews.net/vbulletin/showthread.php?t=72490
netllama is offline   Reply With Quote

Old 01-28-07, 08:25 PM   #21
MichaelH
Registered User
 
Join Date: Jan 2007
Posts: 26
Default Re: GeForce 7600 GS blank screen on reboot

Followed instructions and ran yum. I rebuilt the nvidia driver. Attached is the nvidia-bug-report. Still get a blank screen and system is locked.
Attached Files
File Type: zip nvidia-bug-report.log.zip (26.1 KB, 77 views)
MichaelH is offline   Reply With Quote
Old 01-28-07, 08:46 PM   #22
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: GeForce 7600 GS blank screen on reboot

Did you ensure that you're using the latest motherboard BIOS?
If you set NvAGP to 0 in xorg.conf does that have any impact?
netllama is offline   Reply With Quote
Old 01-29-07, 10:04 AM   #23
MichaelH
Registered User
 
Join Date: Jan 2007
Posts: 26
Default Re: GeForce 7600 GS blank screen on reboot

I added NvAgp to the xorg.conf file and it seemed to make no difference. I got the signal 11 proplem with it instead of the screen going black and the system locking up. I have checked my BIOS and I am on version F7 and there is a F8, but it only adds support for Opteron processors.

I have attached the conf file.

Michael
Attached Files
File Type: txt xorg.conf.txt (2.6 KB, 104 views)
MichaelH is offline   Reply With Quote
Old 01-29-07, 11:33 AM   #24
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: GeForce 7600 GS blank screen on reboot

According to the xorg.conf that you posted, you're using the 'nv' X driver again.

I'd still suggest updating to the latest SBIOS.
netllama is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
What You Can Expect From GeForce GRID News Archived News Items 0 06-04-12 04:20 PM
Nvidia GeForce 301.42 WHQL drivers DSC NVIDIA Windows Graphics Drivers 5 05-29-12 10:12 PM
Enhance Max Payne 3, Diablo III with GeForce R300 Drivers News Archived News Items 0 05-22-12 06:30 PM
New GPU from Nvidia Announced Today, the GeForce GTX 670 News Archived News Items 0 05-10-12 01:50 PM
Gainward Unleashes the Sexy GeForce GTX 670 Phantom Graphics Card, Also launches the News Archived News Items 0 05-10-12 09:28 AM

All times are GMT -5. The time now is 07:03 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.