Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-29-07, 03:45 PM   #1
skymt
Registered User
 
Join Date: Jul 2005
Posts: 3
Default OpenGL texture rendering (GF4 MX, 9631)

After upgrading to the 9xxx driver series (specifically, 9631), OpenGL texture rendering seems to have been broken on my system (GF4 MX). Most programs that use OpenGL give a totally black display. Others, like crack-attack, xmoto, and glxgears, seem able to draw some things. I've posted some screenshots to help explain.

The problem occurs with the 9631 series drivers on either Ubuntu and Arch Linux. I get the same results whether I use the official version downloaded from nvidia.com or the packaged versions provided by whichever distribution I use. The legacy (7xxx) drivers cause an immediate crash when an application tries to use OpenGL.

8xxx drivers work, but it's my understanding that only the current and legacy drivers will be updated for changes in the kernel. Downgrading to them would only be putting the problem off until later.

Beryl and Compiz work well, and don't affect the rendering problem in any way.
Attached Thumbnails
Click image for larger version

Name:	xmoto.png
Views:	123
Size:	7.5 KB
ID:	23777  Click image for larger version

Name:	crack-attack.png
Views:	120
Size:	57.7 KB
ID:	23778  Click image for larger version

Name:	glxgears.png
Views:	123
Size:	8.3 KB
ID:	23779  
skymt is offline   Reply With Quote
Old 01-29-07, 03:47 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: OpenGL texture rendering (GF4 MX, 9631)

http://www.nvnews.net/vbulletin/showthread.php?t=46678
netllama is offline   Reply With Quote
Old 01-29-07, 04:48 PM   #3
skymt
Registered User
 
Join Date: Jul 2005
Posts: 3
Default Re: OpenGL texture rendering (GF4 MX, 9631)

Here's the .log (gzipped, it's too big to attach otherwise). Please disregard the install log included in the .log, it's from a recent failed attempt to install the 8xxx drivers from the official NVIDIA .sh package. Currently, I'm using the Arch driver package.
Attached Files
File Type: gz nvidia-bug-report.log.gz (33.2 KB, 111 views)
skymt is offline   Reply With Quote
Old 01-29-07, 04:58 PM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: OpenGL texture rendering (GF4 MX, 9631)

Does this problem reproduce if you're not using the Composite extension or the TripleBuffer option?
netllama is offline   Reply With Quote
Old 01-29-07, 06:02 PM   #5
skymt
Registered User
 
Join Date: Jul 2005
Posts: 3
Default Re: OpenGL texture rendering (GF4 MX, 9631)

The symptoms are the same when I disable Composite, TripleBuffer, and ARGB, and restart the X server.
skymt is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Major WineX prob... I think it has to do with the vidcard... Linewbie NVIDIA Linux 20 10-09-02 10:58 PM

All times are GMT -5. The time now is 01:48 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.