Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-30-07, 09:13 AM   #1
Bakked
Registered User
 
Join Date: Jan 2007
Posts: 13
Default Am I screwed? (NVRM: Xid)

The day before yesterday I updated a lot of programs and everything went well. I could use my computer normally yesterday but today when I started it I could not play movies if the player used xvideo. I found the following errors in logs:
Xorg.0.log:
(WW) NVIDIA(0): The NVIDIA X driver has encountered too many errors. Falling
(WW) NVIDIA(0): back to legacy PCI mode.
and dmesg:
NVRM: Xid (0001:00): 13, 0000 01019700 00004097 00001754 00000000 00000002
NVRM: Xid (0001:00): 1, Channel 00000000 Method 00000060 Data 0101020c (lots of these)

I'm guessing this is a hardware error. I had an old geforce 2 card which hung my Xserver with some Xid error in the syslog and I had to replace the card to fix the error. I have not made any hardware changes or software changes since the computer was working. Everything seems to work except xvideo. I get a blank video player and an unresponsive system when I try. Are there any test I could run or should I just look for a new card?

System info:
amd x2, smp system
GeForce 6600LE PCIe (passive cooling)
kernel-2.6.20-rc6
dist gentoo
nvidia-drivers-1.0.9746
mobo asus a8n-sli premium
Bakked is offline   Reply With Quote
Old 01-30-07, 11:43 AM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Am I screwed? (NVRM: Xid)

http://www.nvnews.net/vbulletin/showthread.php?t=46678
netllama is offline   Reply With Quote
Old 02-02-07, 07:56 AM   #3
Bakked
Registered User
 
Join Date: Jan 2007
Posts: 13
Default Re: Am I screwed? (NVRM: Xid)

The error turned out to be a little more elusive than I first thought. The error occurred two times in a row so I thought it was always reproducible but I was wrong. Everything worked fine for two days until today. Again the same error but when I reboot to get a bugreport with logverbose it's gone. I'm going to run with logverbose on from now on until it occurs again.
Bakked is offline   Reply With Quote
Old 02-02-07, 08:09 AM   #4
LubosD
Registered User
 
Join Date: Jan 2005
Location: Czech Republic
Posts: 451
Send a message via ICQ to LubosD
Default Re: Am I screwed? (NVRM: Xid)

I have experienced the same problem, but there is no specific way to reproduce it again.
It has happened several times when I ran 2 independent XVideo applications.

I will post a bugreport when it happens again.
LubosD is offline   Reply With Quote
Old 02-04-07, 02:23 AM   #5
Bakked
Registered User
 
Join Date: Jan 2007
Posts: 13
Default Re: Am I screwed? (NVRM: Xid)

The error occurred again today and I was able to get a bug-report. I put it here: http://www-und.ida.liu.se/~tholi945/...bug-report.log
the /var/log/messages looks worse than it is. I got this card a year ago. All the other Xid are from the old card. The Xorg.conf is a little messy but I use the geforce card for my primary screen and a voodoo3 for an other screen running in xinerama.
Bakked is offline   Reply With Quote
Old 02-04-07, 11:50 AM   #6
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Am I screwed? (NVRM: Xid)

Does this problem persist if you're not using the Voodoo3 card?
Does this problem persist if you're not using the ConnectedMonitor option?
Does this problem persist with a stable, released kernel?
Have you verified that you're using the latest motherboard BIOS?

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 02-04-07, 05:39 PM   #7
LubosD
Registered User
 
Join Date: Jan 2005
Location: Czech Republic
Posts: 451
Send a message via ICQ to LubosD
Default Re: Am I screwed? (NVRM: Xid)

Quote:
Originally Posted by netllama
Does this problem persist if you're not using the Voodoo3 card?
Does this problem persist if you're not using the ConnectedMonitor option?
Does this problem persist with a stable, released kernel?
Have you verified that you're using the latest motherboard BIOS?
I can say yes for all of them, GeForce 7950 GX2.

I sent you a bugreport some time ago (likely right after the Christmas) but later I told you it was fixed in the new driver version. Well, I was wrong, I just didn't know that there was no specific way to reproduce this bug.
LubosD is offline   Reply With Quote
Old 02-04-07, 06:31 PM   #8
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Am I screwed? (NVRM: Xid)

How is a GeForce 7950 GX2 involved here?
Specifically how can the problem be reproduced?
netllama is offline   Reply With Quote

Old 02-08-07, 04:28 AM   #9
Bakked
Registered User
 
Join Date: Jan 2007
Posts: 13
Default Re: Am I screwed? (NVRM: Xid)

A small status update:

Does this problem persist if you're not using the ConnectedMonitor option: Yes
Does this problem persist with a stable, released kernel: Yes. I'm now running 2.6.20-final (probably not what you meant by stable).
Have you verified that you're using the latest motherboard BIOS: I have upgraded to the most recent version.

I haven't tried to disable the voodoo card yet. It's a pita to use a monohead setup.

If you had to follow your gut feeling would you say hardware or software error?

Note: The error seems to occur the first time the xv extension is initiated after a restart. If it fails it will always fail and if it succeeds it will always work until the next restart.
Bakked is offline   Reply With Quote
Old 02-08-07, 11:30 AM   #10
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Am I screwed? (NVRM: Xid)

I don't have a gut feeling right now, however disabling the Voodoo card would be a useful experiment.
netllama is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
NVRM: Xid while using chromium browser blekot NVIDIA Linux 2 06-26-12 02:29 PM
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 12:04 PM
Screen freeze NVRM: Xid error ciancaroll NVIDIA Linux 0 06-05-12 02:05 PM
Xorg hang with 100% cpu, any driver version, GTX275 bones_was_here NVIDIA Linux 20 05-23-12 10:49 AM
GTX 460M, Xorg 1.12, nvidia driver 295.49, linux 3.3.5-1-ARCH and NVRM Xid 44 elsifaka NVIDIA Linux 0 05-14-12 09:48 AM

All times are GMT -5. The time now is 03:56 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.