Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-24-07, 07:40 AM   #1
ewildgoose
Registered User
 
Join Date: Dec 2005
Posts: 6
Default 6600GT Terrible 2D performance

A while back I bought a 6600GT from Gigabyte because it was the only decent fanless card I could find. It has had continuous performance problems with 2D whenever anti-aliased fonts are enabled (it's not terrific when they are disabled either mind)

It is literally sometimes lagging me typing this message in right now. If I use Konsole then you can easily watch the redraw down the screen. Dragging Konsoles scroll bar up and down generates 100% cpu load.

If I turn off aliased fonts then I have trouble reading stuff on my LCD screen in Firefox and Thunderbird in particular - fonts are very gritty and poor quality. However, 2D speeds are dramatically better and things almost become bearable (but it's still a lot slower than same applications Windows on slower hardware). GLXGears gives 3,600 or so...

I have played with suggestions on this forum for months now and just tried updating to the latest drivers to no effect. I need a solution though

Can someone from NVidia please help (or tell me how I can trade it up for a working card...)
Attached Files
File Type: log nvidia-bug-report.log (105.7 KB, 115 views)
ewildgoose is offline   Reply With Quote
Old 01-24-07, 11:33 AM   #2
__entropy__
Registered User
 
Join Date: Oct 2006
Posts: 17
Default Re: 6600GT Terrible 2D performance

Same here.
Would be nice to see this fixed any time soon.
Attached Files
File Type: log nvidia-bug-report.log (78.8 KB, 106 views)
__entropy__ is offline   Reply With Quote
Old 01-24-07, 12:32 PM   #3
ewildgoose
Registered User
 
Join Date: Dec 2005
Posts: 6
Default Re: 6600GT Terrible 2D performance

I am using an Asus P4C-800, possibly not the very latest bios (not sure). AGP. Fastwrites don't seem to be on

Any other common clues here?

If I throw away this card (which cost me 1/3 the price of the computer) and get a 7600 GS, will the problem be gone?
ewildgoose is offline   Reply With Quote
Old 01-24-07, 01:31 PM   #4
PenGun
Registered User
 
Join Date: Jan 2006
Posts: 93
Default Re: 6600GT Terrible 2D performance

You sure that's not KDE. I hate both KDE and Gnome 'cause they are so slow and use all kinds of system resources to no apparent end.

My GT6600 is just peachy in 2D and 3D but I use fluxbox which just runs X and gets out of the way. Rxvt does everything Konsole does but instantly with very little overhead.
PenGun is offline   Reply With Quote
Old 01-24-07, 01:42 PM   #5
pe1chl
Registered User
 
Join Date: Aug 2003
Posts: 1,026
Default Re: 6600GT Terrible 2D performance

Quote:
Originally Posted by ewildgoose
A while back I bought a 6600GT from Gigabyte because it was the only decent fanless card I could find. It has had continuous performance problems with 2D whenever anti-aliased fonts are enabled (it's not terrific when they are disabled either mind)
This has been a known bug for at least a year. It is still not fixed.
However, when you do not use the subpixel hinting (or set it to grayscale) it will work much better. This is under fonts -> antialias -> configuration.
pe1chl is offline   Reply With Quote
Old 01-24-07, 02:08 PM   #6
ewildgoose
Registered User
 
Join Date: Dec 2005
Posts: 6
Default Re: 6600GT Terrible 2D performance

I only have RGB options in here? If I enable the anti-aliasing, but don't enable the rgb stuff then it doesn't appear to do anything at all? (So how to enable greyscale anti-alias?)

Cheers
ewildgoose is offline   Reply With Quote
Old 01-24-07, 05:07 PM   #7
PenGun
Registered User
 
Join Date: Jan 2006
Posts: 93
Default Re: 6600GT Terrible 2D performance

Quote:
Originally Posted by pe1chl
This has been a known bug for at least a year. It is still not fixed.
However, when you do not use the subpixel hinting (or set it to grayscale) it will work much better. This is under fonts -> antialias -> configuration.
So what is that, an AGP thing?
PenGun is offline   Reply With Quote
Old 01-24-07, 06:48 PM   #8
__entropy__
Registered User
 
Join Date: Oct 2006
Posts: 17
Thumbs down Re: 6600GT Terrible 2D performance

Ok, I should have searched the forum before:
http://www.nvnews.net/vbulletin/showthread.php?t=65857

Apparently there is no update from the devs concerning this issue - I wonder why...
__entropy__ is offline   Reply With Quote

Old 01-25-07, 02:12 AM   #9
PenGun
Registered User
 
Join Date: Jan 2006
Posts: 93
Default Re: 6600GT Terrible 2D performance

Oh hell, I dunno why anyone uses that crap. KDE, Gnome ... you lonely for windose or something?

Programmers whining about sub pixel font rendering, I'm gonna go back to FreeBSD if this keeps up .

Fat and bloated has been done. Lean and mean is how I like my machine.

This running a satellite card, an HDTV, a mini DAW, 64bit and 32 bit mplayers (no gui, xine fer DVDs ... I could go on but my point is you have no need of that junk.

I only do this once in a while but those lame window managers drive me crazy. Thanks for your patience.
PenGun is offline   Reply With Quote
Old 01-25-07, 02:52 AM   #10
pe1chl
Registered User
 
Join Date: Aug 2003
Posts: 1,026
Default Re: 6600GT Terrible 2D performance

Quote:
Originally Posted by PenGun
This has been a known bug for at least a year. It is still not fixed.
However, when you do not use the subpixel hinting (or set it to grayscale) it will work much better. This is under fonts -> antialias -> configuration.
So what is that, an AGP thing?
It is in the KDE Control Center under Appearance -> Fonts.
Maybe you have an old KDE version? I use 3.4.2 level b (SuSE 10.0), probably not the newest either.

It has been discussed before and it happens only on certain cards (6600GT is affected) but it seems either nvidia is unable to fix it or it is a low priority to them.
pe1chl is offline   Reply With Quote
Old 01-25-07, 03:02 AM   #11
whig
550Ti
 
Join Date: Jan 2004
Location: New Zealand
Posts: 854
Default Re: 6600GT Terrible 2D performance

Do font problems persist when using the 2D "nv" driver?
whig is offline   Reply With Quote
Old 01-28-07, 03:51 AM   #12
_john_i_
gtx260/8200M G/DIY Linux
 
Join Date: Aug 2004
Location: Austin, TX USA
Posts: 137
Default Re: 6600GT Terrible 2D performance

Quote:
Originally Posted by whig
Do font problems persist when using the 2D "nv" driver?
Yes, they do.
_john_i_ is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Boost Your Performance Goals 10x ' This Week on inside* Publications News Archived News Items 0 05-13-12 05:20 PM
NVIDIA Unleashes the GeForce GTX 670 Graphics Card ' Performance Perfected (WCCFTECH) News GeForce GTX 670 Reviews 0 05-10-12 08:40 AM
My UT2003 Tweak Guide DXnfiniteFX Gaming Central 48 10-30-02 11:59 PM
Linux performance of ut2003 Please Read... Linewbie NVIDIA Linux 17 09-23-02 09:02 AM
so let's try this again in the new forum - bad performance with correctly inst.driver neutrino NVIDIA Linux 11 08-01-02 04:19 PM

All times are GMT -5. The time now is 12:03 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.