Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-30-06, 05:49 AM   #1
martinjreed
Martin Reed
 
Join Date: Aug 2004
Posts: 8
Default xrandr not working after suspend resume cycle

Hi,

I have a problem with Xranr after a suspend to RAM. It works as many times as I like after a clean start of X but after suspend to RAM it silently ignores any mode switch request. I frequently change between

twinview (with external CRT) <-> single laptop screen <-> clone (for presentations)

a number of times a day so getting this working would be really nice.

It used to work flawlessly on Xorg 6.8 (I think) and an older version of the nvidia driver (7000 series I think). I am not sure which upgrade (Xorg or nvidia driver) stopped it working. The main problem is I am not sure if it is an Xorg problem or an nvidia driver problem so I do not even know where to start asking/looking but am trying here first!

Set up is:

Dell Latitude D820, nVidia Corporation Quadro NVS 110M GeForce Go 7300

Linux 2.6.18 (gentoo suspend2 patches), SMP and PREEMPT enabled, (nv driver and AGP disabled)
Xorg 7.1
nvidia-drivers 1.0.9629
ACPI enabled

nvidia relevant part of Xorg.conf
Code:
Section "Device"
	Identifier  "Card0twinview"
	Driver      "nvidia"
	VendorName  "nVidia Corporation"
	BoardName   "Unknown Board"
	BusID       "PCI:1:0:0"
	Option 	    "NvAgp"	"1"
	Option	    "TwinView" "true"
	Option      "TwinViewOrientation" "CRT-0 LeftOf DFP-0"
	Option	    "ConnectedMonitor" "DFP-0, CRT-0"
    Option "SecondMonitorHorizSync"   "50-90"
    Option "SecondMonitorVertRefresh" "59-75"

	Option      "FlatPanelProperties" "Scaling=aspect-scaled"
	Option "MetaModes" "CRT-0: 1024x768 +0+0, DFP-0: 1024x768 +0+0 ; CRT-0: 1280x1024 +0+0, DFP-0: 1680x1050 +1280+0; CRT-0: NULL, DFP-0: 1680x1050 +0+0"
	Option "RenderAccel" "on"
	Option "DPI" "129 x 120"
	Option "ConstantDPI" "false"
	Screen 0
EndSection
I first noticed this problem on another older Dell Inspiron machine after an Xorg/nvidia upgrade
martinjreed is offline   Reply With Quote
Old 12-15-06, 11:27 AM   #2
walex0325
Registered User
 
Join Date: Dec 2006
Posts: 5
Default Re: xrandr not working after suspend resume cycle

Have you tried using the nvidia-settings utility to disable/enable your different TwinView configurations? Dynamic Twinview control seems to work well. I too have the same problems with xrandr after resuming (using suspend2). Unfortunately, I also have problems suspending after enabling or disabling displays in nvidia-settings. Just wondering if you saw the same issue.
walex0325 is offline   Reply With Quote
Old 03-12-07, 11:07 AM   #3
walex0325
Registered User
 
Join Date: Dec 2006
Posts: 5
Default Re: xrandr not working after suspend resume cycle

This has been patched. Available at

https://bugs.freedesktop.org/attachm...86&action=edit
walex0325 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
302.07 no resume from suspend stecklum NVIDIA Linux 85 12-07-12 01:27 PM
xrandr shift after 302.17 not working. C-J NVIDIA Linux 4 06-28-12 09:00 AM
[Bug Report] Xid error after resume with 307.02, and compiz stops working. John K. NVIDIA Linux 0 05-09-12 02:42 PM

All times are GMT -5. The time now is 09:56 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.