Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-14-03, 11:35 AM   #13
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

OK... find won't print an error if no file is found, it'll just do nothing, like it did. So you, for reasons unknown ATM, don't have a kernel module anywhere.

From a freshly-decompressed NVIDIA_kernel directory, do a make >log.txt 2>&1 as root and attach the resulting log.txt file.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 03-14-03, 01:24 PM   #14
rObkE
[root@robke]# rm war -rf
 
Join Date: Mar 2003
Location: Belgium
Posts: 15
Default

Here you go...
rObkE is offline   Reply With Quote
Old 03-14-03, 05:23 PM   #15
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Install kernel-source.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 03-15-03, 06:46 AM   #16
rObkE
[root@robke]# rm war -rf
 
Join Date: Mar 2003
Location: Belgium
Posts: 15
Default

That means I have to compile the source RPM? When I to that, I get about the same errors as in my log.txt...
BTW, before I opened this thread I reinstalled the RPMs and tarballs about a dozain times, and once I succeeded launching kde, but after a reboot I simply got a blank screen again.
rObkE is offline   Reply With Quote
Old 03-15-03, 07:17 AM   #17
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

No, that means install your Linux kernel's source package. It's named kernel-source, and the version has to match what uname -r tells you. And unless you've updated your kernel at all (Mandrake doesn't do that, do they?), it's on your original distro CDs -- CD 3, to be exact.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 03-15-03, 09:49 AM   #18
rObkE
[root@robke]# rm war -rf
 
Join Date: Mar 2003
Location: Belgium
Posts: 15
Default

I installed ncurses-devel and kernel-source. Building the tarballs worked, but when running X I get a...? Blank screen.

Last edited by rObkE; 03-15-03 at 12:13 PM.
rObkE is offline   Reply With Quote
Old 03-15-03, 06:21 PM   #19
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default You're not going to want to hear this, but...

That one, I don't have an answer for.

You can try searching this forum for "blank screen", and you might just come up with something. No guarantees though...
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 03-16-03, 07:00 AM   #20
rObkE
[root@robke]# rm war -rf
 
Join Date: Mar 2003
Location: Belgium
Posts: 15
Default

thx anyway
i've learned a lot while messing around trying to get my drivers work
i'll try to recompile both rpms this time
rObkE is offline   Reply With Quote

Old 03-16-03, 09:50 AM   #21
rObkE
[root@robke]# rm war -rf
 
Join Date: Mar 2003
Location: Belgium
Posts: 15
Default

I did a clean install and found this in my logs:
Quote:
Mar 16 16:36:16 localhost -- root[1476]: ROOT LOGIN ON vc/1
Mar 16 16:36:21 localhost kernel: 0: nvidia: loading NVIDIA Linux x86 nvidia.o Kernel Module 1.0-4191 Mon Dec 9 11:49:01 PST 2002
Mar 16 16:36:34 localhost kernel: Linux agpgart interface v0.99 (c) Jeff Hartmann
Mar 16 16:36:34 localhost kernel: agpgart: Maximum main memory to use for agp memory: 203M
Mar 16 16:36:34 localhost kernel: agpgart: Unsupported SiS chipset (device id: 0648), you might want to try agp_try_unsupported=1.
Mar 16 16:36:34 localhost insmod: /lib/modules/2.4.19-16mdk/kernel/drivers/char/agp/agpgart.o.gz: init_module: No such device
Mar 16 16:36:34 localhost insmod: Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters. You may find more information in syslog or the output from dmesg
Mar 16 16:36:34 localhost modprobe: modprobe: insmod agpgart failed
Mar 16 16:36:34 localhost kernel: 0: NVRM: AGPGART: unable to retrieve symbol table
Mar 16 16:40:12 localhost syslogd 1.4.1: restart.
Is this of any help?
rObkE is offline   Reply With Quote
Old 03-16-03, 11:49 AM   #22
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Yes, it does help:

Quote:
Mar 16 16:36:34 localhost kernel: agpgart: Unsupported SiS chipset (device id: 0648), you might want to try agp_try_unsupported=1.
So the problem is that you're using an SiS chipset that isn't supported by that version of agpgart. If you think it works just like all the other SiS chipsets (which is often, but not always, the case), then you can edit /etc/modules.conf and add a line that looks like options agpgart agp_try_unsupported=1, save and exit, and run /sbin/depmod -a (this will get rid of a warning that modules.conf is more recent than the module dependency file). Then try it again, and see if it works.

It may not -- if not, then try upgrading your kernel, to something like the newest 2.4.21-pre that's out. To do that, you will need to download 2.4.20 and the .21-pre patch, then decompress 2.4.20 and apply the patch. Copy the .config file from Mandrake's kernel source into the root of your .21-pre kernel tree, and run make menuconfig. Check through the settings; you may want to make some things built into the kernel so you don't have to deal with an initrd (stuff like your root filesystem, and support for IDE devices, would be a good thing to build in -- anything that would be required to mount the root filesystem). Then continue with the kernel build process, as documented in Documentation/Changes in the source tree.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 03-16-03, 01:46 PM   #23
rObkE
[root@robke]# rm war -rf
 
Join Date: Mar 2003
Location: Belgium
Posts: 15
Default

Quote:
So the problem is that you're using an SiS chipset that isn't supported by that version of agpgart. If you think it works just like all the other SiS chipsets (which is often, but not always, the case), then you can edit /etc/modules.conf and add a line that looks like options agpgart agp_try_unsupported=1, save and exit, and run /sbin/depmod -a (this will get rid of a warning that modules.conf is more recent than the module dependency file). Then try it again, and see if it works.
Done that, simply get a blank screen again. When I check my logs I see the same errors as above.
Tomorrow or so I'll try to update my kernel...
rObkE is offline   Reply With Quote
Old 03-23-03, 06:18 AM   #24
rObkE
[root@robke]# rm war -rf
 
Join Date: Mar 2003
Location: Belgium
Posts: 15
Default

I was looking on how to update my kernel, and I found this on the MandrakeLinux site:
Quote:
Error scenario: When installing using an Nvidia card on some particular monitors, X11 is badly configured and cannot start.
Why: The installer misdetects a Plug'n Play monitor and configures it incorrectly in the Monitor section of XF86Config-4.
Solution: Format a floppy disk with a DOS filesystem (in Linux, you can use the command "mkdosfs /dev/fd0"). Copy patch.pl to the floppy disk. Remove the floppy and reboot using the Mandrake Linux 9.0 CD1 to do a CD-ROM installation. During boot, press F1 at the splash screen, then place your floppy disk that contains patch.pl in the floppy drive. At the prompt, type "patch", then follow the installation as usual.
Could it be...?
There might be one slight problem: I don't have a floppy drive...

Last edited by rObkE; 03-23-03 at 06:58 AM.
rObkE is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mandrake Linux 9.0 (Dolphin) now available | comments? volt General Linux 10 10-19-02 10:13 PM
POSSIBLE AGP TROUBLE (mandrake 9.0) chrono86 NVIDIA Linux 4 10-12-02 12:09 PM
Mandrake 9.0 driver installation Andy Mecham NVIDIA Linux 3 10-02-02 04:12 PM
Mandrake 9.0 upgrade - x crashes gozilla NVIDIA Linux 2 09-27-02 10:04 AM
mandrake 9.0 beta 4 junkphreak2002 NVIDIA Linux 6 09-04-02 08:23 PM

All times are GMT -5. The time now is 03:23 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.