Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-06-07, 09:08 PM   #1
nvkrudl3r
Registered User
 
Join Date: Feb 2007
Posts: 14
Default 6150 + SUSE 10.2 - YAST install of nvidia driver(s) not working

Hello,

I have an MSI 6150... SUSE was installed with the BIOS "OnChip VGA Frame Buffer Size [16MB]" and "OnChip VGA Trap Enable [Enable]".

Single core, with 2.6.18.2-34-default kernel.

I installed x11-video-nvidia and nvidia-gfx-kmp-default packages via YAST. Re-started X.

VESA Framebuffer is still my only video option. sax2 log says:

FATAL: Error inserting nvidia (/lib/modules/2.6.18.2-34-default/updates/nvidia.ko): No such device
(EE) NVIDIA(0): Failed to load the NVIDIA kernel module!
(EE) NVIDIA(0): *** Aborting ***
(II) UnloadModule: "nvidia"
(II) UnloadModule: "ramdac"
(II) UnloadModule: "fb"
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

Similar error after a init 3 modprobe attempt.

The nvidia.ko file does exist at that location. Any thoughts?

Just getting back into linux, after a few years off... please be kind. I would rather not "do it the hard way", so posting a nvidia-installer.log is not an option now... I'm hoping someone ran into the same trouble with 10.2 (searched, with no luck)? Thanks.
nvkrudl3r is offline   Reply With Quote
Old 02-06-07, 10:22 PM   #2
nvkrudl3r
Registered User
 
Join Date: Feb 2007
Posts: 14
Default Re: 6150 + SUSE 10.2 - YAST install of nvidia driver(s) not working

Quote:
Originally Posted by nvkrudl3r
I would rather not "do it the hard way", so posting a nvidia-installer.log is not an option now... I'm hoping someone ran into the same trouble with 10.2 (searched, with no luck)? Thanks.
By that, I mean I am trying to get the drivers installed without using one of the official .run installers... that should be possible with SUSE 10.2.
nvkrudl3r is offline   Reply With Quote
Old 02-06-07, 11:39 PM   #3
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: 6150 + SUSE 10.2 - YAST install of nvidia driver(s) not working

FATAL: Error inserting nvidia (/lib/modules/2.6.18.2-34-default/updates/nvidia.ko): No such device
Please check the output of `dmesg` for 'NVRM' messages at the time of the failure.
zander is offline   Reply With Quote
Old 02-07-07, 11:59 AM   #4
nvkrudl3r
Registered User
 
Join Date: Feb 2007
Posts: 14
Default Re: 6150 + SUSE 10.2 - YAST install of nvidia driver(s) not working

From dmesg, after init 3 modprobe nvidia:

nvidia: module license 'NVIDIA' taints kernel.
NVRM: The NVIDIA probe routine was not called for 1 device(s).
NVRM: This can occur when a driver such as rivafb, nvidiafb or
NVRM: rivatv was loaded and obtained ownership of the NVIDIA
NVRM: device(s).
NVRM: Try unloading the rivafb, nvidiafb or rivatv kernel module
NVRM: (and/or reconfigure your kernel without rivafb/nvidiafb
NVRM: support), then try loading the NVIDIA kernel module again.
NVRM: No NVIDIA graphics adapter probed!

So after:
init 3
modprobe -r nvidiafb
modprobe -r rivafb
modprobe -r rivatv

And then: modprobe nvidia, same result.

Thanks for taking an interest in this problem... perhaps it is better suited for the SUSE forums, but there has been good support here for the 6150, so I figured this was a good place to start.
nvkrudl3r is offline   Reply With Quote
Old 02-07-07, 12:51 PM   #5
adamk75
Registered User
 
Join Date: Nov 2006
Posts: 228
Default Re: 6150 + SUSE 10.2 - YAST install of nvidia driver(s) not working

FYI, I encountered the exact same problem with the drivers installed via yast. I know that you don't want to use the drivers from nVidia's website, but they did get everything working for me.
adamk75 is offline   Reply With Quote
Old 02-07-07, 05:49 PM   #6
nvkrudl3r
Registered User
 
Join Date: Feb 2007
Posts: 14
Default Re: 6150 + SUSE 10.2 - YAST install of nvidia driver(s) not working

Quote:
Originally Posted by adamk75
FYI, I encountered the exact same problem with the drivers installed via yast. I know that you don't want to use the drivers from nVidia's website, but they did get everything working for me.
That is certainly good to know I have an out. One of the reasons I was coming back to GNU/Linux was the fact that (supposedly) a kernel update or the like wasn't going to FUBAR your video settings/drivers, etc. But perhaps SUSE isn't quite there yet.
nvkrudl3r is offline   Reply With Quote
Old 02-07-07, 05:55 PM   #7
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: 6150 + SUSE 10.2 - YAST install of nvidia driver(s) not working

The nvidia kernel module is always built against a specific kernel version (as are nearly all kernel modules). This is part of the kernel module architecture, and isn't SuSE specific.
netllama is offline   Reply With Quote
Old 02-07-07, 06:28 PM   #8
nvkrudl3r
Registered User
 
Join Date: Feb 2007
Posts: 14
Default Re: 6150 + SUSE 10.2 - YAST install of nvidia driver(s) not working

Quote:
Originally Posted by netllama
The nvidia kernel module is always built against a specific kernel version (as are nearly all kernel modules). This is part of the kernel module architecture, and isn't SuSE specific.
I was speaking of the YaST update method, which would be SUSE specific.
nvkrudl3r is offline   Reply With Quote

Old 02-07-07, 07:05 PM   #9
nvkrudl3r
Registered User
 
Join Date: Feb 2007
Posts: 14
Default Re: 6150 + SUSE 10.2 - YAST install of nvidia driver(s) not working

OK. I compiled. After the first run of sax2 stuck me at a refresh rate of 53 for my CRT?!?... I am now up and running fine.

Please don't waste valuable time trying to fix this, but if anyone does know how to get the drivers installed in SUSE 10.2 with YaST (on a 6150), please post here.

Thanks.

EDIT: I see there is still some issue with the refresh rate... sax2 listed it correctly at 85 (and it looks like 85), but in configure desktop->display, the list has 50-59 as my choices. Hmmmm.
nvkrudl3r is offline   Reply With Quote
Old 02-08-07, 03:46 AM   #10
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: 6150 + SUSE 10.2 - YAST install of nvidia driver(s) not working

nvkrudl3r: See the README documentation on the "DynamicTwinView" option.
AaronP is offline   Reply With Quote
Old 02-08-07, 06:08 PM   #11
nvkrudl3r
Registered User
 
Join Date: Feb 2007
Posts: 14
Default Re: 6150 + SUSE 10.2 - YAST install of nvidia driver(s) not working



Wow... I wasn't even looking for help on that problem, and here you guys go and point me towards the solution before I have time to even start... Thanks!

Regarding the OT, I did find some mention of a "tiny-nvidia-installer" that simplified the process somewhat in SUSE 10.1/2...

http://susewiki.org/index.php?title=...aphics_Drivers

But it was later removed...

http://lists.opensuse.org/opensuse-f.../msg00049.html
nvkrudl3r is offline   Reply With Quote
Old 02-11-07, 04:45 PM   #12
F. W. Kooistra
Registered User
 
Join Date: Feb 2007
Posts: 9
Default Re: 6150 + SUSE 10.2 - YAST install of nvidia driver(s) not working

I dir 3 /5 install the same way : Yast
3 went thru good
1 wenr bad : but other hardware was bad too
1 went bad : and that was on two fields diffrent hardware
1/ amd 64 x2 proc + PCI e bus
all otherw ere 32 bit amd + agp video bus
__________________
Frank W. Kooistra : Delft The Netherlands
F. W. Kooistra is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Geforce 440 Go, SuSE 8.0, and new Nvidia drivers loudawg NVIDIA Linux 4 06-01-04 12:54 AM
Radeon 9700 not all that? sancheuz Other Desktop Graphics Cards 200 10-12-02 09:31 PM
Suse 8.1 and Nvidia drivers tombraider500 NVIDIA Linux 4 10-06-02 11:19 AM
Red Hat null(limbo beta 3), guide to install Nvidia Drivers utiel NVIDIA Linux 21 09-30-02 05:32 PM
NVIDIA drivers won't install... Dnzauker NVIDIA Linux 6 09-12-02 06:47 AM

All times are GMT -5. The time now is 05:56 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.