Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-10-07, 10:37 PM   #1
rotarychainsaw
Registered User
 
Join Date: Mar 2006
Posts: 25
Default Xorg 100%cpu and NVRM:Xid messages

Hey all,
I have been trying to get beryl going on an old laptop with a geforce2 go chip in it(driver 9631). Normal metacity works fine with no lockups, but when I start beryl or compiz after about 5 - 10 minutes X will lock up. The mouse will still move, but nothing else. It will also unlock itself once in a while. I left open the task manager thing and it looks like X.org shoots up to 99% usage for the whole time.

I left the system log viewer open and got it to lock to see what comes up.
Kernel log:
Feb 10 22:13:35 bj-laptop kernel: [17205373.788000] NVRM: Xid (0001:00): 8, Channel 00000000
X.org.log
(WW) NVIDIA(0): WAIT (0, 7, 0x8000, 0x00004994, 0x00004994)

Do these errors shed any light as to what is going on?
Thanks in advance

Last edited by rotarychainsaw; 02-14-07 at 09:09 AM.
rotarychainsaw is offline   Reply With Quote
Old 02-11-07, 04:39 PM   #2
rotarychainsaw
Registered User
 
Join Date: Mar 2006
Posts: 25
Default Re: Xorg 100%cpu and NVRM messages

I just noticed that nvidia-settings reports that the video card has 32mb of ram onboard. I could swear it used to report 64mb. I think I'll try to find an older driver.
rotarychainsaw is offline   Reply With Quote
Old 02-12-07, 04:50 PM   #3
rotarychainsaw
Registered User
 
Join Date: Mar 2006
Posts: 25
Default Re: Xorg 100%cpu and NVRM messages

here is a bug report from before a crash, I don't know how to telnet in to this thing after it locks.

I also just turned off 'renderaccel' and it hasn't locked yet, but I hope that this isn't the real solution because I like my renderaccel.
Attached Files
File Type: zip nvidia-bug-report.log.zip (34.6 KB, 121 views)
rotarychainsaw is offline   Reply With Quote
Old 02-13-07, 01:47 PM   #4
rotarychainsaw
Registered User
 
Join Date: Mar 2006
Posts: 25
Default Re: Xorg 100%cpu and NVRM messages

I think I'm gonna try updating to fiesty to see if the new kernels fix this. Can anyone point me in a direction as to what those errors mean?
rotarychainsaw is offline   Reply With Quote
Old 02-13-07, 09:59 PM   #5
rotarychainsaw
Registered User
 
Join Date: Mar 2006
Posts: 25
Default Re: Xorg 100%cpu and NVRM messages

Still does it in feisty

It even locked up with renderaccel false. I'm gonna follow that other thread with the nvrm xid problems. maybe its an acpi issue.

edit: when that sticky up top says that 9631 are legacy drivers, that is talking about old cards like this nv11, right?
rotarychainsaw is offline   Reply With Quote
Old 02-14-07, 09:42 AM   #6
rotarychainsaw
Registered User
 
Join Date: Mar 2006
Posts: 25
Default Re: Xorg 100%cpu and NVRM messages

Quote:
You can disable ACPI by booting with the acpi=off kernel parameter.

I have a few questions:
0) Why are you using the ConnectedMonitor option? Does removing it have any impact?
1) Does this problem persist if you're not using the Composite extension and/or the Triplebuffer option?
2) If you set NvAGP to 0 in xorg.conf, does that have any impact on the problem?
3) Specifically which motherboard are you using, and which BIOS version?

Thanks,
Lonni
I'm following the other threads as well.

acpi=off makes things a little better, but it still locks up.
I tried all the things in the stability sticky, but I duess since this is a single core cpu, nothing happened.
1)Disabling triple buffering made the lockups more frequent, but they actually unlocked more often.
2)Did this the same time as triple buffering
3)Not sure, dell inspiron 4100, old school.

I'm attaching a new bug report for my feisty install, though it is pre lockup. also i couldn't get startx --logverbose 6 to work, it complained about a font or something.
I'm also including some of my kern.log because there was some interesting nvidia soft lock messages.
Thanks to anyone who looks.
Attached Files
File Type: zip nvidia-bug-report.log.zip (26.4 KB, 116 views)
File Type: zip kern.log.zip (19.5 KB, 123 views)
rotarychainsaw is offline   Reply With Quote
Old 02-14-07, 03:01 PM   #7
rotarychainsaw
Registered User
 
Join Date: Mar 2006
Posts: 25
Default Re: Xorg 100%cpu and NVRM messages

I'm begging for help over here lol.

My next step is to try to find a way to put an older bios back on this laptop. Apparently the vidcard bios is kept with the mainboard bios on these dell laptops, and I upgraded the bios just before reinstalling edgy the first time due to new batteries.
rotarychainsaw is offline   Reply With Quote
Old 10-04-09, 11:31 PM   #8
druggo
Gentoo
 
Join Date: Oct 2009
Location: Beijing
Posts: 1
Send a message via ICQ to druggo Send a message via Yahoo to druggo Send a message via Skype™ to druggo
Default Re: Xorg 100%cpu and NVRM messages

we're run into the same problem, the system hangs in windowsXP too, maybe this is the hardware faulty
druggo is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
UEFI+Nvidia - NVRM: Your system is not currently configured to drive a VGA console... interzoneuk NVIDIA Linux 0 06-26-12 05:51 AM
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 12:04 PM
Screen freeze NVRM: Xid error ciancaroll NVIDIA Linux 0 06-05-12 02:05 PM
Xorg hang with 100% cpu, any driver version, GTX275 bones_was_here NVIDIA Linux 20 05-23-12 10:49 AM
GTX 460M, Xorg 1.12, nvidia driver 295.49, linux 3.3.5-1-ARCH and NVRM Xid 44 elsifaka NVIDIA Linux 0 05-14-12 09:48 AM

All times are GMT -5. The time now is 01:02 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.