Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-12-07, 01:57 AM   #1
Xevious
Registered User
 
Join Date: Aug 2002
Posts: 291
Default Get pauses in q3 and weird glitches with XGL

I use XGL and I use the nonXgl script as well as the -xorgAc as well as this script so I can play games:

#!/bin/sh

DISPLAY=":93"

if [ -z "$1" ]; then
echo "Usage: nonXgl <command>"
exit 1
fi

LD_PRELOAD=/usr/lib/libGL.so.1 $@


I believe the problem is related to this in the syslog:

os_map_kernel_space: can't map 0xf0008000, invalid context!


Basically whenever running at resolutions at 3000x2000 and above or so it does this. when running @ 3840x1500 it seemed to run ok. Sometimes it just freezes at startup.

Here the bug report because of the size:

http://www.houkouonchi.net/work/nvidia-bug-report.log

Anyone have any ideas what would cause this and also what that error is?
Xevious is offline   Reply With Quote
Old 02-12-07, 02:55 PM   #2
Xevious
Registered User
 
Join Date: Aug 2002
Posts: 291
Default Re: Get pauses in q3 and weird glitches with XGL

bump
Xevious is offline   Reply With Quote
Old 02-15-07, 08:26 AM   #3
Xevious
Registered User
 
Join Date: Aug 2002
Posts: 291
Default Re: Get pauses in q3 and weird glitches with XGL

bump again.
Xevious is offline   Reply With Quote
Old 02-15-07, 10:48 AM   #4
adamk75
Registered User
 
Join Date: Nov 2006
Posts: 228
Default Re: Get pauses in q3 and weird glitches with XGL

First of all, why are you using XGL? The nVidia drivers support all the necessary extensions to run beryl and compiz directly, without the need for XGL. Secondly, both beryl and compiz (and XGL) carry a significant amount of overhead and have put a lot of work on the GPU, so I wouldn't be at all surprised that you experience pauses with Q3A when running XGL.
adamk75 is offline   Reply With Quote
Old 02-15-07, 06:20 PM   #5
Xevious
Registered User
 
Join Date: Aug 2002
Posts: 291
Default Re: Get pauses in q3 and weird glitches with XGL

I use XGL, because XGL + compiz actually runs pretty good, where as AIGLX + beryl I get about 5 frames a second. and XGL + compiz I get best performance. What is weird is the nvidia drivers I am seeing, and why do I only have these problems at resolutions over 2048x1536? Seems weird to me.
Xevious is offline   Reply With Quote
Old 02-15-07, 06:25 PM   #6
Xevious
Registered User
 
Join Date: Aug 2002
Posts: 291
Default Re: Get pauses in q3 and weird glitches with XGL

Also, just to add to my knowledge when I use that script it forwards it to the X server which XGL runs on top of so I didn't even think it was using XGL, but I could be wrong. q3 actually runs fine (no pausing/freezing) other than it looks like crap and the framerate sucks if I run it natively inside of XGL itself (not using that script).
Xevious is offline   Reply With Quote
Old 02-15-07, 06:55 PM   #7
adamk75
Registered User
 
Join Date: Nov 2006
Posts: 228
Default Re: Get pauses in q3 and weird glitches with XGL

You don't need to use either XGL or AIGLX with the nVidia drivers. They expose the necessary features for compiz and beryl with direct rendering.

Secondly, even if you're running Q3A on the non-XGL server, you're graphics card is still doing all the processing for XGL and beryl/compiz. That's a whole lot of overhead.

Adam
adamk75 is offline   Reply With Quote
Old 02-15-07, 07:02 PM   #8
Xevious
Registered User
 
Join Date: Aug 2002
Posts: 291
Default Re: Get pauses in q3 and weird glitches with XGL

Maybe I am missing something here? I need some sort of acceleration as regular X is horidly slow at rendering with just 2d. I will try tomorrow with regular X (no XGL) and see if q3 will run right. What is weird is that my home system can do XGL + 2560x1600 on q3 without any problems but my work comp can't (it locks up) and i often have to go to the console and kill quake 3.
Xevious is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:27 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.