Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-14-07, 05:03 AM   #1
iero
Registered User
 
Join Date: Feb 2007
Posts: 3
Default Big Wall display (more than 10kpixels) - Slowdown problems.

Hi you all,

I'm running a display wall. It contains 12 (4x3 - 30inches) screens (2560x1600px each), 6 hp9300 nodes (bi opterons dual cores, 16Gb RAM, with nVidia G70GL [Quadro FX4500]) to pilot the screens, one other hp9300 to control the others.

Everything with an infiniband network.

To control the wall, I'm using the last version of everything, including xorg-server 1.2 and Xdmx.

I have posted my entire configuration here : http://forums.gentoo.org/viewtopic-p...1.html#3905761

My problems are :

- The refresh is slow. When I move a big window (something around 8000 pixel width), it's not fluid.

- When I try to zoom or move a big (more than 15000 px width) picture in gimp, the refreshment is long. It's not a bandwidth problem (the infiniband bw is quite empty), but it seems to be more a XputImage and XgetImage problem (Xorg internal functions used to send images). I've found that using Xperf and gdb but I'm not a X core hacker, so, it's dificult to detect if it is those function which cause the problem. Maybe it's a gimp way to refresh, because the display is quickest with gkview for example. Does the e17 team works on those optimisations (with imlib2, ecore, .. ) ?

- Glx doesn't works well. using glxgears, I can get 25 000fps on each node, but 500 fps using the display wall. I know that glxgears is not parallelised, but, 24000 fps it's an huge difference !! So, beryl doesn't works either (just thru the wall, it's ok on each node).

- Every 3D (as openinventor, googleearth..) crash. I cannot understand why. It seems to work with only 3 nodes, but not on 6.

So, I'm looking for advices, tips, hints, anything to get this working.

Every idea is welcome !

Thanx,

Greg.

ps : Scuse my english, it's not my native language.
iero is offline   Reply With Quote
Old 02-14-07, 05:04 AM   #2
iero
Registered User
 
Join Date: Feb 2007
Posts: 3
Default Re: Big Wall display (more than 10kpixels) - Slowdown problems.

Oh, I forgot.

I'm using the last nvidia-drivers (1.0.9746).

Code:
[i] x11-drivers/nvidia-drivers
     Available versions:  1.0.8776 (~)1.0.9631 (~)1.0.9746
     Installed versions:  1.0.9746(12:36:28 02/09/07)(dlloader kernel_linux)
     Homepage:            http://www.nvidia.com/
     Description:         NVIDIA X11 driver and GLX libraries
iero is offline   Reply With Quote
Old 02-14-07, 05:17 AM   #3
chunkey
#!/?*
 
Join Date: Oct 2004
Posts: 662
Default Re: Big Wall display (more than 10kpixels) - Slowdown problems.

wow... nice setup! Do you have some pics?

But don't forget to read the stickys... (nvidia-bug-report.log)

If you have a problem, PLEASE read this first
chunkey is offline   Reply With Quote
Old 02-14-07, 05:26 AM   #4
iero
Registered User
 
Join Date: Feb 2007
Posts: 3
Default Re: Big Wall display (more than 10kpixels) - Slowdown problems.

Quote:
Originally Posted by chunkey
wow... nice setup! Do you have some pics?

But don't forget to read the stickys... (nvidia-bug-report.log)

If you have a problem, PLEASE read this first
I promised to send pics when it will be working With an nvidia pics on the wall display or anything else !

Here are my nvidia-bug-reports for the master and one slave.

Greg.
Attached Files
File Type: log nvidia-bug-report-master.log (117.1 KB, 84 views)
File Type: log nvidia-bug-report-slave.log (81.5 KB, 84 views)
iero is offline   Reply With Quote
Old 02-14-07, 12:02 PM   #5
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Big Wall display (more than 10kpixels) - Slowdown problems.

I have a few questions:
0) How are you tying all of the X screens together between these systems? Are you using Framelock cards?
1) It is fully expected that there will be a non-trivial performance loss when using the Composite extension (especially on large desktops, such as you are using). This is because using a compositor requires that everything be first rendered off screen before getting composited back onto the visible desktop (effectively twice as much rendering). Do the performance problems persist if you're not using the Composite extension?
2) You stated that every 3D application crashes. Is this only when using more than 3 nodes or regardless of the number of nodes?

Thanks,
Lonni
netllama is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Stubborn screen res problem Alpsoandso NVIDIA Linux 6 05-03-12 06:00 PM
302.07 (beta) for Linux x86/x86_64 released AaronP NVIDIA Linux 0 05-02-12 09:55 AM
Glx mrbig1344 NVIDIA Linux 7 09-30-02 06:45 AM
Desperate for help with Display problems!!!!! Petz NVIDIA Linux 12 09-18-02 07:26 PM

All times are GMT -5. The time now is 03:22 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.