Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-26-06, 01:11 AM   #1
wvl0
Registered User
 
Join Date: Sep 2006
Posts: 1
Default Driver 9625 - TV not detected at startup, but nv-settings does

Hi,

I read that many people were experiencing trouble with TV-out. Apparently there's a workaround available by adding the ConnectedMonitor option.

My setup is simply a LCD + TV connected via SVIDEO.

I applied the workaround but that didn't work. The funny thing is that in the log I see that the nvidia driver cannot find the tv (it repeatedly says there's only a crt connected) but when I run nvidia-settings and press detect devices, the tv shows up in the screen layout box and can be configured. I wrote an xorg.conf file with the tv in twinview & seperate screen mode, but when I restart X only the LCD works.

Anyway, why is the TV not detected when X startsup, while nvidia-settings' detect devices does find it?
wvl0 is offline   Reply With Quote
Old 09-28-06, 05:09 PM   #2
lxnay
Registered User
 
Join Date: Dec 2005
Posts: 19
Default Re: Driver 9625 - TV not detected at startup, but nv-settings does

I have the same problem man...

NVIDIA devs??
__________________
Fabio Erculiani
RR4/RR64 and Sabayon Linux Founder
http://www.sabayon.org
lxnay is offline   Reply With Quote
Old 09-28-06, 05:20 PM   #3
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Driver 9625 - TV not detected at startup, but nv-settings does

See:
http://www.nvnews.net/vbulletin/showthread.php?t=46678
netllama is offline   Reply With Quote
Old 09-28-06, 06:38 PM   #4
Lithorus
Registered User
 
Lithorus's Avatar
 
Join Date: Sep 2004
Posts: 783
Default Re: Driver 9625 - TV not detected at startup, but nv-settings does

Can verify that I have the same problem here. Will produce a nvidia-bugreport later..
Lithorus is offline   Reply With Quote
Old 09-28-06, 06:59 PM   #5
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Driver 9625 - TV not detected at startup, but nv-settings does

I believe that I've run into this problem, and opened bug 257362. However, I'd still like to see a bug report to verify that those reporting it here are hitting the same issue as I've come across. In my testing, using the ConnectedMonitor option works around the lack of TV encoder detection.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 09-29-06, 12:52 AM   #6
lxnay
Registered User
 
Join Date: Dec 2005
Posts: 19
Default Re: Driver 9625 - TV not detected at startup, but nv-settings does

Quote:
Originally Posted by netllama
I believe that I've run into this problem, and opened bug 257362. However, I'd still like to see a bug report to verify that those reporting it here are hitting the same issue as I've come across. In my testing, using the ConnectedMonitor option works around the lack of TV encoder detection.

Thanks,
Lonni
Sent
ConnectedMonitor does not work for me, I have always used that.
__________________
Fabio Erculiani
RR4/RR64 and Sabayon Linux Founder
http://www.sabayon.org
lxnay is offline   Reply With Quote
Old 09-29-06, 10:21 AM   #7
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Driver 9625 - TV not detected at startup, but nv-settings does

In the future, please post bug reports in the nvnews thread, so that all the information is in the same location.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 09-29-06, 10:48 AM   #8
sams0n
Registered User
 
Join Date: Dec 2005
Posts: 24
Thumbs up Re: Driver 9625 - TV not detected at startup, but nv-settings does

Quote:
Originally Posted by netllama
I believe that I've run into this problem, and opened bug 257362. However, I'd still like to see a bug report to verify that those reporting it here are hitting the same issue as I've come across. In my testing, using the ConnectedMonitor option works around the lack of TV encoder detection.

Thanks,
Lonni
You are just damn lucky. ConnectedMonitor does NOT work around this issue. With the current beta driver I can set:

a) Twinview (though I do NOT want it)
b) Separate TV
c) Separate LCD

But NO I CANNOT set them both working together (I will bug report later). If I use ConnectedMonitor option - TV wakes up and runs the second X screen (as should) but the LCD (the first X screen) goes "out of singnal" as nvidia driver sets some crazy refresh rate (for LCD) of around 141hz. Yes, nvidia driver completely ignores the refresh rates I put in the LCD Monitor section.

The funny thing - the nvidia-settings detects my TV, but I cannot use it (ConnectedMonitor does NOT help). Sorry for the long post.

PS: Would you, nvidia guys, consider the following driver options:

**Section Device**
Option "DetectMonitor" "CRT-0" # detects and uses any found CRT

or

**Section Device**
Option "ForceMonitor" "TV-0" # just sends the signal to the videocard's TVout (like damn old vcr do) No bloody buggy detection

PPS: I will post my bugreport later. Thanks
sams0n is offline   Reply With Quote

Old 09-29-06, 11:04 AM   #9
lxnay
Registered User
 
Join Date: Dec 2005
Posts: 19
Default Re: Driver 9625 - TV not detected at startup, but nv-settings does

sams0n,
so a workaround for now is only using TV, without TwinView?
Does Dual X works for you?

Anyway, I had the same setup with the latest 8xxx drivers and everything worked fine.
__________________
Fabio Erculiani
RR4/RR64 and Sabayon Linux Founder
http://www.sabayon.org
lxnay is offline   Reply With Quote
Old 09-29-06, 11:13 AM   #10
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Driver 9625 - TV not detected at startup, but nv-settings does

sams0n,
The problems that you're describing sounds different than the problems that others are reporting here. However, without a bug report, I can't speculate on what is happening on your system.

The ConnectedMonitor option already accomplishes what your suggested new options do.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 09-29-06, 11:48 AM   #11
lxnay
Registered User
 
Join Date: Dec 2005
Posts: 19
Default Re: Driver 9625 - TV not detected at startup, but nv-settings does

Lonni,
here you are.
Attached Files
File Type: log nvidia-bug-report.log (78.1 KB, 151 views)
__________________
Fabio Erculiani
RR4/RR64 and Sabayon Linux Founder
http://www.sabayon.org
lxnay is offline   Reply With Quote
Old 09-29-06, 12:28 PM   #12
sams0n
Registered User
 
Join Date: Dec 2005
Posts: 24
Default Re: Driver 9625 - TV not detected at startup, but nv-settings does

Quote:
Originally Posted by lxnay
sams0n,
so a workaround for now is only using TV, without TwinView?
Does Dual X works for you?

Anyway, I had the same setup with the latest 8xxx drivers and everything worked fine.
Quick answer - no, no dualhead for me

PS: With 87** something I had it working too. Alas, there are new xorgs and new kernels.
sams0n is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
302.11 driver only allows native resolution settings of laptop DFP darinmiller NVIDIA Linux 2 05-30-12 03:45 PM
Redhat 8.0 NVIDIA works - INSTRUCTIONS STEEL1 NVIDIA Linux 267 04-15-03 06:48 PM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 08:49 AM
Nvidia Driver causes crash on Standby/Suspend dasher NVIDIA Linux 5 09-16-02 05:57 PM

All times are GMT -5. The time now is 07:53 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.