Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-19-06, 04:02 PM   #1
artem
Registered User
 
Join Date: Jun 2006
Posts: 710
Unhappy X.org doesn't start: segmentation fault trying to initialize GLX extension

Hello, I've recently upgraded to vanilla kernel 2.6.16.36 (I had 2.6.16.27 before) and X.org no longer starts with GLX enabled - I get segmentation fault. I tried increasing X.org verbosity level by running X -logverbous 9 but I just get the same result:

...
(II) Initializing extension GLX
Segmentation fault.

When I comment out "glx" module in X.org configuration file X.org starts.

Hardware: Sempron 3000/939, nForce4/nVidia 6100 IGP (or maybe 6150) motherboard. Upgrading to the most recent driver available (96.31) doesn't help.
artem is offline   Reply With Quote
Old 12-19-06, 04:04 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: X.org doesn't start: segmentation fault trying to initialize GLX extension

See:
http://www.nvnews.net/vbulletin/showthread.php?t=46678
netllama is offline   Reply With Quote
Old 02-01-07, 12:57 PM   #3
artem
Registered User
 
Join Date: Jun 2006
Posts: 710
Default Re: X.org doesn't start: segmentation fault trying to initialize GLX extension

I'm sorry for a long delay.

Updating for 2.6.16.38 and latest nVidia drivers didn't help. OpenGL/GLX still doesn't load.

Here are two reports: one with GLX enabled and X.org segfaulting and another one with GLX disabled and X.org starting normally.
Attached Files
File Type: bz2 report.tar.bz2 (28.9 KB, 131 views)
artem is offline   Reply With Quote
Old 02-01-07, 01:07 PM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: X.org doesn't start: segmentation fault trying to initialize GLX extension

I see this warning:
WARNING: nvidia-installer was forced to guess the X library path '/usr/lib' and
X module path '/usr/lib/xorg/modules'; these paths were not queryable
from the system. If X fails to find the NVIDIA X driver module,
please install the `pkg-config` utility and the X.Org SDK/development
package for your distribution and reinstall the driver.

I'd suggest reading here:
http://www.nvnews.net/vbulletin/showthread.php?t=72490
netllama is offline   Reply With Quote
Old 02-07-07, 08:40 AM   #5
artem
Registered User
 
Join Date: Jun 2006
Posts: 710
Default Re: X.org doesn't start: segmentation fault trying to initialize GLX extension

I have installed Xorg SDK and pkgconfig as you suggested - still no luck.
Attached Files
File Type: bz2 again.tar.bz2 (25.1 KB, 127 views)
artem is offline   Reply With Quote
Old 02-07-07, 10:19 AM   #6
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: X.org doesn't start: segmentation fault trying to initialize GLX extension

In the installer log I see:
-> Installing classic TLS OpenGL libraries.

I'm wondering if perhaps your system needs the 'new' TLS libraries. Can you try reinstalling with the --force-tls=new option?
netllama is offline   Reply With Quote
Old 02-20-07, 09:50 AM   #7
artem
Registered User
 
Join Date: Jun 2006
Posts: 710
Default Re: X.org doesn't start: segmentation fault trying to initialize GLX extension

Installing new tls libraries did the trick. Thank you. I hope the next version of nVidia linux drivers will automatically check what version of libraries to install.
artem is offline   Reply With Quote
Old 02-20-07, 09:57 AM   #8
chunkey
#!/?*
 
Join Date: Oct 2004
Posts: 662
Default Re: X.org doesn't start: segmentation fault trying to initialize GLX extension

Quote:
Originally Posted by artem
Installing new tls libraries did the trick. Thank you. I hope the next version of nVidia linux drivers will automatically check what version of libraries to install.
The installer does this already! And it does it quite well...
chunkey is offline   Reply With Quote

Old 02-20-07, 10:08 AM   #9
artem
Registered User
 
Join Date: Jun 2006
Posts: 710
Default Re: X.org doesn't start: segmentation fault trying to initialize GLX extension

Quote:
Originally Posted by chunkey
The installer does this already! And it does it quite well...
In my case it didn't.
artem is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
X Failed to load NVdriver c00lr4c3r NVIDIA Linux 13 10-22-02 01:44 PM
Glx mrbig1344 NVIDIA Linux 7 09-30-02 06:45 AM
GForce drivers installed...but dont work tomfullery NVIDIA Linux 6 09-22-02 08:23 AM
Need help to get the X to work on my Acer TravelMate 630 knchee NVIDIA Linux 16 09-19-02 10:16 PM
Segmentation Fault on RH 7.3 Lawrence DeLeon NVIDIA Linux 4 09-16-02 11:42 AM

All times are GMT -5. The time now is 10:35 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.