Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-21-06, 01:37 PM   #1
Linuxhippy
Registered User
 
Join Date: Feb 2004
Posts: 585
Default Another performance problem with FireFox

Hi again,

When scrolling this page http://thor.auto.tuwien.ac.at/~rlieg...est/Info2.html in firefox (especially there where a lot of combo-boxes are) scrolling is very slow and oprofile tells me that most time is WASTED for rendering:

Code:
     9279 30.4539 nvidia_drv.so
     4446 14.5919 firefox-bin
     4434 14.5525 no-vmlinux
     4013 13.1708 libfb.so
     2234  7.3320 Xorg
It would be really great to see a not that limited render implementation in next versions of the nvidia driver. For now I don't see a lot of reasons why I should use a 2d accalerator except for faster blits. Its somehow strange how fast eye-candy stuff like composite/aiglx got implemented and what crappy drivers are under that just because nobody cares about 2D performance.

lg Clemens
Linuxhippy is offline   Reply With Quote
Old 11-21-06, 03:15 PM   #2
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: Another performance problem with FireFox

Does nvidia-settings -a InitialPixmapPlacement=2 help?
AaronP is offline   Reply With Quote
Old 11-21-06, 04:29 PM   #3
Linuxhippy
Registered User
 
Join Date: Feb 2004
Posts: 585
Default Re: Another performance problem with FireFox

no, but it makes some gtk applications more responsive.
(e.g. the panned widget demo of gtk-demo).

lg Clemens
Linuxhippy is offline   Reply With Quote
Old 11-22-06, 04:42 AM   #4
ze moo
Registered User
 
Join Date: May 2005
Posts: 23
Default Re: Another performance problem with FireFox

same problem here with firefox although the display is fast & snappy
using konqueror. gtk apps always seem more sluggish than qt based
ones.
ze moo is offline   Reply With Quote
Old 09-12-07, 03:00 AM   #5
ulhume
Registered User
 
Join Date: Nov 2006
Posts: 4
Default Re: Another performance problem with FireFox

I have the same problem. Eclipse, Firefox, every GTK based app are pretty slow.

I did some test with gtkperf, using different "InitialPixmapPlacement" :

With IPP=0 : 38.6s
With IPP=1 : 40s
With IPP=2 : 67.6s !!

When look closer at each test, il looks like Drawings (Line, Circles, Text, PixBuff) are exactly the same in both cases. But when it come to "controls" tests (combo, progress, etc..), every thing is about 2 times slower using 2 as IPP value.

Hope this will help.
ulhume is offline   Reply With Quote
Old 09-12-07, 03:21 AM   #6
ulhume
Registered User
 
Join Date: Nov 2006
Posts: 4
Default Re: Another performance problem with FireFox

In previous post, I was running 7955 driver, now I tried the same with the 100.14.11.

First, a "well done" to driver developpers, the all test now runs in 22s (instead of 38.6 with previous driver). Don't know what you done, but something obviously changed.

But about "InitialPixmapPlacement", it is still slower with 2 as a value that 0 or 1 (about the same). Now with 2, result is 32s.
ulhume is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
NVIDIA Unleashes the GeForce GTX 670 Graphics Card ' Performance Perfected (WCCFTECH) News GeForce GTX 670 Reviews 0 05-10-12 08:40 AM
My UT2003 Tweak Guide DXnfiniteFX Gaming Central 48 10-30-02 11:59 PM
nv30 problem rumor bob747b Rumor Mill 37 10-10-02 03:14 PM
Low OpenGL Performance Instinct NVIDIA Linux 10 08-08-02 03:56 PM
Nvidia Go on laptop, black border within XFree86 problem raxip NVIDIA Linux 3 07-31-02 10:58 AM

All times are GMT -5. The time now is 12:14 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.