Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-20-07, 06:53 AM   #1
boppen
Registered User
 
Join Date: Oct 2005
Posts: 8
Default XvMC freezes my MythTV-system

Hi!

I have been playing with XvMC a little to reduce CPU usage when wathing HDTV with MythTV, but I have got a problem. when I'm using XvMC my system freezes now and then, I have to push the reset button to restart it.

I'm using driver 9746 and Linux kernel 2.6.18 (-gentoo-r6). My graphics is a integrated 6150 on a ASUS A8N-VM CSM.

This is the last output from Myth when the system freeze:
Code:
2007-02-20 12:24:46.570 XMLParse::LoadTheme using /usr/local/share/mythtv/themes/Retro/ui.xml
2007-02-20 12:24:46.638 Video timing method: RTC
[mpegts @ 0x2b575e8f2480]Parser not found for Codec Id: 94211 !
2007-02-20 12:24:48.130 VideoOutputXv: XvMCTex: Init failed
2007-02-20 12:24:48.131 VideoOutputXv: XvMC Adaptor Name: 'NV17 Video Texture'
X Error: BadMatch (invalid parameter attributes) 8
  Major opcode:  141
  Minor opcode:  14
  Resource id:  0x1a8
2007-02-20 12:24:48.449 VideoOutputXv: ProcessFrameXvMC: Tried to reuse frame but failed
2007-02-20 12:24:48.449 VideoOutputXv: ProcessFrameXvMC: Called without frame
2007-02-20 12:24:48.450 AFD: Opened codec 0x2a63e50, id(MPEG2VIDEO_XVMC) type(Video)
2007-02-20 12:24:48.450 AFD: Opened codec 0x1282cf0, id(MP3) type(Audio)
2007-02-20 12:24:48.653 Opening OSS audio device '/dev/dsp'.
2007-02-20 12:24:48.657 NVP: Enabling Audio
2007-02-20 12:24:48.658 VideoOutputXv: ProcessFrameXvMC: Tried to reuse frame but failed
2007-02-20 12:24:48.658 VideoOutputXv: ProcessFrameXvMC: Called without frame
XvMC: picture structure FRAME
2007-02-20 12:24:50.350 NVP: prebuffering pause
And this is a 'top' in the same second as the system freezes (yes, I'm running Myth as root ;-)


Thans for any help!

Last edited by boppen; 02-21-07 at 02:54 PM.
boppen is offline   Reply With Quote
Old 02-20-07, 11:28 AM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: XvMV freezes my MythTV-system

http://www.nvnews.net/vbulletin/showthread.php?t=58498
netllama is offline   Reply With Quote
Old 02-21-07, 02:58 PM   #3
boppen
Registered User
 
Join Date: Oct 2005
Posts: 8
Default Re: XvMV freezes my MythTV-system

Sorry, missed that ...

But I have gone throught that post and I didn't find anything.

I have a single core processor, kernel 2.6.18 (-gentoo) and I have the latest BIOS (1007) for my ASUS A8N-VM CSM. So I have attached a log-file, but it was run at the same time as Xorg because the computer locks completely and I can't run it afterwards.

/Boppen
Attached Files
File Type: zip nvidia-bug-report.zip (30.2 KB, 100 views)
boppen is offline   Reply With Quote
Old 02-21-07, 08:58 PM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: XvMV freezes my MythTV-system

Are you aware of this problem?
########
irq 3: nobody cared (try booting with the "irqpoll" option)

Call Trace:
[<ffffffff8020ad7f>] dump_stack+0xe/0x10
[<ffffffff80254024>] __report_bad_irq+0x30/0x7d
[<ffffffff80254286>] note_interrupt+0x215/0x257
[<ffffffff8025398f>] __do_IRQ+0xc2/0xff
[<ffffffff8020bd44>] do_IRQ+0xec/0xfa
[<ffffffff80209ba9>] ret_from_intr+0x0/0xa
[<ffffffff80207c70>] default_idle+0x29/0x50
[<ffffffff80207e3a>] cpu_idle+0x95/0xb8
[<ffffffff808bf805>] start_kernel+0x201/0x203
[<ffffffff80814740>] command_line+0x0/0x100
DWARF2 unwinder stuck at command_line+0x0/0x100
Leftover inexact backtrace:
[<ffffffff808bf2a7>] _sinittext+0x2a7/0x2ab

handlers:
[<ffffffff8048ceaf>] (usb_hcd_irq+0x0/0x54)
Disabling IRQ #3
##########

How consistently does this reproduce?
Does this reproduce if you're not using the ConnectedMonitor option?

Please point me to content which reliably reproduces the problem.
netllama is offline   Reply With Quote
Old 02-23-07, 01:36 AM   #5
boppen
Registered User
 
Join Date: Oct 2005
Posts: 8
Default Re: XvMV freezes my MythTV-system

Hi and thanks for the answer!

I tried without the ConnectedMonitor option but then I did only get video output over VGA and a resolution of 1280x720 - but I noticed one thing, the system didn't freeze when using XvMC! So I've been trying a little and this is my results:

XvMC@1920x1080: System freeezes
XvMC@1280x720: Ok
ffmpeg/libmpeg2@1920x1080: Ok
ffmpeg/libmpeg2@1280x720: Ok

So it looks like the problem only occurs when I'm running XvMC in 1920x1080. I'm using an integrated 6150 GPU thats shares the RAM - can that be a problem? But do XvMC consume more Video-RAM than ffmpeg for example?

/Boppen
boppen is offline   Reply With Quote
Old 02-23-07, 11:41 AM   #6
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: XvMV freezes my MythTV-system

Are you stating that this also reproduces with a CRT when doing 1920x1080?

If you wish to use a display device other than a CRT, then you should be adding the UseDisplayDevice option, not the ConnectedMonitor option. See the driver README for more information on the correct usage of these options.

Please point me to content which reliably reproduces the problem.
netllama is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
GeForce 2 freezes system under Direct3D Matthius NVIDIA GeForce 7, 8, And 9 Series 20 06-05-12 02:46 AM
Max Payne 3 system requirements updated, new PC screenshots released News Archived News Items 0 05-28-12 06:49 AM
crashes and freezes Lethal Weapon NVIDIA Linux 9 09-27-02 08:23 PM
Strange RedHat 7.3 issues with A7N266-C nforceuser NVIDIA Linux 8 09-27-02 03:16 PM
System freezes while gaming with a GeForce4 Grimwall NVIDIA GeForce 7, 8, And 9 Series 12 07-31-02 07:50 AM

All times are GMT -5. The time now is 03:53 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.