Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-31-06, 11:58 PM   #1
wang
Registered User
 
Join Date: Mar 2006
Posts: 18
Default FC5 fail to load "nvsound.ko"

I fail to install my nforce sound driver
fail to load "nvsound.ko"

how can i deal with this problem
wang is offline   Reply With Quote
Old 04-01-06, 12:11 AM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: FC5 fail to load "nvsound.ko"

Did you update to the latest FC5 kernel? Please post an nforce-bug-report.log.

-Lonni
netllama is offline   Reply With Quote
Old 04-01-06, 12:22 AM   #3
wang
Registered User
 
Join Date: Mar 2006
Posts: 18
Default Re: FC5 fail to load "nvsound.ko"

yes ,my kernel is 2.6.1-1.2080
I also try the kernel 2.6.1-1.2074 ,but it failed with the same mistake
Attached Files
File Type: log nvidia-nforce-installer.log (19.6 KB, 232 views)
wang is offline   Reply With Quote
Old 04-01-06, 12:25 AM   #4
wang
Registered User
 
Join Date: Mar 2006
Posts: 18
Default Re: FC5 fail to load "nvsound.ko"

how can i fix this problem ??
wang is offline   Reply With Quote
Old 04-01-06, 12:36 AM   #5
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: FC5 fail to load "nvsound.ko"

According to the installer log that you posted (which was not the bug report that I requested), here's the problem:

-> Kernel module load error: FATAL: Error inserting nvsound
(/lib/modules/2.6.16-1.2074_FC5/kernel/sound/oss/nvsound.ko): Unknown symbol
in module, or unknown parameter (see dmesg)

Did you follow the instructions above?
netllama is offline   Reply With Quote
Old 04-01-06, 12:43 AM   #6
wang
Registered User
 
Join Date: Mar 2006
Posts: 18
Default Re: FC5 fail to load "nvsound.ko"

I follow the instructions above ,and install it for many times ,but failled all.

when i install driver in kernel 2.5.15-1.2054,both the audio driver and nvnet driver can not be isntalled with the same error.
when i update kernerl with 2.6.16-1.2074 or 2.6.16-1.2080 ,the nvnet driver can been installed and works well .why the audio driver can not been installed.
wang is offline   Reply With Quote
Old 04-01-06, 12:45 AM   #7
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: FC5 fail to load "nvsound.ko"

(see dmesg)
netllama is offline   Reply With Quote
Old 04-01-06, 12:45 AM   #8
wang
Registered User
 
Join Date: Mar 2006
Posts: 18
Default Re: FC5 fail to load "nvsound.ko"

here is my install step
down load kernel-2.6.16-1.2080****.rpm and kernel-devel-2.6.16-1.2080****.rpm

rpm -Uvh kernel-2.6.16-1.2080****.rpm
rpm -Uvh kernel-devel-2.6.16-1.2080***.rpm

cd
./NFORCE*
wang is offline   Reply With Quote

Old 04-01-06, 12:47 AM   #9
wang
Registered User
 
Join Date: Mar 2006
Posts: 18
Default Re: FC5 fail to load "nvsound.ko"

any details??
wang is offline   Reply With Quote
Old 04-01-06, 02:41 AM   #10
revelation128
Registered User
 
Join Date: Mar 2006
Posts: 1
Default Re: FC5 fail to load "nvsound.ko"

Hi,

I have the same problem and dmesg prints the following:

Code:
nvsound: Unknown symbol remap_page_range
Any ideas, how to deal with that problem?

Regards
Johannes
revelation128 is offline   Reply With Quote
Old 04-01-06, 03:26 AM   #11
The_Cheese
Registered User
 
Join Date: Jul 2004
Posts: 8
Default Re: FC5 fail to load "nvsound.ko"

I too have this problem, and I would bet any money that *anyone* with fc5 (and with the problematic kernels i guess) have the this same problem.

It would be nice to get a sticky for this just as the gfx card issue recieved. WE may not have a solution for the nforce drivers just yet, but at least people will be able to easily see that there are other experiencing the same problems.

It is quite difficult to find any information about people having problems with the nforce drivers, obviously because a lot less people use them compared to the nvidia gfx driver.

Anyway enough of that.

I guess the nforce driver is suffering a similar problem to the gfx driver (that is purely a guess, as I am basically a linux noob). What I cannot understand is that the ethernet driver installs ok (NOTE only after updating the kernel) but the audio driver still fails to install.

For completeness I will attach my install.log. But I would like to see a nvidia representative sticky this, as we have three different people all suffering the same fate, and see if we can't find some solutions to the problem
Attached Files
File Type: log nvidia-nforce-installer.log (20.3 KB, 192 views)
The_Cheese is offline   Reply With Quote
Old 04-01-06, 05:53 AM   #12
wang
Registered User
 
Join Date: Mar 2006
Posts: 18
Default Re: FC5 fail to load "nvsound.ko"

install nforce audio driver in FC5
I found a way to install nforce audio driver in fc5 withou the "unable to load nvsound.ko"
problem

what you need is to apply the patch enclosed.
then you can install the driver without the problem above

1: download both the driver and the patch(nvsound.txt).
and go into the direction where driver and patch you store

2 ./NFORCE-Linux-x86-1.0-0310-pkg1.run --extract-only
mv nvsound.txt NFORCE-Linux-x86-1.0-0310
cd NFORCE-Linux-x86-1.0-0310
patch -p0<./nvsound.txt
3: nforce-installer
.........

Now i have install both the audio driver and nvnet driver in FC5,but
I can not stop the older driver being loaded while the system is start.
i have followed the instruction in RelealeNotes,
that is modify some item in /etc/modprobe.config

for audio driver
remove line
"alias sound-slot-0 i810_audio"

Add the following lines to the configuration file:

alias sound-slot-0 nvsound
alias snd-intel8x0 off
alias i810_audio off

install nvsound /sbin/modprobe --ignore-install nvsound ; sleep 1; /usr/bin/nvmix-reg -f /etc/nvmixrc -L >/dev/null 2>&1 || :
remove nvsound { /usr/bin/nvmix-reg -f /etc/nvmixrc -S >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove nvsound


Add the following lines to the /etc/rc.local

/usr/bin/nvmix-reg -f /etc/nvmixrc -L >/dev/null 2>&1


for net driver

remove line in the configration file
alias eth0 forcedeth

Add the following lines to the configuration file

alias eth0 nvnet
alias forcedeth off


but after i reboot the system
i you "lsmod" to see if the driver have worked ,i found the forcedeth driver for net and the snd-intel8x0 driver for audio
are still runing .I can not stop them being loaded by modify the configuration file as above.
how can i stop the driver for audio and net FC5 offered.

I wish to have nvmixer audio settings automatically restored each time the nvsound driver loads by adding the lines(referred above) to the configuration file for 2.6 kernels

bu every time i shutdown the system it says fail to do this because can not find sound card

what is the matter with the audio driver ,how can i fix the problem referred above.
Attached Files
File Type: txt nvsound.txt (653 Bytes, 739 views)
wang is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
173.14.34 -- Xorg 1.12.1 & 1.11.4, glx module fails to load mereset NVIDIA Linux 17 06-10-12 01:24 AM
Lucid rt kernel can't load latest nvidia driver module, but generic does. marcod NVIDIA Linux 0 05-02-12 06:23 AM
Can't load NVdriver jojotux123 NVIDIA Linux 4 09-18-02 06:15 AM

All times are GMT -5. The time now is 06:08 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.