Go Back   nV News Forums > Linux Support Forums > General Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-04-06, 11:56 AM   #1
B. Williams
Registered User
 
Join Date: Jul 2006
Posts: 9
Default HOWTO: NForce Audio on kernels 2.6.16 and Later

Many people on the forum have been having problems getting the NForce audio modules to load under kernels 2.6.16 and later. According to Nvidia, the reason is that the 2.6.16 kernels support the NForce audio devices with ALSA, although your kernel may not have ALSA support or chipset support built-in. To enable NForce sound in the kernel, load menuconfig and add the following options:

Code:
Device Drivers --->
   Sound ---> 
      <*> Sound card support
      Advanced Linux Sound Architecture ---->
         <*> Advanced Linux Sound Architecture
         PCI Devices --->
           <*>Intel/SiS/nVidia/AMD/ALi AC97 Controller
Recompile, and you should have ALSA sound support.

Please post if you have any problems with your audio.

Regards,
Bradley Williams
Owner, BW Services
B. Williams is offline   Reply With Quote
Old 12-04-06, 06:50 AM   #2
Filthpig
Registered User
 
Join Date: May 2004
Posts: 4
Default Re: HOWTO: NForce Audio on kernels 2.6.16 and Later

Audio out works perfectly, but when I try to use the mic (for skype etc) I only get the sound on my own speakers, and nothing is picked up in the system. I've tried Krec and Ardour to check the input, and neither recieve any sound at all.

I'm running Kubuntu Edgy on an Abit NF7 mobo with the built-in Realtek ALC650F sound card.
Filthpig is offline   Reply With Quote
Old 12-22-06, 04:32 PM   #3
guldo
Registered User
 
Join Date: Dec 2006
Posts: 3
Default Re: HOWTO: NForce Audio on kernels 2.6.16 and Later

Hello
Hope it's fine to post here.
I can't get my mobo-soundcard to work.
Linux: 2.6.18
Mobo: AM2NF6G-VSTA
Audio (integrated): Realtek ALC888 7.1 channel audio CODEC with High Definition audio
Module: snd-hda-intel

Audio just does not work. See details in the attachment.
alsaconf finds no cards.
As soon as I try and use some audio application (or even: most /dev/sndstat) many modules are loaded, but alsa does not work.
As you can see in the attachement, also snd-sb16 modules are loaded.
(I previously had a sound blaster card)

What's wrong?

Thank you

p.s.: alsa-base 1.0.8-7
alsa-oss 1.0.12-1
alsa-utils 1.0.9a-2
Attached Files
File Type: log alsa.log (2.9 KB, 227 views)
guldo is offline   Reply With Quote
Old 12-27-06, 07:45 AM   #4
guldo
Registered User
 
Join Date: Dec 2006
Posts: 3
Default Re: HOWTO: NForce Audio on kernels 2.6.16 and Later

help...
I got rid of the snd_sb* modules via /etc/modprobe.d/blacklist, but still the sound card does not work.
guldo is offline   Reply With Quote
Old 12-27-06, 09:37 AM   #5
guldo
Registered User
 
Join Date: Dec 2006
Posts: 3
Default Re: HOWTO: NForce Audio on kernels 2.6.16 and Later

Solved!
Thanks to a friend of mine who guided me to the right howto.
I just had to compile the latest alsa driver with the option:
--with-card=hda-intel

bye
guldo is offline   Reply With Quote
Old 12-30-06, 02:32 AM   #6
SLippe
R.I.P. Babe Thread
 
Join Date: Jun 2004
Posts: 12,387
Default Re: HOWTO: NForce Audio on kernels 2.6.16 and Later

Glad you got it working.
SLippe is offline   Reply With Quote
Old 01-20-07, 02:16 PM   #7
gary@web.ca
Registered User
 
Join Date: Jan 2007
Posts: 1
Default Re: HOWTO: NForce Audio on kernels 2.6.16 and Later

Quote:
Originally Posted by guldo
Solved!
Thanks to a friend of mine who guided me to the right howto.
I just had to compile the latest alsa driver with the option:
--with-card=hda-intel

bye
Can you point me to the HOWTO that worked for you. I am still struggling with the sound on the ASROCK AM2NF6G-vsta. Also having trouble with the NIC Network Chipset: Realtek PHY TRL8201CL also.

Distribution ubuntu 6.10

Thansk Gary

Last edited by gary@web.ca; 01-20-07 at 02:48 PM.
gary@web.ca is offline   Reply With Quote
Old 03-27-07, 04:17 PM   #8
pablo1966
Registered User
 
Join Date: Mar 2007
Posts: 1
Default Re: HOWTO: NForce Audio on kernels 2.6.16 and Later

Here's how I got my Asrock K8NF6G-VSTA netcard working with Kubuntu 6.06 (may apply to other models of motherboard):

NIC : Realtek RTL8201CL
SOUND : Realtek ALC883 (7.1 ch/HD)
VGA : Nvidia GeForce 6100 nForce 405 vbios ver. 05.61.32.14.03

The network card issue appears to be a forcedeth driver version thing; updating the driver to v.0.60 apperently solves the problem.
The audio issue is solved (at least playback works) installing ALSA drivers stand-alone from http://www.alsa-project.org
ftp://ftp.alsa-project.org/pub/driver/alsa-driver-1.0.13.tar.bz2
The video driver I'm using right now is oficial http://us.download.nvidia.com/XFree86/Linux-x86/1.0-9755/NVIDIA-Linux-x86-1.0-9755-pkg1.run and worked out of the box.

Install kernel 2.6.15-28-386 and headers
Code:
sudo apt-get update
sudo apt-get install linux-image-2.6.15-28-386
sudo apt-get install linux-headers-2.6.15-28-386
Install build tools
Code:
sudo apt-get install build-essential
Now, following the instructions from this forum https://launchpad.net/ubuntu/+source....15/+bug/76346
Download this http://librarian.launchpad.net/56203...th_0.60.tar.bz

Quote:
I've been able to update to the latest forcedeth 0.60 in the following way I'm going to describe.
Before all:
-I'm using kernel 2.6.15-27-amd64-k8, so change version numbers accordingly to yours;
1)Download latest nvidia nforce package
2)For Dapper, I suggest you using forcedeth.c file contained under Fedora5 folder of the downloaded package
3)Install build-essential plus linux-headers-2.6.15-27-amd64-k8
4)Copy forcedeth.c into some folder, e.g. /home/willytp/forcedeth
5)Into this folder, make a file called "Makefile" containing the following line:
obj-m := forcedeth.o
6)Into this folder, execute the following command:
make -C /usr/src/linux-headers-2.6.15-27-amd64-k8/ SUBDIRS=$PWD modules
7)Copy the just created forcedeth.ko module into
/lib/modules/2.6.15-27-amd64-k8/kernel/drivers/net/
overwriting the old one
8)Execute this command: sudo depmod -a
9)Make a new initrd image: go into /boot/ folder, locate your initrd image, save it name, delete the file, and execute the following command:
mkinitramfs -o initrd.img-2.6.15-27-amd64-k8
10)Cross fingers and reboot
Hoping to help someone, I've attached a file here, containing the appropriate forcedeth.c, the Makefile, a little script to build and the binary file which will work *only* for 2.6.15-27-amd64-k8 kernel.
When compiling the ALSA modules don't forget to use driver hda-intel instead of intel8x0

Code:
./configure --with-cards=hda-intel --with-sequencer=yes; make; make install
--PABLO
pablo1966 is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:36 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.