Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-04-07, 09:39 AM   #1
ctilburg
Registered User
 
Join Date: Aug 2005
Posts: 15
Default 9746 alt-F[123456] doesn't work

virtual consoles seem to be broken... should read control-alt-{F[12345]}
ctilburg is offline   Reply With Quote
Old 01-04-07, 09:45 AM   #2
sambo57u
Registered User
 
Join Date: Jan 2006
Posts: 52
Default Re: 9746 alt-F[123456] doesn't work

I presume you mean ctrl+alt+F[1..] for virtual console. This is
actually working for me but when I do dtrl+alt_f1 I just get a
black screen and no login prompt. When I do ctrl+alt+f7 I do go
back to the previous gui. Using FC6+updates+9746.
sambo57u is offline   Reply With Quote
Old 01-04-07, 09:50 AM   #3
ctilburg
Registered User
 
Join Date: Aug 2005
Posts: 15
Default Re: 9746 alt-F[123456] doesn't work

yep, that is what I'm talking about... I'm on gentoo
ctilburg is offline   Reply With Quote
Old 01-04-07, 10:29 AM   #4
sambo57u
Registered User
 
Join Date: Jan 2006
Posts: 52
Default Re: 9746 alt-F[123456] doesn't work

I actually keep getting "Entering Power Save" message after hitting
ctrl+alt+f1.
sambo57u is offline   Reply With Quote
Old 01-04-07, 12:34 PM   #5
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: 9746 alt-F[123456] doesn't work

see http://www.nvnews.net/vbulletin/showthread.php?t=72490
netllama is offline   Reply With Quote
Old 01-04-07, 08:31 PM   #6
sambo57u
Registered User
 
Join Date: Jan 2006
Posts: 52
Default Re: 9746 alt-F[123456] doesn't work

I could not find any solution there. I am not running Sellinux
and have done all of the recommended steps. This is an
x86_64 system.
sambo57u is offline   Reply With Quote
Old 01-04-07, 09:56 PM   #7
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: 9746 alt-F[123456] doesn't work

Sorry, I meant here: http://www.nvnews.net/vbulletin/showthread.php?t=46678
netllama is offline   Reply With Quote
Old 01-09-07, 02:30 PM   #8
sambo57u
Registered User
 
Join Date: Jan 2006
Posts: 52
Default Re: 9746 alt-F[123456] doesn't work

I think I found a solution to ctrl+alt+Fn problems:

If you are using KDM, edit your kdmrc file (usually in /etc/X11/xdm)
and insert the line:

TerminateServer=true

In all the blocks that contain -Core in their heading.

If you are using GDM try editing gdm.conf and put in the line:

AlwaysRestartServer=true

Hope this helps!
Sammy
sambo57u is offline   Reply With Quote

Old 01-09-07, 10:53 PM   #9
Kethal
Registered User
 
Join Date: Jan 2007
Posts: 9
Default Re: 9746 alt-F[123456] doesn't work

I also had this problem. It seems that something of Nvidia's messed up my config file. Adding these lines to the keyboard section fixed the problem.

Option "Protocol" "Standard"
Option "XkbLayout" "us"
Option "XkbModel" "pc104"
Option "XkbRules" "xfree86"

Without them it interprets the keystrokes as something other than ctr+alt+fn

Good luck,
Justin
Kethal is offline   Reply With Quote
Old 01-20-07, 03:15 AM   #10
codermotor
Registered User
 
Join Date: Jan 2007
Posts: 3
Default Re: 9746 alt-F[123456] doesn't work

I've had the same problem with Fedora Core 6 and 9746 with a GeForce Go 6600 on my Asus Z71V laptop. 9631 works fine.

With 9746, starting from console and running "startx" brings up a working X. Switching to a console (<Alt><Ctrl><Fn>) causes a brief flash - as if the console came up for a few milliseconds - and then a black screen. I can switch back to console F7 and X is back.

The same thing happens when leaving X: flash, then black screen. As with the console switch, the CLI is still running. I can run "startx" again and X runs fine. No errors mentioned in either the X log, or in system log.

I guess I'll go back to 9631 till this is fixed.
codermotor is offline   Reply With Quote
Old 01-20-07, 09:14 AM   #11
derbuffer
Registered User
 
Join Date: Dec 2006
Posts: 10
Default Re: 9746 alt-F[123456] doesn't work

Hi, I think this is a known problem with the nvidia/framebuffer and vga= kernelparameter. Have a look at:

http://www.nvnews.net/vbulletin/showthread.php?t=83900

http://www.nvnews.net/vbulletin/showthread.php?t=83335

http://www.nvnews.net/vbulletin/showthread.php?t=83858

Always the solution is to edit the vga= parameter into vga=normal (or deactive fb?).

Greetings
derbuffer is offline   Reply With Quote
Old 02-02-07, 12:07 AM   #12
dorin.lazar
Registered User
 
Join Date: Aug 2005
Posts: 9
Default Re: 9746 alt-F[123456] doesn't work

Hello, I have the same problem here.
When I try to switch to a console I am getting no signal on my monitor. Going back to X works without problems. The system does not hang, nor crash.
The distribution is FC6 with the latest updates, I use the kmod-nvidia packed by rpm.livna.org.
Attached Files
File Type: log nvidia-bug-report.log (92.3 KB, 104 views)
dorin.lazar is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
295.40 Does not Work Had to downgrade to 295.33 Archmbc NVIDIA Linux 4 05-03-12 03:38 PM
do 3d glasses really work? Gator General Hardware 19 12-30-02 05:39 AM
Need help to get the X to work on my Acer TravelMate 630 knchee NVIDIA Linux 16 09-19-02 11:16 PM
Can't get FSAA to work krow NVIDIA Linux 6 09-17-02 09:03 AM

All times are GMT -5. The time now is 01:41 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.