Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-23-07, 08:38 PM   #1
Vladimir Ivanov
Registered User
 
Join Date: Jan 2007
Posts: 2
Default Screen shaking, Laptop Lenovo, 128 Mb GeForce Go7300, SUSE 10.2

Hi everyone. I am running OpenSuSE 10.2 (2.6.18.2-34-default) on my laptop Lenovo 3000 N100 (128Mb GeForce Go7300). It has the latest NVIDIA driver 1.0-9746 installed. I noticed that the screen is flickering/shaking a little. It looks like the entire image is physically moving. It happens quite often, and it is very annoying. The resolution is 1680x1050 (default for this display). I have tried to change the vertical refresh rate, it does not help. I also tried to remove “HorizSync” and “Vertrefresh” lines from X-conf and let NVIDIA to decide refresh rates, it does not help either. I attached the bug report.

Any help would be greatly appreciated.
Attached Files
File Type: zip nvidia-bug-report.zip (28.6 KB, 202 views)
Vladimir Ivanov is offline   Reply With Quote
Old 03-07-07, 01:19 AM   #2
andersk
Registered User
 
Join Date: Mar 2007
Posts: 8
Default Re: Screen shaking, Laptop Lenovo, 128 Mb GeForce Go7300, SUSE 10.2

I have the same problem with the same laptop. Any ideas yet?
andersk is offline   Reply With Quote
Old 03-08-07, 02:54 AM   #3
therealpete
Registered User
 
Join Date: Feb 2007
Posts: 1
Default Re: Screen shaking, Laptop Lenovo, 128 Mb GeForce Go7300, SUSE 10.2

Load the module with the following options:
options nvidia NVreg_RegistryDwords="PerfLevelSrc=0x2222"

I had the same problem, it's gone now
therealpete is offline   Reply With Quote
Old 03-08-07, 05:11 AM   #4
stefan42
Registered User
 
Join Date: Jul 2003
Posts: 51
Default Re: Screen shaking, Laptop Lenovo, 128 Mb GeForce Go7300, SUSE 10.2

Quote:
Originally Posted by Vladimir Ivanov
Hi everyone. I am running OpenSuSE 10.2 (2.6.18.2-34-default) on my laptop Lenovo 3000 N100 (128Mb GeForce Go7300). It has the latest NVIDIA driver 1.0-9746 installed. I noticed that the screen is flickering/shaking a little. It looks like the entire image is physically moving. It happens quite often, and it is very annoying. The resolution is 1680x1050 (default for this display). I have tried to change the vertical refresh rate, it does not help. I also tried to remove “HorizSync” and “Vertrefresh” lines from X-conf and let NVIDIA to decide refresh rates, it does not help either. I attached the bug report.

Any help would be greatly appreciated.
I had this effect too (on a Inspiron 9400). I could verify with nvclock that the flickering happens when the clock frequency changes (e.g. some time after some opengl activity ended). I've sent a bug report to NVidia but they couldn't reproduce the problem. Can you verify if your flickering also happens when the frequency changes?
stefan42 is offline   Reply With Quote
Old 03-12-07, 01:58 AM   #5
andersk
Registered User
 
Join Date: Mar 2007
Posts: 8
Default Re: Screen shaking, Laptop Lenovo, 128 Mb GeForce Go7300, SUSE 10.2

Yes, the flickering seems to correspond with the GPU clock changes reported by nvclock. And indeed, setting PerfLevelSrc=0x2222 makes it go away. Thanks, and do you want any more information?
andersk is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:10 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.