Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-12-07, 10:00 AM   #1
Protex
Registered User
 
Join Date: Apr 2004
Posts: 3
Default 8x card stuck in 4x mode?

I'm unsure if I'm using agp 4x or agp 8x.

Code:
bash-3.1$ cat /proc/driver/nvidia/agp/card
Fast Writes:     Supported
SBA:             Supported
AGP Rates:       8x 4x
Registers:       0xff000e1b:0x1f004312
bash-3.1$ cat /proc/driver/nvidia/agp/host-bridge
Host Bridge:     PCI device 10de:00d1 (nVidia Corporation)
Fast Writes:     Supported
SBA:             Supported
AGP Rates:       8x 4x
Registers:       0x1f00421b:0x00000312
bash-3.1$ cat /proc/driver/nvidia/agp/status
Status:          Enabled
Driver:          AGPGART
AGP Rate:        8x
Fast Writes:     Enabled
SBA:             Enabled
However, if i check my dmesg i get

Code:
AGP: Found AGPv3 capable device at 0:0:0
AGP: Found AGPv3 capable device at 2:0:0
AGP: Enough AGPv3 devices found, setting up...
AGP: Setting up AGPv3 capable device at 0:0:0
AGP: Putting device into 4x mode
AGP: Setting up AGPv3 capable device at 2:0:0
AGP: Putting device into 4x mode
Using slackware 11, 2.4.33 kernel, 1.0-9755 drivers, 6800GS, nforce3 board
Protex is offline   Reply With Quote
Old 03-12-07, 11:48 AM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: 8x card stuck in 4x mode?

http://www.nvnews.net/vbulletin/showthread.php?t=46678
netllama is offline   Reply With Quote
Old 03-12-07, 12:02 PM   #3
Protex
Registered User
 
Join Date: Apr 2004
Posts: 3
Default Re: 8x card stuck in 4x mode?

Sorry netllama, I thought I had provided enough relevant information to get a clear answer. Here is the log.
So can you tell me if I am running in agp 4x or agp 8x? And if I am running in agp 4x can you point me in the right direction to force it to agp 8x?
Attached Files
File Type: log nvidia-bug-report.log (88.5 KB, 112 views)
Protex is offline   Reply With Quote
Old 03-12-07, 12:12 PM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: 8x card stuck in 4x mode?

From your bug report, the NVIDIA driver is detecting an 8x AGP rate, yet your AGP driver is putting the device into 4x:
AGP: Putting device into 4x mode

This looks like it might be an AGP driver bug, or perhaps the AGP driver is intentionally setting 4x to workaround some other problem. I'd suggest verifying that you're using the latest motherboard BIOS and also to test with a much more recent kernel.

thanks,
Lonni
netllama is offline   Reply With Quote
Old 03-12-07, 09:04 PM   #5
Protex
Registered User
 
Join Date: Apr 2004
Posts: 3
Default Re: 8x card stuck in 4x mode?

I think agpgart just has a typo when reporting to dmesg. I tried the NvAGP driver and i still get
Code:
bash-3.1$ cat /proc/driver/nvidia/agp/status
Status:          Enabled
Driver:          NVIDIA
AGP Rate:        8x
Fast Writes:     Enabled
SBA:             Enabled
bash-3.1$
Yes, i should try another kernel but I don't want to compile one if I don't have to.

Thanks for the help
Protex is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
320.17 can't detect video modes on Lenovo laptop tadawson NVIDIA Linux 13 07-14-12 02:40 AM
Very slow X startup Jeremy NVIDIA Linux 96 05-23-03 11:11 AM
Error messages... HELP!!!! Imperito NVIDIA Linux 3 09-24-02 11:46 PM
Nvidia GF4 MX 440 + Mandrake tomchristopher NVIDIA Linux 3 08-18-02 10:42 AM
nVidia drivers + Red Hat Linux 7.3 Error404 NVIDIA Linux 17 08-16-02 12:34 PM

All times are GMT -5. The time now is 06:57 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.