Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-13-07, 12:06 PM   #1
Chu
Registered User
 
Join Date: Mar 2007
Posts: 2
Default Fail to enable Compiz/Beryl on: GeForce4 4200 - NVidia 1.0.9631 - FC6 2.6.19-1.2911

Hi all,

I am not able to enable the Desktop effects on my Dell Inspiron 8500 with Geforece4 4200 Go card (64M). I did successfully installed the drive 1.0.9631 (as required for this card -1.0.96xx) with the "**.run" + "nvida-xconfig" files and NVIDIA X Sever settings window tells me the GLX direct rendering is YES. But I just can't start Compiz or Beryl. Any idea? I am running FC6 latest kernel 2.6.19-1.2911.6.5.

Thanks ahead, for your help.
Chu is offline   Reply With Quote
Old 03-13-07, 02:09 PM   #2
macemoneta
Registered User
 
macemoneta's Avatar
 
Join Date: Oct 2002
Location: NJ
Posts: 159
Default Re: Fail to enable Compiz/Beryl on: GeForce4 4200 - NVidia 1.0.9631 - FC6 2.6.19-1.29

Check your /etc/X11/xorg.conf for these entries:

Code:
Section "Extensions"
        Option      "Composite" "Enable"
EndSection
If missing, add them.
macemoneta is offline   Reply With Quote
Old 03-13-07, 02:20 PM   #3
lightman
Registered User
 
lightman's Avatar
 
Join Date: Jun 2004
Posts: 1,026
Send a message via ICQ to lightman
Default Re: Fail to enable Compiz/Beryl on: GeForce4 4200 - NVidia 1.0.9631 - FC6 2.6.19-1.2911

Not only that entry.

Check out you're not loading dri, and that you're loading the correct (that is, the NVIDIA one) glx module.

Then, under the Device section, check that it has the following options :

Code:
    Option         "RenderAccel" "true"
    Option         "AllowGLXWithComposite" "true"
And, under the Screen section, look for :

Code:
    Option         "AddARGBGLXVisuals" "True"
    Option         "DisableGLXRootClipping" "true"
lightman is offline   Reply With Quote
Old 03-13-07, 09:51 PM   #4
Chu
Registered User
 
Join Date: Mar 2007
Posts: 2
Default Re: Fail to enable Compiz/Beryl on: GeForce4 4200 - NVidia 1.0.9631 - FC6 2.6.19-1.29

Thanks guys.

But it still is not working. This is my complete xorg.conf file. Anything else needs to change.

Thanks again.

Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (root@localhost.localdomain)  Fri Dec  8 11:45:29 EST 2006

# Xorg configuration created by system-config-display

Section "ServerLayout"
    Identifier     "single head configuration"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Synaptics" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
    Load           "glx"
EndSection

Section "InputDevice"
    Identifier     "Keyboard0"
    Driver         "kbd"
    Option         "XkbModel" "pc105"
    Option         "XkbLayout" "us"
EndSection

Section "InputDevice"
    Identifier     "Synaptics"
    Driver         "synaptics"
    Option         "Device" "/dev/input/mice"
    Option         "Protocol" "auto-dev"
    Option         "Emulate3Buttons" "yes"
    Option         "LeftEdge" "120"
    Option         "RightEdge" "830"
    Option         "TopEdge" "120"
    Option         "BottomEdge" "650"
    Option         "FingerLow" "14"
    Option         "FingerHigh" "15"
    Option         "MaxTapMove" "110"
    Option         "VertScrollDelta" "20"
    Option         "HorizScrollDelta" "20"
    Option         "MinSpeed" "0.3"
    Option         "MaxSpeed" "0.75"
EndSection

Section "Monitor"

 ### Comment all HorizSync and VertSync values to use DDC:
    Identifier     "Monitor0"
    ModelName      "LCD Panel 1680x1050"
    HorizSync       31.5 - 90.0
    VertRefresh     59.9 - 60.1
    Option         "dpms"
EndSection

Section "Device"
    Identifier     "Videocard0"
    Driver         "nvidia"
    Option         "RenderAccel" "True"
    Option         "AllowGLXWithComposite" "True"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Videocard0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Viewport    0 0
        Depth       24
    EndSubSection
    Option         "AddARGBGLXVisuals" "True"
    Option         "DisableGLXRootClipping" "True"
EndSection

Section "Extensions"
        Option  "Composite" "Enable"
EndSection
Chu is offline   Reply With Quote
Old 03-14-07, 12:25 PM   #5
lightman
Registered User
 
lightman's Avatar
 
Join Date: Jun 2004
Posts: 1,026
Send a message via ICQ to lightman
Default Re: Fail to enable Compiz/Beryl on: GeForce4 4200 - NVidia 1.0.9631 - FC6 2.6.19-1.2911

Check that your kernel-devel release (and architecture) matches you running kernel. Just happened to me on a fresh install of FC6 64bit...
lightman is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:38 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.