Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-09-07, 06:25 AM   #1
Nilith
Registered User
 
Join Date: May 2007
Posts: 18
Default Triplehead PCIe (TwinView) + PCI (Mono-Xinerama): No 3D accelration

Hi,

i've recently acquired a triplehead setup, as follows:

Code:
05:00.0 VGA compatible controller: nVidia Corporation G70 [GeForce 7600 GT] (rev a1)
* 1x Widescreen 1920x1200 connected to DVI
* 1x Widescreen 1680x1050 connected to VGA
01:07.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5500] (rev a1)
* 1x Widescreen 1680x150 connected to VGA
All runs fine, except 3d acceleration:
Code:
7 ~$ glxgears
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  78 (X_CreateColormap)
  Serial number of failed request:  12
  Current serial number in output stream:  18
8 ~$
If I disable the second X screen (5500), 3D works fine, on twinview only.

Running the latest linux drivers, 9755.

I tried various MetaMode Settings et al, none made a difference.
Attached Files
File Type: log xorg.log (37.4 KB, 83 views)
File Type: log xorg.conf.log (2.8 KB, 85 views)
Nilith is offline   Reply With Quote
Old 05-09-07, 10:21 AM   #2
Nilith
Registered User
 
Join Date: May 2007
Posts: 18
Default Re: Triplehead PCIe (TwinView) + PCI (Mono-Xinerama): No 3D accelration

Update:

Running the 7600 in Twinview configuration, and running the 5500 as a separate X Server (w/o Xinerama, that is) works like a charm; but I'd rather have Xinerama and no 3D on the secondary card.
Nilith is offline   Reply With Quote
Old 05-09-07, 10:45 AM   #3
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Triplehead PCIe (TwinView) + PCI (Mono-Xinerama): No 3D accelration

This is expected behavior. You cannot mix GPU families with Xinerama and get OpenGL acceleration across the entire desktop.
netllama is offline   Reply With Quote
Old 05-10-07, 02:57 AM   #4
Nilith
Registered User
 
Join Date: May 2007
Posts: 18
Default Re: Triplehead PCIe (TwinView) + PCI (Mono-Xinerama): No 3D accelration

Quote:
Originally Posted by netllama
This is expected behavior. You cannot mix GPU families with Xinerama and get OpenGL acceleration across the entire desktop.
Yes, I expected as much when buying the 5500.

But can't I have OGL on at least the physical screens that the 7600 drives? I don't care about the 5500.

The solution I have now is workable, but a tad annoying. (Can't move windows between X screens, et al).

The problem is I don't get any 3D accel at all when using xinerama.
Nilith is offline   Reply With Quote
Old 05-10-07, 10:28 AM   #5
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Triplehead PCIe (TwinView) + PCI (Mono-Xinerama): No 3D accelration

No, I'm afraid that its not a supported configuration.
netllama is offline   Reply With Quote
Old 05-10-07, 12:02 PM   #6
Nilith
Registered User
 
Join Date: May 2007
Posts: 18
Default Re: Triplehead PCIe (TwinView) + PCI (Mono-Xinerama): No 3D accelration

Problem solved. Got another 7600GT for SLI mode. Ahwell ..
Nilith is offline   Reply With Quote
Old 05-21-07, 11:42 AM   #7
d_u_s_t
Registered User
 
Join Date: Sep 2006
Location: Berlin
Posts: 18
Angry Re: Triplehead PCIe (TwinView) + PCI (Mono-Xinerama): No 3D accelration

Appendix-v.html (Support for GLX in Xinerama) of you driver package says:

Quote:
It is recommended to use identical GPUs. Some combinations of non-identical, but similar, GPUs are supported. If a GPU is incompatible with the rest of a Xinerama desktop then no OpenGL rendering will appear on the screens driven by that GPU. Rendering will still appear normally on screens connected to other supported GPUs. In this situation the X log file will include a message of the form:

(WW) NVIDIA(2): The GPU driving screen 2 is incompatible with the rest of
(WW) NVIDIA(2): the GPUs composing the desktop. OpenGL rendering will
(WW) NVIDIA(2): be disabled on screen 2.
I have the same problem as mentioned above. Combination of a PCIe 7600GT (two TFTs) and an old PCI FX 5200 (for TV-out) with 9755. I don't want to replace my motherboard and buy another PCIe card to get Opengl back!

There are two questions:
  1. If the GPUs are incompatible why don't we get any messages like the one in the quote and why isn't opengl just disabled on the second head and works on the first head without any problems?
  2. Is there any way to manually disable OpenGL for a specific nvidia gpu/screen (a secret evil xorg.conf-option)? If not: Can we expect such an option in future releases?

Thanks!
d_u_s_t is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help to get the X to work on my Acer TravelMate 630 knchee NVIDIA Linux 16 09-19-02 10:16 PM

All times are GMT -5. The time now is 02:24 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.