Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-28-07, 02:10 PM   #1
MCMcButtah
Registered User
 
Join Date: Feb 2007
Posts: 26
Default Beryl slow video, screen saver, unreal touranament problem

I am using the 9746 nvidia drivers, kubuntu with a 2.6.20-5 kernel and the latest
beryl 2.0 SVN and am having the following problems...

If I select XVMC in mythtv for my prefered playback I get a black screen with occassional garbage video displayed. If I choose the standard decoder option video looks good but it is on the slow side, especially during camera pans it is stitchy. Selecting either XVMC or standard with the normal KDE window manager being selected instead of beryl video plays smoothly.

OpenGL screensavers do not work and just give a black screen when selecting
NVIDIA for rendering beryl. If I choose AIGLX the screensavers work fine. Is there any advantage to choosing nvidia?

Unreal tournament 2004 is choppy and stitchy when using beryl, very smooth using the standard KDE window manager.

Other than those issue everything else responds quickly and works very well.
Thanks for any help.
MCMcButtah is offline   Reply With Quote
Old 03-23-07, 04:20 PM   #2
Vash63
Registered User
 
Join Date: Mar 2007
Posts: 8
Default Re: Beryl slow video, screen saver, unreal touranament problem

I'm on Gentoo with Beryl, 9755 Nvidia drivers. I'm getting the exact same issue with the GL screensavers, but that doesn't bother me that much. What does bother me is that I'm having issues with getting mplayer to work full screen, says my CPU is too slow (While I can have the video take up more than a screen length in windowed mode with no issue). I have a pretty powerful system so I doubt that's the issue, and I've tried multiple vid renderers in mplayer all with the same problem. Goes away entirely if I switch to KWin.
Vash63 is offline   Reply With Quote
Old 03-23-07, 04:33 PM   #3
MCMcButtah
Registered User
 
Join Date: Feb 2007
Posts: 26
Default Re: Beryl slow video, screen saver, unreal touranament problem

That is interesting that your video plays well when it is windowed, but not when it is fullscreen. For me the video is kinda slow regardless of if it is fullscreen, windowed, a small low quality file, or a HD feed. My cpu ( Core 2 6400) is also never over 30% utilization even while the video is slow.

Can you maybe give me an idea of some of the config settings you are using?

I have just posted a similiar thread to this one ( because I thaught this thread was dead ) and I will post my configs there this evening.
MCMcButtah is offline   Reply With Quote
Old 03-23-07, 04:37 PM   #4
Vash63
Registered User
 
Join Date: Mar 2007
Posts: 8
Default Re: Beryl slow video, screen saver, unreal touranament problem

With mplayer I've tried everything, usually use xv or gl2 with postprocessing, but even without that I get this issue. In xorg.config I have AddARGBGLXVisuals, RenderAccel, AllowGLXWithComposite and backingstore all set to true. Of course using the nvidia driver, not AIGLX.
Vash63 is offline   Reply With Quote
Old 03-23-07, 04:53 PM   #5
MCMcButtah
Registered User
 
Join Date: Feb 2007
Posts: 26
Default Re: Beryl slow video, screen saver, unreal touranament problem

See the thread titled 'Anyone get smooth video playback with beryl? Is it possible?' that I started earlier.

Sorry for the double post, but I thaught this one was dead as it hadn't been responded to in a month, then the second I create the new thread you replied

In any case user piotrq__ replied with this info:

My config is MUCH slower (in theory ;-) ) than yours, I've got aDuron o/ced to 1800, GF 6800XT and 512 RAM. Video playback is super-smooth for me, I'm using MPlayer from svn and an svn Beryl with latest nvidia driver, and I'm using default -vo xv as my video output driver. I can even apply post-procssing effects via Beryl such as blur, transparency, inverted colours and stuff, wobble the window around, minimize/maximize and the playback will remain just as smooth as without it.



So it seems that our problem is a configuration issue and can be solved.
MCMcButtah is offline   Reply With Quote
Old 03-24-07, 03:45 AM   #6
Vash63
Registered User
 
Join Date: Mar 2007
Posts: 8
Default Re: Beryl slow video, screen saver, unreal touranament problem

I fixed it by removing the blur plugin in Beryl. I can turn postprocessing and everything fully up now with no framedrops and low CPU usage, so it seems that was the entire problem.
Vash63 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Stubborn screen res problem Alpsoandso NVIDIA Linux 6 05-03-12 07:00 PM

All times are GMT -5. The time now is 04:05 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.