Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-24-07, 09:14 PM   #1
mjbjr
Registered User
 
Join Date: Mar 2007
Posts: 8
Default X wont start with 'glx'

The subject pretty much says it all, if my /etc/X11/xorg.conf file
contains:

Load "glx"

(and no 'Load "dri"', or GLcore... btw, 'dri' seems to work fine (no objections))

The xorg X server will not start, though glx seems to be loaded fine,
there does seem to be a possible conflict in the log:

(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture

------
xorg: xorg-x11-7.1
video card: GeForce 7800 GSOC
kernel: 2.6.17-gentoo-r8y #1 SMP PREEMPT
nvidia-drivers: 1.0.9755-r1
gcc: 3.3.4 20040623 (Gentoo Linux 3.3.4-r1, ssp-3.3.2-2, pie-8.7.6)


I've spent considerable time searching the net and tried many possible
solutions, but have yet to find one that works for me. I hope you can help.

Thank you for your time.
Attached Files
File Type: zip nvidia-bug-report.zip (20.5 KB, 111 views)
File Type: zip xorg_glx_conf.zip (4.9 KB, 96 views)
File Type: zip xorg_glx_log.zip (4.3 KB, 112 views)
mjbjr is offline   Reply With Quote
Old 03-24-07, 11:00 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: X wont start with 'glx'

Does this problem persist if you install the official NVIDIA driver package?
netllama is offline   Reply With Quote
Old 03-25-07, 02:36 AM   #3
mjbjr
Registered User
 
Join Date: Mar 2007
Posts: 8
Default Re: X wont start with 'glx'

Quote:
Originally Posted by netllama
Does this problem persist if you install the official NVIDIA driver package?
Yes, and with the same errors.
mjbjr is offline   Reply With Quote
Old 03-25-07, 10:34 PM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: X wont start with 'glx'

I'd like to see a bug report against the official driver package.
netllama is offline   Reply With Quote
Old 03-27-07, 01:39 AM   #5
mjbjr
Registered User
 
Join Date: Mar 2007
Posts: 8
Default Re: X wont start with 'glx'

Quote:
Originally Posted by netllama
I'd like to see a bug report against the official driver package.
First, thank you for your time chasing this down. I appreciate it.

As requested, the attached files are for an nvidia-drivers install using the
driver from the nvidia site. I removed the previous driver install from my gentoo
box using 'emerge -C nvidia-drivers'.
Attached Files
File Type: zip Xorg_glx.0.log.zip (12.2 KB, 93 views)
File Type: zip nvidia_glx-bug-report.log.zip (27.2 KB, 105 views)
File Type: zip nvidia_glx-installer.log.zip (5.1 KB, 97 views)
mjbjr is offline   Reply With Quote
Old 03-27-07, 10:23 AM   #6
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: X wont start with 'glx'

If you reinstall the driver with the --force-tls=new option, does that have any impact?

thanks,
Lonni
netllama is offline   Reply With Quote
Old 03-27-07, 02:23 PM   #7
mjbjr
Registered User
 
Join Date: Mar 2007
Posts: 8
Default Re: X wont start with 'glx'

Quote:
Originally Posted by netllama
If you reinstall the driver with the --force-tls=new option, does that have any impact?

thanks,
Lonni
I assume you mean:

sh NVIDIA-Linux-x86-1.0-9755-pkg1.run --force-tls=new

gives the same results (same xorg.conf w/glx and no dri).

--------
In this particular thread of the problem, I started clean and haven't tried
anything other than what I've been told to do. In the past month I've
tried to get glx working, trying tons of stuff, including the 'tls' thing, and...

in looking at my notes, I saw the 'eselect' thing, so, after the above failure:

# eselect opengl show
xorg-x11

# eselect set opengl nvidia
!!! Error: can't load module set
Killed

Now, that I've commented out 'Load "glx"' and am running from Xorg...

# lsmod | grep -i nv
nvidia 6832884 16
i2c_core 18432 4 nvidia,asb100,eeprom,i2c_i801

Again, thanks for your time.
Attached Files
File Type: zip Xorg_glx_tls.0.log.zip (12.2 KB, 105 views)
File Type: zip nvidia_glx_tls-bug-report.log.zip (26.6 KB, 104 views)
mjbjr is offline   Reply With Quote
Old 04-04-07, 11:45 AM   #8
OpenUser
Registered User
 
Join Date: Apr 2007
Posts: 1
Default Re: X wont start with 'glx'

Quote:
Originally Posted by mjbjr
# lsmod | grep -i nv
nvidia 6832884 16
i2c_core 18432 4 nvidia,asb100,eeprom,i2c_i801
Maybe this link will help you somehow:

http://www.nvnews.net/vbulletin/showthread.php?t=77613

I'm not sure, but some people seem to encounter problems with the eeprom module...
OpenUser is offline   Reply With Quote

Old 04-06-07, 06:11 AM   #9
masterminds
Registered User
 
Join Date: Apr 2007
Posts: 1
Smile Re: X wont start with 'glx'

This was the problem for me too..

And I fixed it with Gentoo Wiki - "HOWTO nVidia Drivers".


Quote:
Error: libnvidia-tls.so.1: cannot handle TLS data

After re-emerging several times the nvidia drivers, it may happen that the glx module fails to load without any apparent reason, with the error "libnvidia-tls.so.1: cannot handle TLS data". This issue is caused by two files being inverted, /usr/lib/opengl/nvidia/tls/libnvidia-tls.so.1.0.8762 and /usr/lib/opengl/nvidia/no-tls/libnvidia-tls.so.1.0.8762. The fix is quite simple: swap the two files. Before trying this, check to see if the libnvidia-tls.so.1.0.8762 file in the no-tls folder is smaller than the one in the tls folder. If it is the case, then the files are already in the correct folder, so do not swap them. If it is not the case, then you can swap them with this command:


Code: Command to swap inverted files

Code:
mv /usr/lib/opengl/nvidia/tls/libnvidia-tls.so.1.0.8762
Code:
/usr/lib/opengl/nvidia/tls/libnvidia-tls.so.1.0.8762.bak && mv
Code:
/usr/lib/opengl/nvidia/no-tls/libnvidia-tls.so.1.0.8762
Code:
/usr/lib/opengl/nvidia/tls/libnvidia-tls.so.1.0.8762 && mv
Code:
/usr/lib/opengl/nvidia/tls/libnvidia-tls.so.1.0.8762.bak
Code:
/usr/lib/opengl/nvidia/no-tls/libnvidia-tls.so.1.0.8762
Restart X and the glx module should load fine, this time. If not, update your glibc!

Good Luck!
masterminds is offline   Reply With Quote
Old 04-08-07, 11:23 PM   #10
mjbjr
Registered User
 
Join Date: Mar 2007
Posts: 8
Default Re: X wont start with 'glx'

Quote:
Originally Posted by OpenUser
Maybe this link will help you somehow:

http://www.nvnews.net/vbulletin/showthread.php?t=77613

I'm not sure, but some people seem to encounter problems with the eeprom module...
Thank you for the suggestion. I intend to try it out, rsn.
mjbjr is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Microsoft explained why they killed start button AthlonXP1800 Microsoft Windows 8 19 10-28-12 09:07 AM
Base mosaic and rotation? happyfunbot NVIDIA Linux 5 07-13-12 12:23 PM
173.14.34 -- Xorg 1.12.1 & 1.11.4, glx module fails to load mereset NVIDIA Linux 17 06-10-12 01:24 AM
Glx mrbig1344 NVIDIA Linux 7 09-30-02 06:45 AM
Remote Accelerated GLX and Raster Display Oddity dzzero NVIDIA Linux 2 09-18-02 01:59 PM

All times are GMT -5. The time now is 01:37 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.